I can no longer send mail, only receive. Exchange 2007, Outlook 2007 and iPhone 5. Cannot connect to outgoing smtp. It's worked for nearly 2 years and now, nothing. Nothing changed on my end.

I connect to a secondary e-mail address using POP/SMTP to my Exch. 2007 through outlook 2007 and iphone 5.  It has worked flawlessly for nearly 2 years.  Now, for some reason, it has stopped working on both.  I have not changed anything on the exchange server.  

However, if I'm within my work wifi...it works as always.  If I turn wifi off on my phone...does not work.
bob_wrightAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
The information you included lacks any detail.
Saying you made no changes, would suggest that your IP might have changed.  Your Exchange server is configured to send through a server that might no longer exist.  Look at the outgoing SMTP logs to get an understanding on what is going on.  If logging not enabled, enable it and see what it reports. Send an email into the exchange and see what it tries to do.

Use whatismyip.com from the exchange.
What SMTP server do you have configured?
0
Joseph NyaemaIT ConsultantCommented:
What I think is that your external SMTP service configuration has changed.
are you able to ping the public IP of your SMTP service.
If you are using a fully qualified domain name, are you able to ping the FQDN? What IP is returned? Is this your public IP.

Are you able to telnet into your SMTP service Public IP and port.
e.g telnet xxx.xxx.xxx.xxx 25
or telnet mail.smtpdomain.com 25

or use SMTP Diagnostics  if using default smtp port 25

Results to this test will hopefully tell us where the problem is.
0
bob_wrightAuthor Commented:
Thanks for the comments.  I actually checked the log of my sonicwall firewall and saw that the SMTP request was being dropped due to an RBL listing.  It subscribes to two well-known RBL services and I don't see ANY listing.  But, when I disable RBL on the firewall, the SMTP call goes through and e-mail flows again.  The firewall RBL is a secondary protection...so this suffices for now.
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

joinaunionCommented:
You can test your exchange setup here, https://testconnectivity.microsoft.com/

Your phone is setup like this?
http://support.apple.com/kb/ht2480
0
arnoldCommented:
which RBL lists?

You should setup 465 or 587 (off port not encrypted) and configure your iphone to use these ports. presumaly the SMTP session requires authenticatuon.  the non 25 ports will eliminate the RBL check for your devices/users.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bob_wrightAuthor Commented:
That's great advise, and makes sense.  Thank you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.