[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 500
  • Last Modified:

firefox showing chinese for microsoft support

Whenever I go to a MS SUPPORT site (not community or technet or general MS sites, just support) like this one http://support.microsoft.com/kb/2917500 I get chinese looking characters (see screenshot). This is in firefox--if I use IE on the same PC it displays in English for the exact same link. Saw online that Real player may be a cause so I removed real player but issue persists. have also disabled and/or removed most of my Firefox add-ons and extensions but that did not help.
EE-Firefox-in-Chinese.jpg
EE-IE-in-English.jpg
0
Lionel MM
Asked:
Lionel MM
  • 11
  • 7
  • 5
  • +3
7 Solutions
 
aadihCommented:
That is an encoding problem.

It looks like you have set an UTF-16 encoding. Change it to a Western encoding (in FF).
0
 
duncanb7Commented:
go to  Firefox browser, there is Firefox icon at the corner around  on most left and most top , and click

Web Developer->Character Encoding->Auto-Detect

Hope understand your question completely.If not , please point it out

Duncan
0
 
Lionel MMSmall Business IT ConsultantAuthor Commented:
UTF-16 encoding. Change it to a Western encoding (in FF)
Where

Firefox icon at the corner around  on most left and most top
Can't find that
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
aadihCommented:
[Not knowing your FF version:] Please follow the 'picture" described at the bottom-most post at:

https://support.mozilla.org/en-US/questions/997257 >
0
 
duncanb7Commented:
The pticure you sent seems is from IE. make sure you are
running  FF. There is a lot options, try or search around

Could you open Firefox browser If you don't have it , just download it


Duncan
0
 
duncanb7Commented:
it is at View icon in between  (File, Edit, View, History, Bookmark, Tools, Help)
Please take a look at the image for the exact location
https://lh6.googleusercontent.com/-UOPdzoOYFfg/UzUyJ-FBHJI/AAAAAAAABDA/sc0wR2BVlhw/s0/ff-universal-none.png

Duncan
0
 
Lionel MMSmall Business IT ConsultantAuthor Commented:
https://support.mozilla.org/en-US/questions/997257
Tried this link--page was setup properly as indicated--tried the MS link again--still chinese

duncanb7 -- there are 2 pictures--one FF one IE; did you look at both pictues--one shows english the other chinese?
0
 
duncanb7Commented:
anyway, just go to FF, click around

Web Developer->Character Encoding->Auto-Detect

I tried my FF that is okay
0
 
Lionel MMSmall Business IT ConsultantAuthor Commented:
Tried View, Character Encoding, and Western -- no change
Went back to View, Character Encoding, and Unicode -- no change
0
 
duncanb7Commented:
How about auto-detect (on not off), just try around other setting if have time
0
 
Lionel MMSmall Business IT ConsultantAuthor Commented:
On my FF my auto detect is OFF and the other options are (see picture)
EE-Firefox-Auto-Detect.jpg
0
 
duncanb7Commented:
How about uninstall FF and re-install FF to update version
0
 
Lionel MMSmall Business IT ConsultantAuthor Commented:
I have already uninstalled FF and I have gone to earlier versions and still the problem persists. I have been on the latest version too and still no luck.
0
 
duncanb7Commented:
you might put Chinese Lanuage stuff  at

Tools->options->Contents->Choose Lanuage(similar to the following image link)

Remove other Lanauge besides English or the language you want
and restart FF

https://support.mozilla.org/en-US/kb/settings-fonts-languages-and-pop-ups#w_content-settings
0
 
Lionel MMSmall Business IT ConsultantAuthor Commented:
thanks but I had already checked that settings (see picture)
EE-Firefox-Lanuguages.jpg
0
 
LeeTutorretiredCommented:
I've requested that this question be deleted for the following reason:

The question has either no comments or not enough useful information to be called an "answer".
0
 
BillDLCommented:
You have a Hong Kong email address, so it is fair to assume that you live there and use a Hong Kong-based ISP.  The Microsoft site will be checking your IP Address and determining that you are in Hong Kong, and that it would therefore be normal for you to be shown in Simplified Chinese (language code ZH-CN).

Once you are on a page in a particular language translation most or all the links will be to pages or files in that language.  You will see that the links to the security advisory is:
http://technet.microsoft.com/zh-cn/security/advisory/2916652
and the download "Rvkroots.exe" link is:
http://www.microsoft.com/zh-cn/download/details.aspx?id=41542

The quick, but probably just temporary, workaround is as follows from that page:
The Chinese text means "Article Translations" and it opens a new paneChoose US EnglishThe URL in the Address Bar should now be showing:
http://support.microsoft.com/kb/2917500/en-us
and all links thereafter should assume that you want the English versions.

If you had arrived at the same page in some other language and had changed it to ZH-CN
Look in the Status Bar down below when hanging the mouse over the linkthe URL in the Address Bar would have been:
http://support.microsoft.com/kb/2917500/zh-cn

Check out the following setting to see whether the Microsoft Support site loads the English pages once changed:
Firefox: Tools menu > Options > Content tab.  Languages section > Click "Choose"Delete unwanted languages and set your preferred one at the top
For those people who aren't seeing the Menu Bar in Firefox, and therefore aren't seeing the "Tools" menu, follow these steps to show it:
FF-Show-Menu-Bar-01.jpg
FF-Show-Menu-Bar-02.jpg
0
 
BillDLCommented:
Sorry if I repeated some of the steps that had already been suggested.  The problerm is that I cannot edit my comment because it has several images in it and Experts-Exchange hasn't yet fixed this bug.
0
 
Lionel MMSmall Business IT ConsultantAuthor Commented:
I am in Tampa, FL and my ISP is based in ST. Pete FL (Brighthouse). When I look up my IP it shows it is in Tampa; my MS email address is at least 20 years old--it is a MSN account and I have never had this problem. PLUS when I use Internet Explorer I do not have this issue--same PC, same ISP, everything the same except when using Firefox I get Chinese. I used the one suggestion you gave and now I can at least see English in the text but there is still lots of Chinese characters on the page. Further this is a fairly new development, about 2 to 3 months now--I think after a Firefox update. I did try to go back to an earlier version but that did not help.
0
 
BillDLCommented:
I'm sorry, I was looking at duncanb7's profile in error when I saw the yahoo.hk email address.

Something is obviously badly screwed up if you are still seeing loads of Chinese after loading the English page, eg. http://support.microsoft.com/kb/2917500/en-us

How do your settings compare with mine in this dialog:
Tools > Options > Content tab > Fonts and Colors section:
Default Font = Times New Roman size 16
Click "Advanced" button:
.
Try temporarily disabling all your Add-Ons, restart Firefox, and test.
Tools menu > Add-Ons > Extensions > use the "Disable" buttons.

I assume you have tried deleting your browser cache?
History menu > Clear Recent History > Time Range = "Everything", tick all boxes > Clear Now.
0
 
Lionel MMSmall Business IT ConsultantAuthor Commented:
I did disable all ad-on and extensions--where possible I removed them. I did try removing all history when this first started and then again about 2 weeks ago. See picture--my setting are exactly the same as yours
ee-FF-Fonts.jpg
0
 
RobOwner (Aidellio)Commented:
Hi Lionelmm,

So you can confirm that you've deleted all history and cookies (on the privacy tab)?

Kb article on how to do that as you are usually directed to localised versions if the website because if this content.
https://support.mozilla.org/en-US/kb/remove-recent-browsing-search-and-download-history
0
 
Lionel MMSmall Business IT ConsultantAuthor Commented:
I did try removing all history when this first started and then again about 2 weeks ago-no luck
0
 
BillDLCommented:
I'm sorry lionelmm.  I am as stumped as you are at the moment.  I have tried to replicate the issue by changing all manner of settings and then visiting the same page, but I can't.
0
 
Lionel MMSmall Business IT ConsultantAuthor Commented:
OK I have it fixed--I re-did all most of the recommendations--I uninstalled firefox. I had a version 3.6 that I installed. I then checked the language settings, I then checked all the add-ons and extensions (there were very few but disabled some), then I closed firefox and went to the users folder and deleted the mozilla\firefox\profile directory, started firefox back up and re-ran delete history--went to MS support and now I see English everywhere so thanks for all the suggestions--they helped in total--thank you.
0
 
aadihCommented:
Great.  :-)
0
 
Lionel MMSmall Business IT ConsultantAuthor Commented:
Thanks for all your time and efforts--appreciate it.
0
 
BillDLCommented:
Thank you lionelmm
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 11
  • 7
  • 5
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now