Running sudo dpkg --configure -a returns >. Now what?

After a failed install of mysql I attempted to run another sudo apt-get. Ubuntu returns:

dpkg package was interrupted, you must manually run sudo dpkg --configure -a to correct the problem.

When I run sudo dpkg --configure -a It returns a single > on the next line. Now what am I supposed to do?

Thanks in advance for your help.
Robert FrancisDirector of Continuous ImprovementAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

serialbandCommented:
Maybe try this:

sudo dpkg-reconfigure -a

Otherwise, try removing the mysql package and run apt-get install again

apt-get remove mysql
apt-get clean
apt-get install


If that's not working, try the following:
sudo dpkg deinstall mysql
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
xeroxzeroxCommented:
Some simple install mysql you need to run below command.
First update the repository.
# apt-get update
#tasksel
and choose Lamp server.Once it done restart mysql service and connect mysql.

If you face any issue.Please write down here.
0
Robert FrancisDirector of Continuous ImprovementAuthor Commented:
When I tried this: sudo dpkg-reconfigure -a
This was returned: libc-bin is broken or not fully installed

When I tried this: apt-get update
This was returned:
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock administrative directory (/var/lib/dpkg/), are you root?
0
serialbandCommented:
It seems that an apt-get process is either still running or failed during the update and kept the lock file.

You should first run

ps -ef | grep apt
ps -ef |grep dpkg


to make sure that it's not still running.  If it is, then you may have to kill the process id(s).  Killing the process should remove the lock file if it's running.  If it's not running, then remove the lock files, because the processes crashed and left them behind.

rm /var/lib/apt/lists/lock /var/lib/dpkg/lock


Then run

apt-get clean all


Once you've cleared it out, then fix any updates.
apt-get update
apt-get upgrade
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.