Changing read/write permissions on NAS public share

I recently began using my NAS again after a period of two years and found that I can't write to the public share.  Pulling up the console at the NAS' IP address allows me to change its settings but I can't find either public or admin listed as shares.  I created another share, set the permissions and was able to read and write to the new share just fine.  I created a shortcut on my desktop to pull up the public share (\\NAS2TB\Public) and it opens just fine but when right-clicking on the folder to bring up properties and then the security tab, I am not allowed to change permissions.  I would appreciate some help with this as I have 500GB sitting in the public folder in a read only state.
ermooneyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
you have to login to the admin interface probably web based and from there set the permissions if you can't remember the web admin password and username then you have to copy what you can off of it and then reset it to factory defaults.   You didn't say which NAS it is there are thousands of different typtes. NAS is a generic term
0
ermooneyAuthor Commented:
Hi,  My NAS is a MASSCOOL 390UES2R.  It contains 2- 2TB drives set in RAID 1.  I can get into the web-based admin interface just fine.  I can see two shares: Admin/Mooneye-14 and Eric  and change their ID and log in profiles.  Just two days ago, I set up the "Eric" share so that I was able to copy all of my data and "RAW" (uninstalled) installation files to it.  I can read and write to the shares that I can see through web admin since I can change their permissions just fine.  The disks are formatted to FAT32.  I can't see the Public share listed anywhere and can't read and write to it.  This is the problem that I'm trying to resolve.  The software running on the NAS is called "Mobile Cybernetor External Net Storage.  I'm attaching the setup manual.  Thanks.
0
gheistCommented:
The storage unit is quite old, but OK. I had one namev Vibe Cyebrnetor at home. Public share is populated via USB port and readonly to network.
0
INTRODUCING: WatchGuard's New MFA Solution

WatchGuard is proud to announce the launch of AuthPoint, a powerful, yet simple, Cloud-based MFA service designed to eliminate the vulnerabilities that put your data, systems, and users at risk.

ermooneyAuthor Commented:
Thanks for your response.  I can view the public folder through the network but can't write to it.  There is no USB drive connected to the NAS.  Perhaps I must reformat the drives and have another go unless somebody comes up with a technique to reset the public folder permissions.
0
ermooneyAuthor Commented:
Just to check if I understood you correctly, are you saying that the public folder is populated by attaching a USB drive to the NAS and that the public folder is then read-only through the network?  It's been a couple of years and I don't remember exactly how I set this NAS up.  Thanks.
0
gheistCommented:
No, it is populated by disconnectinf network and connecting NAS to computer as USB flash drive.
0
ermooneyAuthor Commented:
Aha!  Thanks.  I'll try that first thing in the morning.
0
ermooneyAuthor Commented:
I have connected my NAS to my computer and can see three partitions on the NAS under Win 8.1 computer Management - disk management.  The partitions do not have drive letters assigned and my only option is "delete volume."  All other options are grayed out.   I am guessing that the partitions have an XFS file system format.  What to do?  I am trying to access my public folder.  Should I reformat the disk from its console in Fat 32 format?  Thanks.
0
gheistCommented:
Those are your shares....
Can you boot Ubuntu live CD and check in that disk management what partitions you have? Again delete nothing.
I remember it was just one drive letter.
0
ermooneyAuthor Commented:
Hi.  I went ahead and reformatted the drive in FAT 32.  It created an admin folder and a public folder by default.  The admin folder and public folder permissions are not accessible from the NAS console.  I created a new share and am now copying the data back to it from another (USB) drive overnight.  Since the public folder permissions are not available, I am assuming that they are read only, although it appears that I could write some files to it from my computer over the network.  After the copying is done, I will attach the NAS by USB to the computer and see what it looks like.  I believe that either the public folder has read only permissions by default or there was some drive error.  The console does have the capacity to run scandisk, so I'll run it after the copying is done.  Anyway, I'm happy to have reclaimed that 689 GB from the public folder and now have 1.9+TB available on the drive.  I intend to back up to my NAS while I work on transitioning from WHS 2011 to Server 2012 Essentials.  Losing all of my backups is a possibility although the server is automatically backed up to a USB drive and if I unplug it while upgrading, the backups may be safe.  Thanks.
0
gheistCommented:
Maybe you can set permissions from Windows Client?
0
ermooneyAuthor Commented:
Do you mean by right-clicking on the public folder when it is displayed on the computer in file manager (Total Commander for me)?
0
gheistCommented:
In microsoft windows explorer...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ermooneyAuthor Commented:
Thanks again.  As of this morning, only half of the copying back to the NAS is completed to I'll have to let you know the results of the attempt to change permissions later this afternoon or evening..
0
ermooneyAuthor Commented:
Hi.  The copying had finished so I unplugged the NAS from the network and connected it to the computer by USB.  In Total Commander (same function as Windows Explorer,) I right clicked on the Public folder and couldn't enable permissions from that view so I set "Share" on the folder to everyone, then did the same to the share I had recently copied to, Eric.  Next, I unplugged the NAS from USB, shut it down, plugged in the ethernet cable and restarted the drive.  I opened Total Commander and found the drive under its network name (NAS2TB.)  I right clicked on the Public and Eric folders and found that under properties, security,  read/write permissions were not enabled for anyone.  I tried copying a file from the computer's internal drive to the NAS and it worked for both folders.  Next, I tried deleting the file from both folders and that worked too.  I'm not sure why this worked since when connected to the network, the folders don't have any permissions enabled but I am able to read and write to both of them.  Apparently setting the drive's folders to "Share" did the trick.  Thanks for the help.
0
gheistCommented:
So it is the share level permissions like in windows 3.11
0
ermooneyAuthor Commented:
I guess.  The drive reports that it is running under NT 4.9.  I can't remember if that aligns with the time that we were using Windows 3.11 or not.  It seems a little later but the permissions do act the same as those in 3.11.  Thanks again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.