ssh with special character to sqlplus

Hi,

In Linux RHEL 5.6
I'm trying to execute a SQL statement inside Oracle on a remote host.
My query is using the v$parameter and I'm having problems passing the $(dollar sign).

My code:
RESULT=`ssh 10.0.0.3  "setenv ORACLE_SID $PRIMARY_ORACLE_SID; sqlplus -s / as sysdba << EOF
    select value from v$parameter where name='dg_broker_start';
EOF"`
> echo RESULT=$RESULT
 
 RESULT= select value from v where name='dg_broker_start'

I tried "v$parameter"
and      v\$parameter
and    "v\$parameter"

none of the above worked.
Only the V is left...
LVL 1
peledcAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

woolmilkporcCommented:
You'll have to use at least two backslashes for escaping - the $ sign must be protected from being expanded by the local shell as well as from the remote shell.

If two backslasehs don't work either try three of them (at least I once had to do so to make it work).
0
arnoldCommented:
if I'm not mistaken, you may have to use v\\\$
the first will be drawn down to v\$

If this is a common query, why not setup a script on the remote end to which you will be passing data points?
0
woolmilkporcCommented:
Three backslashes are not sufficient for ssh/sqlplus between backticks.

Try  v\\\\\\$parameter

No joke!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
simon3270Commented:
You could also try 1 (or 3) backslashes between the << and the EOF (immediately before the E of EOF).
0
peledcAuthor Commented:
This worked \\\\\\

Thanks...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.