?
Solved

switport access or routed link

Posted on 2014-07-13
11
Medium Priority
?
296 Views
Last Modified: 2014-07-28
I have a Cisco router and a 3750X layer 3 switch. Should I connect them as a routed link or an switchport access vlan1 from the router (see below)
Scenario 1:
Router-----------
interface gig0/0
ip address 10.10.10.1 255.255.255.0
sw--------------
interface gig1/0/1
switchport access vlan 1
switchport mode access
!
interface vlan1
ip address 10.10.10.2 255,255,255,0
!
interface vlan2
ip address 10.10.20.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.10.10.1

Scenario 2:
Router-----------
interface gig0/0
ip address 10.10.100.1 255.255.255.252
sw--------------
interface gig1/0/1
ip address 10.10.100.2 255.255.255.252
!
inteface vlan1
ip address 10.10.10.2 255.255.255.0
!
interface vlan2
ip address 10.10.20.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.10.100.1
0
Comment
Question by:leblanc
  • 4
  • 3
  • 2
  • +1
11 Comments
 
LVL 50

Accepted Solution

by:
Don Johnston earned 800 total points
ID: 40193479
Both of the options you present are (functionally) the same.

So it doesn't matter which one you use.
0
 
LVL 8

Expert Comment

by:Leo
ID: 40193496
Agree with Don, from both of the configs you will achieve the same result, doesn't matter which one you use....
0
 
LVL 1

Author Comment

by:leblanc
ID: 40193556
ok. So in scenario 1, when I ping a device on vlan 2 from the router, Where will the routing occur? The link between the router and the switch only vlan1 subnet traffic. Thx
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 800 total points
ID: 40193563
Because the only device that has interfaces on VLAN 1 and VLAN 2, the switch will perform interVLAN routing.
0
 
LVL 1

Author Comment

by:leblanc
ID: 40193568
That's right. The switch will do intervlan. So you do not need to have a static route from the router because it is directly connected to vlan1. Correct? The reason I ask is because I build a lab on scenarion 1 and I could not ping vlan2 subnet. Thx
0
 
LVL 8

Assisted Solution

by:Leo
Leo earned 400 total points
ID: 40193571
To help clarify you more....
The pc for example in vlan 10 want to talk to server in another vlan say vlan 20 which will be in different subnet will not find server in same subnet and will throw the request to its gateway. Now the request is with 3750 switch and 3750 switch will check its routing table and will see that the server vlan which is vlan 20 is directly connected so it will route the packet to that vlan.

3750 will send an arp request for the server in vlan 20 to which your pc from vlan 10 want to talk to and once the mac address is learned it will reach the server and same way the reply will come back.

You do not need any subinterfaces because 3750 is itself a layer 3 switch will will handle routing between the vlans.
0
 
LVL 8

Expert Comment

by:Leo
ID: 40193572
Try enabling ip routing on the 3750 and add each vlan to a router protocol such as eigrp in the 3750 switch configuration.
0
 
LVL 1

Author Comment

by:leblanc
ID: 40193577
Yes there is no need for subinterfaces. I want to stay away from router-0on-a-stick type of configuration. ip routing is enabled on the switch.
0
 
LVL 47

Assisted Solution

by:Craig Beck
Craig Beck earned 800 total points
ID: 40194289
There's no need to send all the traffic to be routed between VLANs to the router so interVLAN will be done at the 3750X.  Any traffic not routed at the 3750X will be sent to the router.  Therefore I'd probably use a routed link between the 3750 and the router.  It'd also help to make routing simpler.

Technically though either approach would work - the Layer2 approach would work as long as you have dynamic or static routing configured between the router and 3750X to allow clients using one gateway to route via the other if they need to.
0
 
LVL 1

Author Comment

by:leblanc
ID: 40194438
So I need to configure a dynamic routing protocol like EIGRP between the router and the 3750X with either scenario. Corrrect?

"Any traffic not routed at the 3750X will be sent to the router.  Therefore I'd probably use a routed link between the 3750 and the router."
So if I have a subnet that is not defined in the SVI of the 3750X, it will be sent through the default route to the router. So it does not matter if it is layer 2 or routed link between the router and the switch. Correct?
0
 
LVL 47

Assisted Solution

by:Craig Beck
Craig Beck earned 800 total points
ID: 40194565
So I need to configure a dynamic routing protocol like EIGRP between the router and the 3750X with either scenario. Corrrect?
In either scenario you will probably want a routing protocol, but you don't have to use dynamic protocols; you could use static routes.  If you use a L3 link you'll need to point the 3750's default route via the router and you'll also want to point the router towards the 3750 to reach the subnets it owns.  I'd probably just configure EIGRP stub on the 3750 for this, or use a couple of static routes at the router and a default static route at the 3750.

So if I have a subnet that is not defined in the SVI of the 3750X, it will be sent through the default route to the router. So it does not matter if it is layer 2 or routed link between the router and the switch. Correct?
Kind of, but it's not that simple, hence needing routes between the 3750 and router.

Clients need a default route unless you configure specific static routes on them.  You're intending to have two routers on the same L2 segment (the 3750 will be a router as well as the actual router) so you'll have to use one router as the default gateway, then tell that router to tell clients that want to get to routes via the other router how to get there.  This can get messy and can also introduce problems with traffic flow.  Therefore a routed link is probably the better option.  That way everyone uses one default gateway (the 3750) and it decides where traffic goes, meanwhile the router can only ever send or receive traffic via one along the same path.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Network ports are the threads that hold network communication together. They are an essential part of networking that can be easily ignore or misunderstood, my goals is to show those who don't have a strong network foundation how network ports opera…
In this article, we’ll look at how to deploy ProxySQL.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question