Remote Desktop licensing mode Server 2008

Posted on 2014-07-13
Last Modified: 2014-07-24
Hi there

I am running server 2008 with the remote desktop services role enabled. I have configured the licensing and h\ve activated the Client access licenses. The server is installed on a workgroup environment.

I am recieving an error that states that the remote desktop licensing mode is unconfigured. I have created the policies for the rdc sessions and I have tried to switch from per user to per device mode.

In the server manager the overview is not available as it states that I am currently logged on as a local administrator and to view the server I need to logon as a domain administrator but I am not running a domain. I am running the server in a workgroup.

Can someone please help me to determine where I am going wrong?

Thanks in advance
Question by:DeonLubbe
    LVL 19

    Expert Comment

    by:Miguel Angel Perez Muñoz
    Try deleting HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Grace Period registry key on your RDP server.
    LVL 3

    Expert Comment

    Trying to remember from memory, but i do recall there was a role that required a domain or was that for 2012. That might be causing issues, dont recall though. Anyway,

    The two roles you should have installed is Remote Desktop Session Host and Remote Desktop Licensing.
    LVL 28

    Accepted Solution

    Please double check the steps to activate the license server:

    Can you please also provide the actual error (screenshot), or an event log entry the is related to the issue?

    Author Comment

    Hi Miguel, I get a access denied error when deleting the registry key or the subset entries. It says error deleting values, unable to delete specified values.

    Also BeCraig, this problem partains to Server 2012 and not server 2008 as specified in the help arfticles you refer to.
    I do not have this problem on any of my 2008 servers, only the 2012 servers.

    I have added the remote desktop sessions host and the licesning server. It still shows up with a message when the users log onto the remote sessions after a server reboot saying remote desktop services mode is not enabled.
    Furthermore I cannot see the server in the overview console in the server manager. Perhaps this is somehow related.
    I wish to be able to shadow the user session in server 2012 as I believe this is possible, but I am not sure if i can do this if the server is running in a workgroup environment.

    Thanks for the help so far, any other help appreciated.

    Featured Post

    How does your email signature look on mobiles?

    Do your employees use mobile devices to reply to emails? With mobile becoming increasingly important to the business world, it is in your best interest to make sure that your email signature looks great across all types of devices.

    Join & Write a Comment

    Every now and then, Microsoft does something that totally impresses me. It doesn't happen often, but in this case I must say I am thoroughly impressed with Windows Server Backup. One of the long time issues with Windows Backup has been the ability t…
    The article will show you how you can maintain a simple logfile of all Startup and Shutdown events on Windows servers and desktops with PowerShell. The script can be easily adapted into doing more like gracefully silencing/updating your monitoring s…
    This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
    This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …

    755 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now