[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 456
  • Last Modified:

Remote Desktop licensing mode Server 2008

Hi there

I am running server 2008 with the remote desktop services role enabled. I have configured the licensing and h\ve activated the Client access licenses. The server is installed on a workgroup environment.

I am recieving an error that states that the remote desktop licensing mode is unconfigured. I have created the policies for the rdc sessions and I have tried to switch from per user to per device mode.

In the server manager the overview is not available as it states that I am currently logged on as a local administrator and to view the server I need to logon as a domain administrator but I am not running a domain. I am running the server in a workgroup.

Can someone please help me to determine where I am going wrong?

Thanks in advance
0
DeonLubbe
Asked:
DeonLubbe
1 Solution
 
Miguel Angel Perez MuñozCommented:
Try deleting HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Grace Period registry key on your RDP server.
0
 
Sid6_7Commented:
Trying to remember from memory, but i do recall there was a role that required a domain or was that for 2012. That might be causing issues, dont recall though. Anyway,


The two roles you should have installed is Remote Desktop Session Host and Remote Desktop Licensing.
0
 
becraigCommented:
Please double check the steps to activate the license server:
http://technet.microsoft.com/en-us/library/dd983951%28v=ws.10%29.aspx

Can you please also provide the actual error (screenshot), or an event log entry the is related to the issue?
0
 
DeonLubbeAuthor Commented:
Hi Miguel, I get a access denied error when deleting the registry key or the subset entries. It says error deleting values, unable to delete specified values.

Also BeCraig, this problem partains to Server 2012 and not server 2008 as specified in the help arfticles you refer to.
I do not have this problem on any of my 2008 servers, only the 2012 servers.

I have added the remote desktop sessions host and the licesning server. It still shows up with a message when the users log onto the remote sessions after a server reboot saying remote desktop services mode is not enabled.
Furthermore I cannot see the server in the overview console in the server manager. Perhaps this is somehow related.
I wish to be able to shadow the user session in server 2012 as I believe this is possible, but I am not sure if i can do this if the server is running in a workgroup environment.

Thanks for the help so far, any other help appreciated.
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now