windows 7 professional - unable to write to newly installed disk - file permissions problem ?

I have a new desktop system running Windows 7 Professional. I have just added an additional disk. This is mapped as drive E:   The first disk containing the Windows build is C: and the DVD writer is D:

When using Dreamweaver CC then I can not write files to the E: drive whereas I can do this on the C: drive. Dreamweaver gives the message "An unknown error occured while accessing E:\test.html". Other software such as Notepad can write to the disk with no problem. I can even create new folders within Dreamweaver using the normal editing options.

I have removed the existing partitions from the additional disk and formated the disk from scratch.

I am assuming the problem might be down to the permissions / ownership of the new disk. I have checked the permissions (see screen captures) and these all look sensible. The owner of the disk is SYSTEM and SYSTEM has full permissions.

The Windows 7 Professional PC just has a single user and this user is the administrator.

Any suggestions as to what is wrong ?

Many thanks.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Thomas GrassiSystems AdministratorCommented:
Is E a network drive or local drive you said it is mapped as E?

Sounds like Dreamweaver does not know what type of drive it is.

If a local drive assigned as E then Dreamweaver should have no issue.

What does disk manger show about the drive?
tigger44Author Commented:
E is a local drive - the next drive letter available (E:) has just been assigned by Windows 7.

Disk Manger looks normal - I'll attach a screen shot for you to see.
Thomas GrassiSystems AdministratorCommented:
What happens if you open a file from the E Drive?

Create a simple html page using notepad same it to the E Drive then open it with dreamweaver does it open? if it does then try to save it? Does it save?
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

David Johnson, CD, MVPOwnerCommented:
Users only have READ / Execute give them Full Control
Based on your tests, I don't know that I would suspect NTFS permissions- but here are my thoughts on that anyway:
Capture 13 Shows the drive is owned by user scotsfir\dave
But capture 12 shows that the \USERS group, which I assume dave belongs to, only has Read & Execute permission.
You mentioned you have only one user, but I also see the scotsfir\administrator account specified.  So, can you confirm that dave is a member of the administrator group?
(I must suggest you NOT run with dave as administrator (major security flaw), rather grant the users group full control to the data folders on/or the entire drive e:)

You can also confirm you you have NTFS permissions to the file in question by opening the folder in windows explorer and make a copy of the file (confirm file read, and directory write permissions).  Then delete the original, confirm write permission.

Since working in notepad, lets check some things other than NTFS
- Test with AV software disabled, or folder/file excluded from scanning.
- (Sanity check) Launch Dreamweaver "As Administrator" (right click it for this option)
- run a check disk command (and reboot if needed) to let it scan & fix and problems (command will be something like - chkdsk e: \f)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tigger44Author Commented:

I can create the file with Notepad and then open it with DW. I see the content that I created.

If I try and Save then I get the same unknown error message as before....however after a few seconds the file on E: is rewritten with blank content and a TMP file also appears. I have done a screen shot of this.
Thomas GrassiSystems AdministratorCommented:
Lets try putting LIST permission for Everyone at the Root of Drive E
If that does not help Give Everyone Full Permission at the Root of Drive E
David Johnson, CD, MVPOwnerCommented:
create a new user in the permissions "Everyone" and give it FULL permissions
tigger44Author Commented:
I have been working through the various suggestions from the different experts.

First I checked how the permissions were set on the C: drive (which works OK) and these are identical to the E: drive e.g. users only have Read & Execute + List + Read while administrators and SYSTEM have full contol (everything except Special Permissions).

Disabling the anti virus made no difference.

Running DW as Administrator mean that I could save a file with no error message !

Interestingly I have rebooted the system and when I start DW normally (e.g. just clicking the desktop icon) then everything works normally. I don't understand why this would be so - I would have expected the problem to have returned.
It failed our "sanity check", by working when run as administrator.  In such situation a reboot is always a good idea :)

Was this the first reboot after installation?  Sometimes an installation is not completed until after an initial reboot is done (though nowadays, this is usually due to old/poor installation software).
tigger44Author Commented:
No I had already done multiple reboots. I have tried both a quick format and a full format of the new disk with reboots after each operation (DW CC was already installed).

This was the first time I had tried "run as administrator" and expected that I would need to use this on each occasion unless of course I changed the permissions. However, this was not needed - as since I did the first "run as administrator" it has worked fine since. Most odd....

Thanks again for your help. I'll allocate the points and accept the solution shortly.
Thomas GrassiSystems AdministratorCommented:
When making permissions changes on a computers hard drive sometimes those changes require a restart to take effect.

Unusually a logoff and then log back on will work .

Restart never hurts.

If you have the correct permissions you should be ok now.
Possible cause:

Doing "run as administrator", will also allow the the software to write to particular registry keys, which also have read/write permissions.  I suspect some reg entry needed to be created, and your account only has permission to READ this entry, while the admin has permission to write it.  (Cannot explain why admin GROUP would not have permission, probably just be the way the reg key was created; for an individual user (admin) rather than a group.)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.