GPO to set Internet Explorer as Default Browser

I recently had a browser incompatibility for a web application that many users need. As a work around I had them use firefox while I troubleshooted IE.

Now that I have IE sorted out, I want to force IE back as the default browser for all users.

I found that I can set each file extension (.url . html, etc) under user > Pref> Control Panel > Folder Options

This seems to work fine after some basic testing. It does not though, change the actual "Default Program" back to IE. So any desktop shortcuts still have a firefox icon and I'm sure I will run into other issues further down the road this way.

Is there a better way to do this besides by just file extenstion?

My domain controllers are server 2012 R2 and the workstations are windows 7 pro with Internet Explorer 11
LVL 1
bts86Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

McKnifeCommented:
Choosing IE as default browser adjusts all file types and nothing else. You need to do ALL of them and all will be ok.
0
Premkumar YogeswaranAnalyst II - System AdministratorCommented:
I found this link.. just to share
http://www.experts-exchange.com/Software/Internet_Email/Q_28422549.html

Credit goes to McKnife....!!!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bts86Author Commented:
Thanks for all of the info.

I added entries for all possible file extensions for browsers but not all are applying. I see this in the windows application log:
Source: Group Policy Folder Options   Event ID: 4098
The user 'htm' preference item in the 'IE Default Browser {837E4BF2-B788-4659-8FE0-28F89C0A4865}' Group Policy object did not apply because it failed with error code '0x80070005 Access is denied.' This error was suppressed.

The ones that are not applying are: htm html xht and xhtml

Ive tried setting the gpo as 'update' as well as 'replace'
0
McKnifeCommented:
"Credit goes to McKnife....!!! " - or so it seemed... ;-)
bts86, you can do this using logon scripts, also. Simply use reg.exe to manipulate the registry.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.