• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 921
  • Last Modified:

Cannot create a group email or security group email address from the SBS Console (SBS 2011)

Any time I attempt to create a Distribution Group with an outside email or a Security Group with an outside email, it fails with the error "Unable to create an e-mail address for the group", and fails out.  It never adds any members to the group, and ultimately doesn't look like it actually creates any group at all.  Seems to be a recent problem, but I haven't tried to add a group since last year.

I've tried multiple group names, so it's not a duplication problem in that regard.

I've attached the addgroup.log file.
addgroup.log
0
Firemedic41
Asked:
Firemedic41
  • 5
  • 3
  • 3
1 Solution
 
suriyaehnopCommented:
Based on definition of Distribution Group

http://technet.microsoft.com/en-us/library/bb125178(v=exchg.141).aspx

Distribution groups are mail-enabled Active Directory group objects that are created to expedite the mass sending of e-mail messages and other information within an Exchange organization

Within an Exchange organization is the DL/Security is for internal use only so it must be with internal Primary SMTP address
0
 
Firemedic41Author Commented:
hi, thanks for the reply!

I'm not sure what to do with your comment specifically.  The groups are attempting to be built with the option to have email access from outside of the organization.  This is being done from within the Create Groups Wizard, and this is the first time these errors have come up.
0
 
suriyaehnopCommented:
Your statement:

Any time I attempt to create a Distribution Group with an outside email or a Security Group with an outside email

What i understand is you tried to create a distribution / security group with external primary smtp address..
0
Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

 
Firemedic41Author Commented:
No.  I'm sorry I wasn't more clear.  I'm using the internal SBS Groups wizard to create a Distribution Group (and also tried a Security Group) that is able to receive emails from outside of the organization.
0
 
suriyaehnopCommented:
Based on your log:

[15808] 140714.115851.2001: Messaging: Executed management shell command: Set-DistributionGroup -RequireSenderAuthenticationEnabled "$false" -BypassSecurityGroupManagerCheck "True" -ManagedBy "ADMIN" -Identity "grouptest" -ForceUpgrade "$true"
[15808] 140714.115851.2971: Messaging: Pipeline returned error.
[15808] 140714.115851.2971: Messaging: MessagingTaskException: There are multiple recipients matching the identity "ADMIN". Please specify a unique value. - Error# (80006)

Instead of using UPN name or something that unique such as email address,alias
0
 
Adam RayCommented:
At least for testing purposes, have you tried creating test group(s) from the Exchange Console rather than from the SBS console?

If it works, it will point you to look next.
0
 
Firemedic41Author Commented:
I haven't tried the EMC yet.  I saw a few suggestions on trying to use that...but it seemed to end up breaking something else.  So I didn't try it yet.

@suriyaehnop - I did see that in the log.  I didn't enter that information as the email address.  I'm unsure of why it's being included which is likely part of the problem.  The only thing I can think of is that I'm logged into the console as that user.  However, no user being added to the group has that email address, and the email address being created doesn't have anything to do with "ADMIN" except that there are users in the "ADMIN" group being included in the groups I'm attempting to create.
0
 
Firemedic41Author Commented:
Of course also is the problem of the Group not being created at all.  So to WCLLC - if the EMC works, it works as only creating a email Distribution Group and not a Security Group with external email capability.

It's pretty frustrating because the error simply says it can't create it, and that's it.  no other information anywhere.  Probably the worst SBS error yet.  LOL.
0
 
Adam RayCommented:
If memory serves me, creating the group outside of the SBS Console doesn't break anything other than it not showing up in/being able to manage it from the SBS Console. (Not a great long term solution, but creating things in the EMC/ AD Users and Computers tend to provide more useful error messages for troubleshooting.)

As a sanity check, have you tried creating Sec Group w/external email from the SBS Console using a name/email address like "testASDF" with zero or one members to see if the problem is with creating any group in general or with just the specific one you are attempting?

As an aside, my previous suggestion of creating the group through EMC was incomplete. A somewhat more complete process is as follows (unfortunately I don't have access to an SBS 2011 at the moment to do a full step by step.)
--Use AD Users and Computers to create a universal sec group in the OU that SBS normally puts its group objects.
--Use EMC to create/add Exchange features to the existing/newly created sec group.

Additional notes:
--You may want to just create an internal email address for it first then add/enable the external email address afterward so you have more troubleshooting checkpoints.
--After the group is created you can run c:\Program Files\Windows Small Business Server\bin\GroupConverter.exe to "migrate" the manually created group into a fully functional SBS group that you can see/edit in the SBS console.
0
 
Adam RayCommented:
Hold on a second, I read the log again and I think I see what is happening.

Do _not_ use the ADMIN user account to login to the server. Create/use an administrator account with a different name; your real name, for example. If I'm right, the SBS console can't disambiguate between the "administrator" and the "admin" account behind the scenes when it's running powershell commands.

Note: ADMIN refers to the "yourdomain.local\admin" account that exists in your particular network. I'm assuming you still have the [non-renamed] built-in "administrator" account as well.
0
 
Firemedic41Author Commented:
Yep!  This was it.  I wondered about that in the log.  Seeing as I hadn't chosen the "ADMIN" account at all, the only commonality was that I was logged in as that.

Nice find!  Thanks!  Full points.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 5
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now