RDWeb RDP Access Intermittent Among Workstations/PCs

RDWeb RDP Access Intermittent Among Workstations/PCs

I am seeing this issue currently with a domain:
RDWeb and IIS is setup properly and working.
Everything is configured correctly - certs are in place, matching, etc.
Recently access to Workstations via RDP is failing inside RDWeb.
This is also happening with RemoteApps

This happens on only some workstations, and it does not seem to be IE version or OS version dependent. Has anyone seen this, and know the update(s) that may be causing the issue?
bizcoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MaheshArchitectCommented:
Is this 2012 \ 2012 R2 RD Web access ?

In that case if you are using Win 7 clients, you need to update RDP clients on win7 to RDP 8 \ 8.1

http://support.microsoft.com/kb/2923545/en-us
0
bizcoAuthor Commented:
This is Server 2008 R2
0
bizcoAuthor Commented:
What error do you see when the connection fails?
The remote access gateway is unavailable

Does access fail to all workstations and RemoteApps at once, or is it inconsistent?
The remote access is consistent on failure per workstations, either the workstation can or cannot.

What does the issues follow (the workstation the resources are accessed from, the resource accessed, an Internet carrier, time of day, etc.)?
Nothing in common
      
When the issue occurs, can you ping the resource?
You can ping the resource
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

bizcoAuthor Commented:
Points Increased, also looking into mstsc.exe version, most are not working with different versions, so that eliminates that.
0
btanExec ConsultantCommented:
the forum seems to share similar issue
http://social.technet.microsoft.com/Forums/windowsserver/en-US/0e340938-309c-415f-997c-5ca3d3051160/rdweb-getting-remote-desktop-gateway-server-is-temporarily-unavailable-error?forum=winserverTS

I would suggest the following action plan.

1. Minimize the complexities. The error you are seeing states that RDGateway is not available. Do not test by connecting through the RDWeb page. Use only MSTSC and connect using these settings (where server.domain.com is you will replace with the FQDN that is on the subject line of the certificate that is bound to the Gateway service.  Based on configuration, you may have to use “hosts” files to resolve the name if needed). It is very important to uncheck the “Bypass RD Gateway server for local addresses” in the Remote Desktop Client. Otherwise it will still utilize 3389 which would work internally.

2. Test internally first. Preferably on the Gateway server itself. Does it work?  If so move to another server\client on the internal environment and try to connect to another device utilizing the RD Gateway settings in the MSTSC.  Did that work?

3. Test externally only utilizing MSTSC trying to RDP through the Gateway service to an internal device.  Don’t utilize Websso or RDWeb as they are completely different services and we don’t want to confuse the troubleshooting steps any more than they may be.

4. Once we have proven we can get the RDGateway to work internally using MSTSC then try utilizing the RDWeb page. Does it work internally? (Keep in mind that you must also uncheck the Bypass option in the RemoteApp\RD Gateway configuration otherwise it will utilize 3389 to connect).

*Note: We need to keep in mind that RemoteApp, RDWeb, WebSSO, and RDGateway are different services that provide different functionality.  RDGateway is nothing more the a proxy service that converts incoming SSL data (actually RPC over HTTPS) to RDP 3389 data and passes it to the backend resource you are trying to contact.  Get that working first without all the other services.
** If everything works good internally, then you know that the issue is somewhere within the Firewall or outside getting in.
Eventually, the author went through

http://www.scribd.com/doc/15682090/TS-Gateway-2008-RSA

I added this line in remote desktop connection manager > go to the personal vertual desktops properties > Custom RDP setting    >
pre-authentication server address: s: https://TsGateway.company.com/rdweb
require pre-authentication:i:1
This is for publishing VDI through TMG 2010.
0
bizcoAuthor Commented:
Found the issue was due to configuration. RDWeb was sharing a OWA certificate to cut cost. Migrated RDWeb to another server and all is working fine now.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
btanExec ConsultantCommented:
thank for sharing , hope the posting has assisted.
0
bizcoAuthor Commented:
It wasnt configured in best practice so I moved the RD Server
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.