• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 149
  • Last Modified:

Migration to Exch2013, Rooms not responding to invites

Recently migrated a client to Exchange 2013 from 2007. They had a few user mailboxes which were used as rooms. So after the upgrade, I converted them to Room mailboxes.

Now, when a user books something on the calendar for that room, it is accepted but does not send a confirmation email to the user. I checked the Room settings and it has an email address tied to it. Not sure what else to check.
0
Schuyler Dorsey
Asked:
Schuyler Dorsey
  • 11
  • 5
1 Solution
 
Taylor ShipmanCommented:
Have you made a delegation to the resource mailbox?

Only the meeting organizer would get a accepted invite I believe.  
 Included a snip to show you were to set that.
Exchange.PNG
0
 
Schuyler DorseyAuthor Commented:
Followed this MS link. http://support.microsoft.com/kb/2005631 

My results:

ResourceType Room
RemoteRecipientType None
RecipientType UserMailbox
IsShared False
0
 
Schuyler DorseyAuthor Commented:
Thanks for that info. Let me try real quick.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Schuyler DorseyAuthor Commented:
The organization still gets no confirmation the room was booked.

I have no delegation set. I did not set that as I am not looking for a specific person to manage the calendar.. we just want the calendar to auto-accept invites as long as there is no conflict.

Do I still need a delegation?
0
 
Taylor ShipmanCommented:
No you should not then.  

Have you checked the queue to see if any emails from that resource mailbox are stuck there?  Sometimes moving them to a new database and moving them back will free up stuck emails on room mailboxes.

Also make sure you have moved the arbitration mailbox to the new 2013 server also.
0
 
Taylor ShipmanCommented:
Also check Direct Booking in Outlook

Go to tools
options
calendar options
resource scheduling
disable automatic accept
0
 
Schuyler DorseyAuthor Commented:
There are no emails in the queue.

Wouldn't disabling auto-accept prevent the item from being accepted and put onto the calendar?
0
 
Taylor ShipmanCommented:
You would think it would work that way but I believe if you have that enabled then it doesn't do anything.  

There is an issue with Direct booking and the auto accept on Exchange 2013.  

Run this command and make sure the AutomateProcessing value is set to Autoaccept
Get-CalendarProcessing –id <Room id> |FL
0
 
Schuyler DorseyAuthor Commented:
It is set to AutoAccept.

As I mentioned, the calendar invites ARE accepted and placed on the Resource calendar. But the confirmation email is not sent to the meeting organizer.

Just checked another client's Exch13 I migrated too a few weeks ago and a new Room MB at default settings auto-sends a confirmation when the invite is accepted.
0
 
Taylor ShipmanCommented:
The only other thing I could think of is the mailbox is full or corrupted.  Do you have another database you can move it to?  Or check the limits on it?
0
 
Schuyler DorseyAuthor Commented:
The behavior seems to be this way for ALL resources mailboxes in this environment. I even created a new one with default settings and it did NOT send a confirmation email.

This makes me wonder if it is a global setting somewhere?
0
 
Schuyler DorseyAuthor Commented:
Currently running on CU4/Sp1.
0
 
Schuyler DorseyAuthor Commented:
It looks like it isn't properly processing Free/Busy. It auto-accepts everything.. regardless of whether or not there is a conflict.
0
 
Schuyler DorseyAuthor Commented:
testconnectivity.microsoft.com shows green for EWS-Availability test and Autodiscover tests.

Get-WebServicesVirtualDirectory shows it pointing to the correct URL.
0
 
Schuyler DorseyAuthor Commented:
After we removed the booking delegates, the room stopped working. Users would not receive email confirms, room was not accepted and it was never added to the calendar. Found that if we added a booking delegate back in, the room would start working again but the confirmation emails would still come from the OLD booking delegate.

Spent 6 hours on phone with Microsoft Support over the course of two days and after all their diagnostics and troubleshooting, their final recommendation was to export the calendars, delete the mailbox, create a whole new one and import the data.

We went through adsiedit, ldap, A.D., Exchange properties and found zero difference between the migrated non-working mailboxes and the 2 new test room mailboxes I created directly in Exch13 which worked correctly.
0
 
Schuyler DorseyAuthor Commented:
MS support provided the only answer.
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 11
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now