Scheduled Task for Custom App Calls EXCEL.EXE only when LOCAL ADMIN

We have a couple of VisualStusio 2010 custom apps that use EXCEL to generate output.  These custom apps only run properly when the user account used in the scheduled task has LOCAL ADMIN rights.  Without the admin rights, the custom app calls excel properly at the desktop, but not as a scheduled task.  Is there any way to allow a custom app to call excel WITHOUT being a local admin on the server?
tcloudAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Aaron TomoskySD-WAN SimplifiedCommented:
Is the app trying to save a file inside the users folder or some other place you need to be a local admin to access?
0
dan_blagutCommented:
Hello

Your account should have some specific rights (that local admin account already has)
http://serverfault.com/questions/256196/windows-scheduled-task-what-are-the-minimum-user-rights-needed-for-the-task

Dan
0
tcloudAuthor Commented:
Aaron, The application saves the file to a network path where the user already has access.

Dan,  The log on as batch job rights are already assigned.  Please note that the custom app runs properly from the scheduled task; it just cant call/open excel.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

tcloudAuthor Commented:
The task runs properly.  The application called by the task runs with no issues.  That VS2010 application calls EXCEL, but EXCEL will only open if administrator, even though the user account can run EXCEL at the desktop level.
0
Aaron TomoskySD-WAN SimplifiedCommented:
did you uncheck "run with highest priveledges"?
0
tcloudAuthor Commented:
No, the Run w/ High Priv is set.
0
Aaron TomoskySD-WAN SimplifiedCommented:
uncheck that and see what happens
0
tcloudAuthor Commented:
Unchecking the option didnt fix it.
0
David Johnson, CD, MVPOwnerCommented:
scheduled tasks don't work well with windows forms as they need a window that scheduled tasks doesn't provide.  Try setting a batch file in the scheduled task that then calls the application.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tcloudAuthor Commented:
Using BATCH FILE CONTAINING 'CMD.EXE /C START application.exe' in task scheduler did the trick!  Thanks David!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual Basic.NET

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.