• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2126
  • Last Modified:

Cannot ping local interface on Cisco Router

I have configured loopback interface and physical interface on Cisco router.
I can ping the loopback but cannot ping the physical interface ip address, though I checked it and it is up.

I will am posting the configuration  below:

R5#sh run
Building configuration...

Current configuration : 2380 bytes
!
! Last configuration change at 07:15:50 UTC Tue Jul 15 2014
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
vrf definition 101:ACME
 rd 5.5.5.5:1
 !
 address-family ipv4
 route-target export 5.5.5.5:101
 route-target import 1.1.1.1:101
 exit-address-family
!         
vrf definition 102:CBT
 rd 5.5.5.5:2
 !
 address-family ipv4
 route-target export 5.5.5.5:102
 route-target import 1.1.1.1:102
 exit-address-family
!
!
no aaa new-model
!
!
!
ip source-route
ip cef
!
!
!
!
no ipv6 cef
!
multilink bundle-name authenticated
mpls label range 500 599
!
!
!
!
!
!
!
!
!
redundancy
!
!
! 
!
!
!
!
!
!
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
 !        
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
 !
!
interface FastEthernet2/0
 description connection to ACME site 2
 vrf forwarding 101:ACME
 ip address 192.168.202.1 255.255.255.252
 duplex auto
 speed auto
 !
!
interface FastEthernet2/1
 description fa2/1 connecting to CBT Site 2
 vrf forwarding 102:CBT
 ip address 192.168.202.1 255.255.255.252
 duplex auto
 speed auto
 !
!         
interface GigabitEthernet4/0
 ip address 10.45.0.5 255.255.255.0
 negotiation auto
 mpls ip
 !
!
!
router ospf 1
 log-adjacency-changes
 network 5.5.5.5 0.0.0.0 area 0
 network 10.45.0.0 0.0.0.255 area 0
!
router rip
 version 2
 !
 address-family ipv4 vrf 101:ACME
  redistribute bgp 65536 metric 5
  network 192.168.202.0
  no auto-summary
 exit-address-family
!
router bgp 65536
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 65536
 neighbor 1.1.1.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community extended
  neighbor 1.1.1.1 next-hop-self
 exit-address-family
 !
 address-family ipv4 vrf 101:ACME
  no synchronization
  redistribute rip
 exit-address-family
 !
 address-family ipv4 vrf 102:CBT
  no synchronization
  neighbor 192.168.202.2 remote-as 65537
  neighbor 192.168.202.2 activate
 exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
 shutdown
!         
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
end

R5#

Open in new window

0
jskfan
Asked:
jskfan
2 Solutions
 
Don JohnstonInstructorCommented:
You didn't say which interface.  If it's  in a non-default VRF, you have to specify the VRF when you ping.
0
 
Istvan KalmarCommented:
If you checking interface which became to any vrf you need to use this:

ping vrf CBT 192.168.202.1
0
 
jskfanAuthor Commented:
I seeā€¦ After I specified VRF as you suggested , I managed to ping it.

R5#ping vrf 101:ACME 192.168.202.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.202.2, timeout is 2 seconds:
!!.!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 16/26/36 ms
R5#
0
 
jskfanAuthor Commented:
Thank you Guys!
0
 
Member_2_6427606Commented:
Unable to ping local vrf interface on a 7600 cisco router. vlan is created and the interface vlan is up/up
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now