Robocopy command parameter to migrate home drives while retaining the file ownership after copied to target file server

Hi people,

I'm using Windows Server 2012 R2 as the new file server to copy the Home Drives content from the old file server (Server 2008) to the S:\ drive in the new file server.

Can anyone please suggest me which parameter should I use to make sure that the file & directory ownership is still retained from the old source file server in the new file server ?

I have tried to copy using the following one line batch script:  

robocopy \\OldFileServer\Homes S:\homes *.* /MIR /SEC /SECFIX /LOG:C:\TEMP\RoboCopylogs.txt

Open in new window


but the result is that all of the copied directories in the new S: drive are owned by the newServer2012R2\Administrators group ?

the users cannot delete the files in their own Home drives.

Is there any way or parameter to include or script to fix the ownership above?
LVL 9
Senior IT System EngineerIT ProfessionalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Arjun VyavahareTechnical ConsultantCommented:
Hi,

I would suggest you to use Microsoft File Migration Toolkit, this tool will copy files as well as permissions of folder and folder ownership.

I hope this wil resolve your issue.

Regards,
Arjun
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Senior IT System EngineerIT ProfessionalAuthor Commented:
ok, I have install it on the new target server, but what's the command line to use in the Windows Server 2012 R2 ?
0
Joel JerkinConsultantCommented:
Hi,

If you are using robocopy, try with the following line:
robocopy \\OldFileServer\Homes S:\homes *.* /MIR /COPYALL /SECFIX /LOG:C:\TEMP\RoboCopylogs.txt

Open in new window

/COPYALL (same as /COPY:DATSOU) will include the O-flag (Owner Information).

You can read more about the /COPY parameter here.

Regards,
Joel
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.