What is wrong with my Symfony Configuration?

Towards the end of the first tutorial (http://symfony.com/legacy/doc/jobeet/1_4/en/01?orm=Doctrine), I’m asked to change the configuration of my server so it’s looking in my “bruce” folder (home/ sfprojects/jobeet/web/index.php). Here’s what I did:

# Be sure to only have this line once in your configuration

# This is the configuration for your project

  DocumentRoot "/home/sfprojects/jobeet/web"
  DirectoryIndex index.php
  <Directory "/home/sfprojects/jobeet/web">
    AllowOverride All
    Allow from All

  Alias /sf /home/sfprojects/jobeet/lib/vendor/symfony/data/web/sf
  <Directory "/home/sfprojects/jobeet/lib/vendor/symfony/data/web/sf">
    AllowOverride All
    Allow from All

I’m changing the port and the root directories. Simple enough. Thing is, ” home/sfprojects/jobeet/lib/vendor/symfony/data/web/sf” doesn’t exist. That may not make a difference, but when I went to see the page that’s supposedly at http://~localhost~:8080/, I get a “page not found” error. What am I doing wrong?
brucegustPHP DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Did you try the port besides 8080 such as 9090 ?
Did you stop and start apache again ?
Did you find the index.php at that directory on shell command, for example, ls /home/sfprojects/jobeet/web/index.php  ?

brucegustPHP DeveloperAuthor Commented:
Duncan! I'm glad you're up, my friend!

When I go the shell command route, first off, I'm using this: ls home/sfprojects/jobeedt/web/index.php. I'm omitting the first "/" and I wanted you to see that, being that I'm not sure that's a deal breaker or not.

The screen print I have attached shows you, both the outcome of the command (which was successful), as well as the way I have things set up as seen in my Finder.

I have re-started Apache. I have not tried any other ports other than the ones specified in the tutorial I'm attempting to make my way through (http://symfony.com/legacy/doc/jobeet/1_4/en/01?orm=Doctrine).

What do you think?
Please answer my question ?

Try other port such as 9090 instead of 8080  since your system might be using 8080
for other application and check whether the file of index.php
is at that directory first or not

Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

brucegustPHP DeveloperAuthor Commented:
OK, I changed the port to 9090 and when I open up MAMP after restarting it, I get this URL: http://localhost:9090/MAMP/?language=English and I get the MAMP start page.

If I try this: http://localhost:9090/home/sfprojects/jobeet/web, I get a page not found.

Things is, that doesn't surprise me because I'm assuming that MAMP is not looking for a file outside the MAMP application itself, correct? So if I don't have a "home" directory in my MAMP application, should I expect it to open up a page that's sitting in my user/bruce directory?
Now you are using  MAMP ?  why not switch to XAMPP that is better
for apache setup ,

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
brucegustPHP DeveloperAuthor Commented:
I'm just going by the tutorial at http://symfony.com/legacy/doc/jobeet/1_4/en/01?orm=Doctrine

Regardless of which service I use, shouldn't my Symfony project be located within my MAMP application? How can a php page work unless it's hosted within the app? It boggles my mind to think that I'm pointing my web server to a page that's in my user folder as opposed to a file that's "hosted" with my web server.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.