How can i reduce high physical memory usage in SBS 2011

Posted on 2014-07-17
Last Modified: 2014-08-05

i have a client with an SBS 2011 server on a HP ML350 G8 platform with 24GB ram and a 4core 2.4Ghx Xeon. The page files is 36864 and is on the data partition.
I am having problems at the moment with the performance of sage accounting software running slowly and i believe it is because of the amount of memory in use. I have attached some task manager screen shots can you give me any pointers as if the problem is exchange, IIS etc and any ideas on how to resolve the problem.

Thanks in advance
Question by:VBOSS
    LVL 11

    Expert Comment

    by:David Kroll
    Try setting the database cache size for Exchange.

    Author Comment

    Thanks...i found a similar article last night and implemented it and set it to 8gb (8388608). It had no obvious effect as the memory level was just the same and the store.exe was just the same as what is being displayed unless i entered an invalid amount so i removed the setting.
    LVL 95

    Expert Comment

    by:Lee W, MVP
    Would be helpful to know what article you found...

    You need to specify the MINIMUM cache size as well - that means you must define both msExchESEparamCacheSizeMax AND msExchESEparamCacheSizeMin.

    Author Comment

    Here it is

    i didn't notice anything about CacheSizeMin but there are a few more links down the page that i ran out of time to look at last night.
    LVL 95

    Accepted Solution

    I would suggest when looking for information involving SBS, especially if it's linked to/created by Susan Bradley, PAY ATTENTION.  

    The selected answer to that question explicitly states CacheSizeMin:

    You can modify the default database cache size values by making changes to the msExchESEParamCacheSizeMax and msExchESEParamCacheSizeMin attributes in Active Directory.

    Most people overlook it because they don't care what the minimum is, they just want the maximum set... except that it doesn't work right unless they are BOTH set.

    Author Comment

    sorry too many long hours this week. I have made the changes again but i will have to wait until morning and see what happens. Thanks.
    LVL 5

    Assisted Solution

    by:Adam Ray
    If your operating on too little sleep... don't forget to restart the Exchange IS service after you make the registry changes ;)

    I also limit the RAM size of the SBSMonitoring and WSUS SQL databases when trying to free up RAM on an SBS box.

    Author Closing Comment

    Thanks guys all worked well. Appreciate all comments as i was sleep deprived

    Featured Post

    What Should I Do With This Threat Intelligence?

    Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

    Join & Write a Comment

    Introduction At 19:33 (UST) on Tuesday 21st September the long awaited email arrived with the subject title of “ANNOUNCING THE AVAILABILITY OF WINDOWS SBS 7 PREVIEW”.  It was time to drop whatever I was doing and dedicate as much bandwidth as possi…
    If you are a user of the discontinued Microsoft Office Accounting 2008 (MSOA) and have to move to a new computer running Windows 8, you will be unhappy to discover that it won't install.  In particular, Microsoft SQL Server 2005 Express Edition (SSE…
    how to add IIS SMTP to handle application/Scanner relays into office 365.
    In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…

    755 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now