?
Solved

Problems switching wireless networks

Posted on 2014-07-17
16
Medium Priority
?
378 Views
Last Modified: 2014-08-17
I am having a strange problem.  I have techs on the road using mobile hotspots for internet access.  When they are done for the day, they are suppose to come to the shop, connect to our internal wifi and transfer any data they may have back to the shop through our software.

This is what happens:

There are two Wifi Networks:
VerizonWiFi - the mobile hotspot network
OfficeWifi - the wifi at the Office

Tech connects to VerizonWifi and gets:
ip: 192.168.1.100/24
Gateway 192.168.1.1
DNS 192.168.1.1

Everything is as it should be

when he gets back to the office, he switches to connect to the OfficeWifi but gets this:
ip: 192.168.2.150/24
Gateway 192.168.1.1
DNS OurServer1
DNS OurServer2

The gateway is incorrect and should be 192.168.2.1

If I open a command prompt and do an ipconfig /release and then a renew, then the Gateway changes to 192.168.2.1 like it should be and everything works again.

It does the same thing if I start connected to the OfficeWifi then switch to the VerizonWifi.
It is doing this on most but not all laptops
These are all brand new W7 Pro laptops that were setup identically.

I didn't have one on me, but I will be trying a usb WiFi adapter in the next day or two to hopefully rule out any strange issue there may be with the type of wireless adapter installed in the laptop.  

Any other suggestions on what to try?
0
Comment
Question by:pmitllc
  • 7
  • 6
  • 3
16 Comments
 
LVL 99

Expert Comment

by:John Hurst
ID: 40203530
Make sure you are using straight DHCP with no special settings.

I routinely connect to 192.168.x.x at home office, suspend, connect to 192.168.y.y at a client,, suspend, come back to home office and reconnect. No issues. True for Vista, Seven and Eight.
0
 
LVL 6

Author Comment

by:pmitllc
ID: 40203534
Yes both are straight DHCP as far as I know....the verizon network is basically the defaults for the hotspot, and the Office network's DHCP is handled by our server and a couple reservations.  I'm pretty sure that the DHCP showed in the ipconfig /all and was correct.....I will verify tomorrow.

I do know that my personal laptop and phone can connect just fine to both.

I am leaning towards some weird hardware problem with the card in the laptop, which should be easy to test with a USB wifi adapter.
0
 
LVL 99

Expert Comment

by:John Hurst
ID: 40203538
Take one or two computers with problems and reset TCP/IP

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Restart the computer

Then also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
LVL 2

Expert Comment

by:UnHeardOf
ID: 40203575
Is there an updated driver for the wireless card ? You could also run wireshark and view the dhcp packets to see if you see anything unusual.
0
 
LVL 99

Expert Comment

by:John Hurst
ID: 40203576
I have used Atheros (XP) and various Intel (Vista through Eight) and multiple driver revisions with no issue.

Try the reset idea before updating a driver because updating a driver will also reset.
0
 
LVL 2

Expert Comment

by:UnHeardOf
ID: 40203583
You could try running in safe mode with networking to see if the issue persists.
0
 
LVL 6

Author Comment

by:pmitllc
ID: 40205424
More Information from today.  I stated some things incorrectly in my original post.

I thought that the problem happened when I switched from either network, but it seems to only happen when I switch from our Verizon WiFi to our office WiFi.  Switching from the Office WiFi to the Verizon WiFi normally works (sometimes it shows the same problem with the yellow triangle, but then fixes itself if you let it sit for a minute).

When you are on Verizon Wifi and click the wireless icon in the system tray to change to the Office Wifi, it shows connected next to the Office Wifi network.  If I hold the mouse over the wifi icon, it shows "identifying" and after a couple seconds the yellow triangle appears and it says no internet access (I have also seen it say there was internet access with no triangle, but it was still identifying and it wouldn't work).

I was also getting proper IP information from ipconfig /all as long as I waited a while before running it.  If I switched from Office to Verizon and ran an ipconfig as soon as it said I was connected to Verizon, I was seeing mostly the Office Wifi information.  That is why I thought there were issues with the default gateway in my first post.  If I ran it a few more times, the information eventually updated. - this was really confusing and made it hard to troubleshoot.

When connected to the Office Wifi and it works, it shows DOMAIN.LOCAL when hovering over the wireless icon in the system tray

I tried safe mode and had the same result.
I tried a USB adapter and had the same result.
Removing and readding wireless network doesn't help.

I did a release renew and that worked.  Resetting the ip stack also worked, but I don't want a reboot of the PC to be required.

Right now, I created a batch file on the desktop that releases and renews the IP that works if they have problems connecting.  

I am thinking the problem is with the laptop identifying the network as the domain network.
0
 
LVL 99

Accepted Solution

by:
John Hurst earned 2000 total points
ID: 40205433
Wireless can be tricky on a domain because the domain connection takes priority and then it cannot find a connection because wireless is not running.

Now that you have clarified, it is this issue causing your problem, not wireless switching.

Try to delay the domain until after the wireless has connected.
0
 
LVL 99

Assisted Solution

by:John Hurst
John Hurst earned 2000 total points
ID: 40205443
There is a Microsoft Support article for waiting for a connection before logging onto the domain.  See if it helps.

http://support.microsoft.com/kb/305293
0
 
LVL 6

Author Comment

by:pmitllc
ID: 40211508
I enabled the "Always wait for the network at computer startup and logon" via local group policy, but now the laptops are taking way to long to log in.  

I let it sit for 5 min, then plugged in the network cable and it logged in immediately.
0
 
LVL 99

Expert Comment

by:John Hurst
ID: 40211528
You can see if there is a parameter to adjust the time, but I think this is the way wireless and domain connections act. I discourage wireless domain connection for this reason.
0
 
LVL 6

Author Comment

by:pmitllc
ID: 40212008
I am thinking that for this type of situation, I would need to setup a different type of wireless network like a RADIUS server (but I have no experience with this).  Would that be a better method for domain connected wireless laptops?

I did have someone else tell me to try turning on Network Discovery, so I will attempt that as well the next time I am in.
There are a couple laptops that work perfectly fine, so I am wondering if it was something as simple as this.
0
 
LVL 2

Expert Comment

by:UnHeardOf
ID: 40212934
Are you using the windows builtin wireless client or a third party like intel ?
0
 
LVL 6

Author Comment

by:pmitllc
ID: 40222659
I am using windows built in client.  
Changing sharing settings makes no difference.
Currently, the wireless network is WPA2-PSK AES.  I am able to get them to connect by running a small script that disconnects them from the network connects to the work network then does a release renew and flushdns.

This is a network i took over after they decided they needed to upgrade.  The person that originally set all of this up is no longer available.

Would setting something like this up would help the problem?  I am assuming at the very least it would be better security : http://www.cisco.com/c/en/us/support/docs/wireless/aironet-1100-series/44100-leaplocalauth.html
0
 
LVL 6

Assisted Solution

by:pmitllc
pmitllc earned 0 total points
ID: 40230058
We decided to use netsetman pro to switch between networks which is working very well.  

We blocked off a range from DHCP and had the tool statically assigning IPs when connected.

The tool also allows for release, renew, flushdns, and registerdns commands to be added when switching networks which seems much more reliable than my batch script method.
0
 
LVL 6

Author Closing Comment

by:pmitllc
ID: 40265949
My solution is working for me, however, John pointed out the root of the problem.
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Resolve DNS query failed errors for Exchange
In the modern office, employees tend to move around the workplace a lot more freely. Conferences, collaborative groups, flexible seating and working from home require a new level of mobility. Technology has not only changed the behavior and the expe…
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question