Exchange 2010 Out of Office

Migrated from Exchange 2003 to Exchange 2010 and it broke OOO.

"Your Automatic reply settings cannot be displayed because the server is currently unavailable.  Try again later."

I've read and tried some of the many solutions on the web and it hasn't fixed the issue.  

I believe one of the problems is that this client's Active Directory domain name is different than their production EMail domain. (abc.com vs. def.com), and the client does not own the public domain for their internal domain name and therefore cannot obtain a third party SSL certificate.  We are using a selfsigned certificate.
NEMCAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NEMCAuthor Commented:
OOO works correctly when configuring via OWA.
0
Adam FarageEnterprise ArchCommented:
make sure autodiscover is working properly, as this is handled by Exchange Web Services (Availability Module)

To test this from the Outlook client, in the task bar CTRL+RIGHT CLICK the Outlook icon and select "Test Email AutoConfig"

Post the results, and make sure the proper EWS Internal and External URL are being pulled.
0
NEMCAuthor Commented:
Adam, thanks for the response.

If I just use Autodiscover and disable both Guesssmart options, it fails with:

Autoconfiguration was unable to determine your settings!

If I enable Guesssmart, it comes back with SMTP information and the correct external URL only.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Rajitha ChimmaniCommented:
If the AD domain is different from email domain you must have the autodiscover SCP records. Have you tried the below solution?

How to Configure the Availability Service for Cross-Forest Topologies
http://blogs.technet.com/b/exchange/archive/2011/03/04/3412075.aspx

Export-AutoDiscoverConfig
http://technet.microsoft.com/en-us/library/aa998832(v=exchg.141).aspx
0
NEMCAuthor Commented:
I have not tried the Cross Forest solution.  I'll take a look at the notes.

I opened a call with Microsoft and his response was that we could reconfigure the servers SSL to allow OOO to work from within Outlook, but as a result Outlook would generate an SSL error every time it launched.

Further stated that the only was to resolve that issue would be to import the server's Certificate into each Outlook client. (And repeat whenever certificate was renewed).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
NEMCAuthor Commented:
Client did not want to deal with the Microsoft solution and is going to live with use OWA to set OOO.

Thanks to everyone who responded.
0
NEMCAuthor Commented:
Microsoft provided a valid workaround, but client did not want to incur the client side changes.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.