Solved

Unable to apply permissions on mounted drives

Posted on 2014-07-18
5
365 Views
Last Modified: 2014-08-12
Hi
 I have a Windows 2008R2 server that is part of a domain that has mounted SAN drives. However users are able to browse on a non-mounted directory but not on a  mounted Directory with the same permissions. I would appreciate your assistance with this.
0
Comment
Question by:Phil Mapfumo
  • 3
  • 2
5 Comments
 
LVL 70

Expert Comment

by:Merete
ID: 40205899
A mounted drive is a drive that is mapped to an empty folder on a volume that uses the NTFS file system.
Try sharing the folder it is mounted to.
Have you rebooted and allowed the settings to settle?
0
 

Author Comment

by:Phil Mapfumo
ID: 40208607
I have rebooted the machine but still there is no change. I would like the mounted drives to inherit the permission from the root drive. I have found this link
http://jthys.wordpress.com/2010/09/04/microsoft-volume-mount-points-list-folder-permissions/

 However l am not sure what he means by :

1.Create an empty folder Users3 under the root folder.
2.Initialize disk and format the volume in Disk Management.
3.Mount the new Volume to the empty folder Users3

 I cannot really initialize and  format the volume as l have many files on the volume or am l misunderstanding the process
0
 
LVL 70

Expert Comment

by:Merete
ID: 40208770
0
 

Author Comment

by:Phil Mapfumo
ID: 40214740
Merete
 I not sure what is being suggested in the link that you have provided, does that mean that the l can apply the permissons to a root folder or drive and there will be inherited by the mounted folder
0
 
LVL 70

Accepted Solution

by:
Merete earned 500 total points
ID: 40215963
What caught my eye was the two points>
the first one and is his problem>
In this case the actual shares are child folders and not the root, so as long as users have list rights at the mount point, they should be able to get to the actual shares. The part that I am trying to understand is, why can I not correctly change permissions on the mount point itself.
The other refers to the mount point and the folder>
The key for this to work seems to be leaving the default everyone's group in the mount point permissions and then adding any new groups that are required to make the folder permissions match the mount point permissions.
 If you remove the default "everyone" which is inherited form the root volume, permissions do not work correctly.
I think this is a bug related to mount points that people should be aware of when setting permissions.
0

Featured Post

VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Remote Apps is a feature in server 2008 which allows users to run applications off Remote Desktop Servers without having to log into them to run the applications.  The user can either have a desktop shortcut installed or go through the web portal to…
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question