Solved

FM - Can't get a Rec to Show Up in a Portal Whose Total is Zero

Posted on 2014-07-18
7
170 Views
Last Modified: 2014-07-23
Cannot get a record to show up in a portal.  I have a summary table of banks and one of them has 0 for the current year.  I made sure my calculation would display a 0 instead of a blank in the field, but it still doesn't show up.  Any suggestions?
0
Comment
Question by:rvfowler2
  • 4
  • 3
7 Comments
 
LVL 25

Expert Comment

by:Will Loving
ID: 40204958
So you want the field to actually show 0 for the year?  Make sure that it's a Number field or result and that the formatting for the field is set so that "Do not display if zero is unchecked" on the Inspector, Data Tab, Number Formatting.
0
 
LVL 2

Author Comment

by:rvfowler2
ID: 40209861
I did that, but it is still not showing up in the portal.  See attached.  (And no filters in the portal).
Capture4.JPG
0
 
LVL 25

Expert Comment

by:Will Loving
ID: 40210004
I'm assuming your calculation says something like, If( A - B = 0 ; "0" ; A - B )

Make sure the check box at the bottom of the calculation is checked. Make sure the "Do not evaluate if all referenced fields are empty" option is unchecked.

Do not evaluate...
0
Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

 
LVL 2

Author Comment

by:rvfowler2
ID: 40212713
"Make sure the check box at the bottom of the calculation is checked."  Which check box?  On your other point, went through and unchecked "Do not evaluate...", but still not showing in portal.
0
 
LVL 25

Expert Comment

by:Will Loving
ID: 40212866
I was referring to the "Do not evaluate…." checkbox
0
 
LVL 25

Accepted Solution

by:
Will Loving earned 500 total points
ID: 40215288
I'm guessing that the relationship you are using for the portal is somehow excluding the record that bank record that has zero. Either because of the zero, meaning no data to display, or because that bank record isn't valid in the relationship.
0
 
LVL 2

Author Closing Comment

by:rvfowler2
ID: 40215308
Yes, I was using the wrong TO by mistake, the one I used to calculate the summary fields for the current year.  Used an X relationship table in the portal and it appeared.  Thanks, Will.
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Pop up windows can be a useful feature of any Filemaker database.  Though best used sparingly, they can be employed in a multitude of different ways, for example;  as a splash screen at login, during scripted processes to control user input, as pick…
Having just upgraded from Filemaker 11 to Filemaker 12 over the weekend, we thought we would add some tips for others making the same move.  In general, our installation went without incident. Please note that this is not a replacement for Chapter 5…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

825 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question