Windows 7 Networking - Unable to stop password prompt

Hi Guys...

I'm having a problem with a client who recently replaced his old Win XP "server" with a Win 7 Pro. He also has new Win 7 Pro client machines replacing old XP machines, now 1 out 2 win 7 Pro machines connecting to the win 7 Pro server keeps asking for credentials.

All these machines are in the same Workgroup and have configured through "Advanced sharing settings" to "Turn on network discovery", "Turn on file and printer sharing" and "Turn off password protected sharing" amongst other settings to share.

So I came home and tried this setup on my Win 8.1 Standard desktop and Win 7 Home Premium laptop.

* Added both machines to same workgroup.
* Applied all the "Advanced sharing settings" as above to share without passwords.
* I could see share on the Win 8 machine from win 7 laptop without the need to enter credentials but couldn't see Win 7 shares from Win 8 desktop without entering remote username and password.
* Noticed laptop didn't have AV, installed Trend Micro + updates etc, both now running same AV. Rebooted both machines.
* Tried sharing - same as above, when trying to connect to Win 7 shares, kept asking for credentials.
* Disabled Windows FW on machines and rebooted, still the same Win 7 asks for password but Win 8 doesn't

It seems to be a "random" problem with Win 7 machines, the "Turn off password protected sharing" settings does not work, system keeps asking for Username & Password?
ErgsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mitchell MilliganInformation Technology Network AdministratorCommented:
Something you could try to do is to create an account on the computer with the share that exactly matches the username and password of the account you are trying to access it from.  Sometimes this works.  I am assuming you have tried checking the box that says "Remember Credentials"?
0
ErgsAuthor Commented:
On the Win 8 desktop I added the remote details into Credentials Manager and I connected without being prompted for credentials - is this the only way around problem?
0
Mitchell MilliganInformation Technology Network AdministratorCommented:
The credential manager is also a really good way to go, that will securely store your windows credentials, and that would work as well.  In effect, when you check the box that says "Remember My Credentials" it is storing those in the Credential Manager.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Mitchell MilliganInformation Technology Network AdministratorCommented:
If this answered your question, please be sure to mark this question as answered!  Thanks!
0
JohnBusiness Consultant (Owner)Commented:
When you turn OFF use user accounts and passwords, you turn ON Homegroup.

Have you got Homegroup running? and is it mismatched between machines?
0
Mitchell MilliganInformation Technology Network AdministratorCommented:
Don't use the homegroup, it is junk.  It is better off the way you have it with remembered credentials.  Homegroups muck up simple networking.
0
JohnBusiness Consultant (Owner)Commented:
I do not use Homegroup, but note my comment above. When you turn Homegroup OFF, you enforce user names and passwords. That is a better way to go however, as machines can be mismatched and share folders. I do that all the time.  However, some people like Homegroup and (set up properly) it does work reasonably well.
0
Gajendra RathodSr. System AdministratorCommented:
I recommended to create one user in all three machine with same password.

Access the share resource using this user credentials.
0
Scott ThompsonComputer Technician / OwnerCommented:
If all else fails with the Networking, go to Manage Credentials, clear them out on every machine, then reconnect and save.  A lot of times that helps me with these 'odd' issues.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.