Solved

[Win7, Goldmine5.5]  Buttons Missing from "OpenFile" DialogueBox

Posted on 2014-07-20
12
326 Views
Last Modified: 2014-07-20
O/S:           Windows 7, SPK 1
App:           Goldmine version 5.50 10424 April/2001

I'm in the process of moving my applications (including Goldmine) from an older PC (with Win2000) to a newer one (with Win7 and VirtualBox/XP). Although Goldmine works fine on the VM/XP side of the computer, I would prefer to use it on the Win7 side, however I am having a problem.

I want to open one of my existing databases.
I go to "File/Open"
I get the "Contact Set Databases" dialogue box.
It shows two databases:
       Description                     Access         Database/Location
       Common Contact Set     Public           C:\Program Files (x86)\Goldmine\Common
       Demo File                      Public            C:\Program Files (x86)\Goldmine\Demo

These two databases come as part of the initial Goldmine installation.

The following buttons appear at the bottom of the dialogue box:
(1) New
(2) Attach
(3) Delete
(4) Properties
(5) Open File
(6) Close

I can open either one of these databases with the "OpenFile" button.
However I want to open one of my own already-existing databases.

Normally you would click "Attach" and the wizard will let you browse to the location of the database and will let you add a Description for the database and let you choose what Access Rights to give, etc.

The problem is the Attach button is greyed-out.
Likewise for the Delete and Property buttons.

I also tried the following (after right-clicking the program icon), but to no avail:  
(1) Run as administrator
(2) Troubleshoot compatibility


As I said before, it works fine on the XP side, but I would prefer to use it on Win7.
Any suggestions would be greatly appreciated.

Gary
0
Comment
Question by:CE101
  • 6
  • 5
12 Comments
 
LVL 50

Expert Comment

by:jcimarron
Comment Utility
CE101 --
I am not sure Goldmine version 5.50 will run properly on Win 7.  Run it in Compatibility Mode for XP even when using Win 7.  Right click on .exe file|Properties|Compatibility tab| check"Run this program in Compatibility Mode for" and choose XP from the drop down list.
0
 

Author Comment

by:CE101
Comment Utility
Hi  jcimarron:

Thank you for responding.

> Run this program in Compatibility Mode

I tried it.
Same thing.

Any other suggestions?
0
 
LVL 11

Expert Comment

by:stevengraff
Comment Utility
It sounds like the GoldMine account you're using doesn't have Master rights.
0
 
LVL 11

Expert Comment

by:stevengraff
Comment Utility
If you log on all the way, then choose Help | About GoldMine, then click System, then scroll down, you'll see something like this:

Checking for Master rights...
Note the "Master" designation.
0
 

Author Comment

by:CE101
Comment Utility
Hi stevengraff:

Thank you for responding.

> It sounds like the GoldMine account
> you're using doesn't have Master rights.
> If you log on all the way...
> Note the "Master" designation.

In my case it shows:
       Logged User:   GARY  
Nothing about Master.

QUESTION:
(1) Do you have to be a Master to be able to attach a database?  
(2) Is this something unique to Win7?   Do forget that these buttons are not greyed out in my VM/XP.
(2) If I am not the master, who is?

I looked in C:\ProgramFiles(x86)\Goldmine and see the following INI files
(1) Gary.ini
(2) GM.ini
(3) GoldSync.ini
(4) Mike.ini

Note:  After installing GM on the new computer, I simply copied the Gary and Mike INIs from the old computer.

I remember that during the installation process there was something about a user name and it defaulted to the computer name. I don’t remember what I did. Perhaps I changed it to GARY.  Or I may have just blanked it out.    Was that the Master user??

Any suggestions would be greatly appreciated.
0
 
LVL 11

Accepted Solution

by:
stevengraff earned 500 total points
Comment Utility
If you just copied these files, that might be the problem. Look inside your gm.ini and see if you have pointers to your old location; especially, note the setting for sysdir.

You may want to try renaming your gm.ini, or deleting it.

Also, see if you can log in to GoldMine with the default master account: un=master, pw=access.

And yes, you do need Master rights for what you're trying to do.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:CE101
Comment Utility
Hi stevengraff:

> see if you can log in to GoldMine with the
> default master account: un=master, pw=access.
> And yes, you do need Master rights for
> what you're trying to do.

Thank you.

Ok, I did the following:
(1) Logged in as Master and attached the database
(2) Logged in as GARY - was able to open the database

I also tried to make GARY a Master, by logging in as Master, and going to  \File\Configure\ConfigureUserSettings.  However I was surprised to find that GARY does not appear in the list of users.  

I guess that’s because I didn’t go through the process of creating the user (I only copied in the INI file).

It's been so long since I've done this stuff, I guess I forgot the proper procedure.
0
 
LVL 11

Expert Comment

by:stevengraff
Comment Utility
GoldMine's files may be found in 3 principle places:

1.

The root, i.e. where the gmwN.exe lives.

2.

gmbase (below the root).

3.

contDBName (or whatever you've named it), (also below the root, normally, but could be wherever you've placed it upon creation, or manual move).
If you upgraded from a really old system you would not see a gmbase directory.

Your list of users would be in a file called users.dbf (plus .mdx), which you would find in either the root or gmbase folders.
0
 

Author Closing Comment

by:CE101
Comment Utility
Thank you very much for your help!!
0
 
LVL 11

Expert Comment

by:stevengraff
Comment Utility
You're quite welcome. :)
0
 

Author Comment

by:CE101
Comment Utility
Also thanks to  jcimarron.

I should have awarded him some points too. Unfortunately, by the time I closed the case I had forgotten there was more than one respondent. Sorry JCI.
0
 
LVL 11

Expert Comment

by:stevengraff
Comment Utility
I would say you awarded points properly, even if by accident. It would not have been right to award points to cimarron... his answer was off-base, and a waste of time if you pursued it. In fact, and I don't intend this as mean-spirited, for that reason, he should get negative points.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Decide what contact details to include in email signatures with these top 10 email signature contact details DOs & DON'Ts.
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum editing capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now