How to enable RPC on Windows Server 2008 R2?

Hi Experts,
I am not a regular 'server guy' but am trouble-shooting an issue where it appears RPC is not enabled on a Windows Server 2008 R2. It's a brand new installation so may not have everything turned on that has to be. With all the myriad screens for services, rules, features, permissions, roles, and you name it whatever other terminologies are called (my last experience was with Windows 2000 Server!) I'm somewhat overwhelmed.

Can someone explain how (or if it's even possible to configure) to enable RPC on Windows Server 2008 R2?
LVL 1
rascalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AkinsdNetwork AdministratorCommented:
Check the settings in services - it should be set to automatic, if not, set it.

Also check port 135 on firewall

Check DNS resolution

Is dotnet framework 3.5 enabled on the server role? If not enable it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rascalAuthor Commented:
Thanks Akinsd,
I will check the RPC server to ensure it's set to "automatic", and will check the firewall port 135.
What specifically should I check when you refer to "check DNS resolution" however?
and dotnet 3.5 is enabled on the server role.
0
AkinsdNetwork AdministratorCommented:
Try pinging the server by NetBIOS (eg SERVER1) name and also by fqdn (eg SERVER1.domain.local).
If pings are successful in both tests, then you can overrule DNS resolution
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

rascalAuthor Commented:
Thanks, and by the way, this whole issue came about since I was running TinyMCE (it's image manager) on the server and when attempting to view a folder, it clocked/timed-out and came back with a message: Server Error, produced by a source code file called rpc.js so I assume it was a remote procedure call issue since the website is an exact copy of the one on our test servers here in our office where the software runs fine.
0
rascalAuthor Commented:
More details: The rpc.js file contains the following code, where the "The server response wasn't JSON format" message is presented. It's actually trying to execute an ajax function(?) so are there other settings that need to be set on a Windows Server 2008 R2 to allow ajax to execute?

(function($){
      window.RPC = {
            pageBaseURL : document.location.href.replace(/[^\/]+$/, ''),

            init : function() {
                  $().ajaxError(function(e, req, se) {
                        if (req.status)
                              $.WindowManager.status({title : "The server response wasn't JSON format", content : req.responseText});
                  });
            },
0
AkinsdNetwork AdministratorCommented:
I'm going to assume that IIS is already enabled.

If it was working prior to crashing, try removing and re-installing the following
- IIS
- Dot net framework (2 or 3 or 4 or all as desired)

You may also try installing the Ajax plugin for aspx
http://www.microsoft.com/en-us/download/details.aspx?id=883
0
rascalAuthor Commented:
We discovered that the problem was caused by the file ModCloudFlare. When we disabled that we were able to get into our admin side of the WordPress site . We removed and reinstalled the iThemes security plugin just in case, although from the log files it looks like just ModCloudFlare was the culprit.
0
AkinsdNetwork AdministratorCommented:
Great!
Glad to hear that
0
rascalAuthor Commented:
The actual problem was external (see last comment by Rascal) but your response was completely appropriate. Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.