Indexing problem

I am trying to set up a full text search on a table in SQL Server 2008 R2.  My table looks like this
Table.jpgAccording to what I have read I need to create a "unique, single-column, non-nullable index".  When I try to create the index on the FText field everything is grayed out so I cannot do it.

How do I proceed?
LVL 3
jdthedjAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

duttcomCommented:
You have "Allow nulls" checked - making that field nullable and therefore not suitable to be an index.
0
duttcomCommented:
Also, the single column index means that only one column should be the index. It looks like you have two and are looking at adding a third. Assuming CNum is some sort of unique number then that should be your primary key - the 'unique, single column, not-nullable index'.

You can then add other indexes (which are not primary indexes) separately by going into your table design, right clicking and then choosing one of the other index types (Indexes/keys) from the list. That way you can set different combinations of fields to be included in your unique index (e.g. FName and FYear cannot have the same combination of values in any record) without making those fields primary keys.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jdthedjAuthor Commented:
Thanks for the reply duttcom - In the management studio, when I click on Indexes, the new index option is still grayed out after removal of the allow nulls
0
jdthedjAuthor Commented:
Sorry - didn't see your 2nd comment.
0
jdthedjAuthor Commented:
Thanks very much!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.