Permit personal workstation to relay mail with sendmail

I am self-hosting my domain email on Linux using sendmail. I want my laptop to be able to use this email server as the smtp/pop server, including being able to cc: to other recipients.

I've set up the Outlook outgoing server to require authentication and I've put my Linux ID and password in the "Log on using" section. This permits mail send from my laptop to be delivered to my Linux account, but anyone I cc on some other domain gets reject with "relaying denied".

How do I fix this?
LVL 1
jmarkfoleyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jan SpringerCommented:
modify /etc/mail/access and add your internal subnet:

i.e.,
  Connect:192.168.1                  RELAY

when done:

  makemap hash access < access
0
jmarkfoleyAuthor Commented:
Hmmm, is there nothing else to filter on? The Outlook client is a laptop which can travel and may get different IPs.
0
Jan SpringerCommented:
then you need to configure SMTP AUTH by creating a self-signed certificate, installing sasld and modifying the sendmail.mc to reflect the changes.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jmarkfoleyAuthor Commented:
Well, I guess I need some help setting this up. I've created a certificate using CAcert.org, which I've used successfully before. And I've configured sendmail as I've done before. According to checktls.com, I'm OK.
However, My Android mail program says
Username or password incorrect.
(535 5.7.0 authentication failed)

Open in new window



I've run `saslauthd -a shadow` and the user is in the /etc/shadow file. I've re-enter the userid and password multiple times. I'm *sure* it is correct.

Any idea how to fix this?
0
jmarkfoleyAuthor Commented:
I figured out all of Jan's "things I need to do" on my own.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.