Solved

SCCM 2012 config manager r2 - Pxeboot to deploy captured o.s- confused..

Posted on 2014-07-21
22
741 Views
Last Modified: 2014-09-05
Hi

i have managed to make some progress with my SCCM 2012 server after sp1 didn't work - so uninstalled waik 8.1 and config manager 2012 r1 and reinstalled waik 8.1 and config manager 2012 r2

lab setup
1.)desktop (server) - 2,)switch - 3,) laptop
sql 2012
server 2012
waik8.1
sccm 2012 config manager r2

I have configured my dhcp scope, created a boot cd and captured an image from a vanilla win 7 64 bit machine - confirmed this has worked as it's uploaded to my server.

Now after capturing the image I have formatted the hard drive, to test my image, so i wish to deploy it from the server back down to the laptop..

However I am getting mixed information about ports 60/66/67 I think under dhcp they need to be configured or unconfigured for pxe??

My machine is picking up the dhcp scope when i try to do a pxe boot but then fails.

I have checked my server 2012 config/roles and wds is installed.

I know the hardware is fine as I've done a capture, windows firewall is disabled and no anti virus programs are installed.

My server has 3 roles all on the same box - server 2012, sql 2012 and sccm config manager 2012 r2.

Are there any instructional s for complete rookies out there?

Many thanks.
0
Comment
Question by:Michael Murphy
  • 14
  • 6
22 Comments
 
LVL 28

Expert Comment

by:Michael Pfister
Comment Utility
Do you have a OS deployment Task Sequence advertised to the collection containing your system you're trying to boot via PXE?

Also check http://gerryhampsoncm.blogspot.de/2013/02/sccm-2012-sp1-step-by-step-guide-part_18.html
0
 
LVL 16

Expert Comment

by:vivigatt
Comment Utility
The usage of DHCP options 60, 66 and 67 with PXE system is simple but people are confusing.
- WITHOUT a real PXE server, you MUST NOT specify DHCP option 60 and you MUST specify DHCP option 67 (boot file name). Option 66 (TFTP server's IP address) is optional: if you don't specify it, the PXE specification states that it will consider that the DHCP server is also the TFTP server.
- WITH A REAL PXE SERVER/SERVICE, you must NOT specify DHCP options 66 nor 67, as this is precisely the role of the PXE Server to send these details (TFTP server's IP address and boot-file name) to the requesting node. You MAY have to specify DHCP option 60 and set it to "PXEClient" ONLY if the PXE Service runs on the same host on which the DHCP service runs too.

In your case, since there is only one server (I assume that your lab network is isolated), DHCP and PXE services runs on your "server" (desktop) and then you must set DHCP Option 60 to "PXEClient" . If that is not the case (you don't mention DHCP server, as one of the roles for your server), you must not set DHCP option 60.
If any case, if your WDS/SCCM role runs OK, it includes a real PXE service (that must be configured or tuned) and a tftp service too, so it is useless (and can cause issues) to specify DHCP option 66 and 67.

You can find more details about all that in my article (and the comments I made to it):

http://www.experts-exchange.com/Networking/Misc/A_2978-PXEClient-what-is-it-for-Can-I-use-PXE-without-it.html
0
 

Author Comment

by:Michael Murphy
Comment Utility
hi everyone

mpfister - will check that too

vivigatt- thanks for this explanation this is what someone had been talking to me about, and ... in all guides i could not find this - this is a good explanation in laymans /newbies terms.

I think your key definition of live/and lab enviroment helps.

My lab enviroment is isolated/ring fenced so if i mess up i don't affect anyone/anything. the lab  has DHCP configured on the same box as server 2012 , this is where i setup the scope.

I did also configure this under dhcp but have not done anything for port 60 nor checked that .

066   IP Address of WDS Server
 067   smsboot\x86\wdsnbp.com

http://www.windows-noob.com/forums/index.php?/topic/6353-using-system-center-2012-configuration-manager-part-7-build-and-capture-windows-7-x64-sp1/ - this was referenced elsewhere on e.e I think and basically someone said this would get pxe issues fixed  - so I am walking through this as a reference and double checking if i've done these tasks, if the tasks aren't required I am just doing them anyway!

These are the pxe errors on the test lab laptop when trying to pxe boot

pxe-e11 arp timeout
pxe-e30 tftp cannot open connection
pxe-m0f Exiting pxe

some other information has also come through to me from key points that may /may not be covered elsewhere

1.) The main thing was not documented at that time “Windows Deployment Services” should be installed. SCCM installation did not install it and did not complain it is not installed.

2.) Second important thing is that all custom solutions (i.e. Windows distribution) should be accessible via network for system(s) account. So I granted read access to Authenticated Users.

3.) Also not documented and critical steps as are (see the attached): a cut and paste from my friend

29. Uncheck “Configure task sequence for use with BitLocker)”.
35. Uncheck all options
40. Collection: Browse >> select “All Systems” >> OK (if not “All Systems” then this step required a complex pre-configuration and computer discovery setup)
45. Check all options
47. Check all options

The important configuration areas:
•         Software Library > Operating Systems > Boot Images (distributed once at setup of SCCM)
•         Software Library > Operating Systems > Operating System Images (Windows native or custom .WIM distributions)
•         Software Library > Operating Systems > Task Sequences (should be created, deployed and distributed)

I did configure this under dhcp

066   IP Address of WDS Server
 067   smsboot\x86\wdsnbp.com

This is what I am going to triple check along with the windowsnooblink.

Apologies if all this information maybe duplicated, just not had a chance to run through and check doc vs doc .
0
 

Author Comment

by:Michael Murphy
Comment Utility
Also to add i captured my vanilla machine via capture media boot disk which was created from the sccm server and which then uploaded up to the server.

Is this the best way to do it or are there other ways - not trying to get off subject i feel people maybe advising doing it other ways unless I am mistaken in these docs?

Thanks all.
0
 
LVL 16

Expert Comment

by:vivigatt
Comment Utility
If I read correctly, your DHCP and PXE service runs on the same host. So you must set DHCP option 60 (String, "PXEClient") and you should unset options 66 and 67, provided that there is no issue with your PXE service (provided by WDS, even if some options in SCCM installation can also install it).

Your PXE error (e11) means that the PXE client can't resolve the TFTP server (or ProxyDHCP server) IP address to a MAC address.

First thing to check: your switch(es) must be configured so that STP (spanning tree protocol) is set to Portfast or disabled (Portfast is a better choice):
http://www.dummies.com/how-to/content/spanning-tree-protocol-stp-and-portfast.html

You can also check these links:
https://www.bootix.com/support/problems_solutions/pxe_e11_arp_timeout.html
http://blogs.technet.com/b/system_center_configuration_manager_operating_system_deployment_support_blog/archive/2011/10/14/troubleshooting-the-pxe-service-point-and-wds-in-configuration-manager-2007.aspx
http://h18013.www1.hp.com/products/servers/management/rdp/knowledgebase/00000138.html
0
 

Author Comment

by:Michael Murphy
Comment Utility
Thank you vivigatt, i will check your points hopefully in next 24 hours before i go on holiday.

you have understood my scenario 100% and questions, so i will configure port 60 and unconfigure ports 66 and 67.

and then take a look at stp and pxe e11 arp timeout.

Thanks !
0
 

Author Comment

by:Michael Murphy
Comment Utility
Hi.just to.clarify. do you.think there .maybe a problem with.my Cisco switch.which has been fine uploading the .win file.capturecapture. I can swap.this.for.Another switch or hub that will be basic and in configured. Thanks
0
 

Author Comment

by:Michael Murphy
Comment Utility
Hi

I removed ports 66,67 and tried to add 60 via this command

netsh dhcp server \\<DHCP_server_machine_name> add optiondef 60 PXEClient String 0 comment=PXE support
netsh dhcp server \\<DHCP_server_machine_name> set optionvalue 60 STRING PXEClient

It is saying command line is not found.

This is word for word what I typed

netsh dhcp server \\server2012test add optiondef 60 PXEClient String 0 comment=PXE support
netsh dhcp server \\server2012test set optionvalue 60 STRING PXEClient

server2012 is the hostname of my sccm server.


I followed this command from

http://blogs.technet.com/b/system_center_configuration_manager_operating_system_deployment_support_blog/archive/2011/10/14/troubleshooting-the-pxe-service-point-and-wds-in-configuration-manager-2007.aspx

My colleague told me to do a custom port add via dhcp manager instead, but I can't find this. - not getting much help from colleagues.
0
 

Author Comment

by:Michael Murphy
Comment Utility
hi vivgatt pls ignore previous post - the problem was because I had dhcp manager open and the below commands wouldn't run - I managed to run these two command lines

netsh dhcp server \\server2012test add optiondef 60 PXEClient String 0 comment=PXE support
 netsh dhcp server \\server2012test set optionvalue 60 STRING PXEClient

They worked fine !

mpfister - re ran thru this and I have done this task too

http://gerryhampsoncm.blogspot.de/2013/02/sccm-2012-sp1-step-by-step-guide-part_18.html .

now have this error message which is different.

pxe-e55: proxy dhcp services did not reply to request on port 4011

so had a look at the link you kindly provided -

http://h20565.www2.hp.com/portal/site/hpsc/template.PAGE/public/kb/docDisplay/?spf_p.tpst=kbDocDisplay&spf_p.prp_kbDocDisplay=wsrp-navigationalState%3DdocId%253Demr_na-c04022688-1%257CdocLocale%253D%257CcalledBy%253D&javax.portlet.begCacheTok=com.vignette.cachetoken&javax.portlet.endCacheTok=com.vignette.cachetoken

so used google.: -

http://social.technet.microsoft.com/Forums/windowsserver/en-US/3747b974-ba4f-41e4-abd9-a2e7a38e994b/pxee55-proxydhcp-service-did-not-reply-to-request-on-port-4011-on-physical-machines?forum=winservergen

https://www.bootix.com/support/problems_solutions/pxe_e55_proxydhcp_service_did_not_reply_to_request_on_port_4011.html

tells me

CAUSE

The "PXE-E55" error indicates that the PXE client has sent a request to the proxyDHCP server on port 4011, but did not receive a reply. This problem can only occur when the DHCP Class Identifier Option #60 is set on the DHCP server, but there is no proxyDHCP service running on port 4011 on the same machine.

RESOLUTION

If you are operating DHCP and proxyDHCP services on different machines, do not set the DHCP Class Identifier Option #60 in the DHCP configuration, and let both services run on port 67/udp (bootps).

If you are operating DHCP and proxyDHCP services on the same machine, set the DHCP Class Identifier Option #60 in the DHCP configuration. Let the DHCP service run on port 67/udp, and the proxyDHCP service on port 4011/udp.

so now even more confused?

opened up 60 and deleted 66,67 .

Now told here

 Let the DHCP service run on port 67/udp, and the proxyDHCP service on port 4011/udp.

Appreciate everyone's help big time - will check in whilst on holiday.
0
 
LVL 16

Expert Comment

by:vivigatt
Comment Utility
You now need to have a proper PXE (ProxyDHCP) running on the server. WDS has one.
You need to configure it so that it is bound to the correct interface and so that it serves your PXE client.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:Michael Murphy
Comment Utility
hi

back from holiday to a mountain of work so only got to try today.

i have made progress but everything has been a red-herring/wild goose chase.

ok - actions taken

tried with ports 60,66,67 all enabled in dhcp - vivigat appreciate your post but there still seems to be alot of conflicting info out there - you are more technical than me but i've just had to try with all of this enabled.

I've swapped out switch - nothing to do with this - used a basic netgear switch - nothing to do with switch - same error..

tried to troubleshoot via telnet to test port 4011 - no reply...

tried another laptop - no difference.

Then a eureka moment ! - rechecked wds service - was not running - tried various workarounds - didn't work...

Then found this.

http://www.windows-noob.com/forums/index.php?/topic/9368-wds-service-crashing-not-starting-sccm-2012-r2/

I applied hotfix kb2910552 .

Now I am NOT getting the pxe error 55 and the laptop/s are connecting to the server. !

However the image isn't deploying it runs the scheduled task and wants to download etc, authenticates with the credentials, and then fails with error -

Failed to run task sequence - an error occured etc. etc. (0x80004005)

This appears to be a generic error message.

When I retry it won't work at all and I think this is because i have to remove the machine from a collection (re-arm) for deployment before re-trying and this details will be cached on the server - if my memory is right.

Same thing happens on both laptops after failing the task sequence.

Now the error message is. abortpxe.com contact administrator.

Thanks everyone.
0
 
LVL 16

Expert Comment

by:vivigatt
Comment Utility
OK, so now you have your PXE Portion working.
(Note that I told you to check that you had a PXE service running and that WDS had one).
You could remove dhcp option 66 and 67, they may cause issues in the future, especially if you want to deploy x86 and x64 images, since the NBP will not be same for each architecture.

If I remember correctly, 0x80004005 is related to access being denied to some resource (file, folder, database...)
Try to explore this path.

If you can read French, this page has some useful details:
http://www.revuedugeek.com/post/2010/10/06/Resoudre-les-erreurs-MDT-2010-80004005

This one:
http://scexblog.blogspot.fr/2013/09/failed-to-run-task-sequence-error.html
says that you have to check BIOS date and time and make sure they are accurate

I assume that now your WinPE environment is downloaded and executed and the error is happening before the image-to-be-deployed is accessed by WinPE. But if you can confirm that, it would be good to make some progress.

You can, if you suspect some issue with the deployment of your WinPE image, put said WinPE image onto a bootable USB stick, boot it from there and see if you get the same error. This page explains how to do that:
http://blogs.ethz.ch/jlaville/2012/04/12/how-to-deploy-windows-7-on-non-pxe-ultrabooks-with-mdt-litetouch/

(the page also explains the boot sequence that is commonly used for deploying Windows over the network, and that was used with RIS then WDS then MDT)
0
 

Author Comment

by:Michael Murphy
Comment Utility
Hi vivigat

I used to speak very basic french but no in 20 years ! I will try and use google to translate. merci.

Re testing the .wim filles I am trying to use the method above but it;' that i think is the old version of waik 8.0.

8.1 doesn't have these files.

however... Image X can restore .wim files can't it for WDS/SCCM 2007/2012? Not seen any bootcd s for that anywhere and never used it as always used clonezilla, altiris and ghost but can try and source.

BIOS and time in synch and correct.

http://scexblog.blogspot.fr/2013/09/failed-to-run-task-sequence-error.html is what I will take a look at while trying to find/make an image x cd if that will work?
0
 

Author Comment

by:Michael Murphy
Comment Utility
0
 

Author Comment

by:Michael Murphy
Comment Utility
0
 

Author Comment

by:Michael Murphy
Comment Utility
Hi

i managed to make a bootable usb stick with image x on it, and have copied to the 3 .wim files down to the usb stick to restore from.

1 of the .wim files is the original capture I did of a base build machine with 2 additional basic apps - I've got this restoring fine via imagex... - this is clearly labelled up capturedtestmachine.wim - this file win764bitenterprise with 2 apps and approx 3gb

2 of the other files are

boot.wim
boot.01000005.wim

Both of them  are under 300 mb and appear to be corrupt/useless.

So this error message may relate to corrupt standard images for windows 7 32/64 bit.

The bit i don't understand is if my standard images/wim files are corrupt and this is the problem why can't i just use via SCCM PXE the file that is good and tested and working??

If I need to close this thread and open a new thread please advise - new to experts exchange.

Many thanks.
0
 

Author Comment

by:Michael Murphy
Comment Utility
Hi

I have now fixed the problem.

dns reconfigured in dhcp manager and re-set boundaries - all now working ok.
0
 

Author Comment

by:Michael Murphy
Comment Utility
I've requested that this question be closed as follows:

Accepted answer: 0 points for Michael Murphy's comment #a40242100

for the following reason:

Provides some assistance/pointers that assisted me getting there in the end.
0
 
LVL 16

Accepted Solution

by:
vivigatt earned 500 total points
Comment Utility
No points awarded for those who took time to educate the author and helped him solving his issue?
That does not seem very fair...
0
 

Author Closing Comment

by:Michael Murphy
Comment Utility
Merci beuchop vivigatt.

I am new to experts exchange and had to google how to give you points!!

If by any chance you are near bolougne/calais there is a beer or two waiting for you as I am in france this weekend !

On a serious note, I think there could some very basic checklists/idiot guides for newbies out there - just clear bullet points for basic
things to check as SCCM is a headache - walkthroughs maybe great, but really a little checklist/test process to narrow down the issue would help newbies .

Log file are great, but what happens when even basic things are not working???

As  a further update, I've now exported/imported live packages into my test environment, and will be working on some packages. my test environment works with live packages that have been imported, and the discovery is working too.

Again thanks to everyone on here on helped - even with experts assisting and I am not lazy it has been quite rewarding getting this far.
0
 
LVL 16

Expert Comment

by:vivigatt
Comment Utility
I am near Boulogne/Calais, otherwise, it would have been a pleasure to meet you.
I agree, SCCM is quite complex (and I mainly focus on the bre-boot and pre-Install portions !)

Thanks for the points
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Every now and then, Microsoft does something that totally impresses me. It doesn't happen often, but in this case I must say I am thoroughly impressed with Windows Server Backup. One of the long time issues with Windows Backup has been the ability t…
The article will show you how you can maintain a simple logfile of all Startup and Shutdown events on Windows servers and desktops with PowerShell. The script can be easily adapted into doing more like gracefully silencing/updating your monitoring s…
In this Micro Tutorial viewers will learn how to restore their server from Bare Metal Backup image created with Windows Server Backup feature. As an example Windows 2012R2 is used.
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now