Solved

Railo configuration

Posted on 2014-07-21
19
419 Views
Last Modified: 2014-07-25
I have just installed Railo and the URL that I use to get my home page to display is:

http://localhost:8888/index.cfm

the problem that I am having is that my relative links are not preserving the :8888 and so my page doesn't work.

For example, if I try to use:
http://localhost/index.cfm?page_id=56&menu_id=60&Label=Terms%20of%20Use

I get an error but if I use
http://localhost:8888/index.cfm?page_id=56&menu_id=60&Label=Terms%20of%20Use

the page displays fine. How do I preserve the :8888 in my relative URLs

Thank you.
0
Comment
Question by:WestCoast_BC
  • 11
  • 8
19 Comments
 
LVL 6

Expert Comment

by:rjohnsonjr
ID: 40210262
If the link is actually

<a href="/index.cfm?page_id=56&menu_id=60&Label=Terms%20of%20Use">My Link</a>

Open in new window


or

<a href="index.cfm?page_id=56&menu_id=60&Label=Terms%20of%20Use">My Link</a>

Open in new window


it should preserve the URL.  Can you confirm this is how you have your links set up?
0
 

Author Comment

by:WestCoast_BC
ID: 40210272
My link looks like:
<a href="index.cfm?page_id=56&menu_id=60&Label=Terms%20of%20Use">My Link</a>

but it does not preserve localhost:8888

it just uses localhost and then my page does not display
0
 

Author Comment

by:WestCoast_BC
ID: 40210275
Do I need to configure my IIS Manager?
0
 

Author Comment

by:WestCoast_BC
ID: 40210354
I removed a mapping that I had set in the Railo Admin so now my URL looks like:

http://localhost:8888/portal/_SampleSites/MySite/index.cfm

Problem is that now when I try to load a JS file using a relative link it tries to use the URL:

http://localhost/js/popup.js

Not only does it not preserve the :8888 after the localhost but it also loses the path information (../portal/_SampleSites/MySite/..).

Is there some configuration that I am missing. I also have ColdFusion server installed on this computer but it is not currently running. When I use it my site displays without problems.
0
 

Author Comment

by:WestCoast_BC
ID: 40210377
I have also tried copying all of my source to the Railo Root directory (../webapps/ROOT) and I get the same problem. Is there a way for me to point localhost to the correct location so if I use it without :8888 it still works?
0
 
LVL 6

Expert Comment

by:rjohnsonjr
ID: 40210524
You have 2 options for that.

1.  Configure IIS for the front end.   Installing from the railo installer will install the iis connector.

2.  If you want to use Tomcat / Jetty as the web server you just have to dive into the config files and change it from port 8888 to port 80.  If you tell me how railo is installed I can point you to the correct file or you could use a program like notepad++ or editplus to search all the files in the railo directory for 8888 and change to 80.  Restart railo and you are good to go.
0
 

Author Comment

by:WestCoast_BC
ID: 40210677
Thanks - How do I configure IIS?
0
 
LVL 6

Expert Comment

by:rjohnsonjr
ID: 40210683
Install railo from the officiall installer and it has the option to install the connector for you.  I will research more detail for you tomorrow.
0
 

Author Comment

by:WestCoast_BC
ID: 40210710
I have installed Railo Express and it did not give me an option to install the connector.  Do I need to install the full version of Railo?
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
LVL 6

Expert Comment

by:rjohnsonjr
ID: 40211320
Yes, definitely.  Install the full version.  Let me know if you have any hiccups.
0
 

Author Comment

by:WestCoast_BC
ID: 40211735
Instead of installing the full version can I change my Railo configuration to use port 80 instead of 8888? If so do I need to change the start.bat file to read:

"jre/bin/java" -DSTOP.PORT=8887 -DSTOP.KEY=railo -javaagent:lib/ext/railo-inst.jar -jar start.jar --module=http jetty.port=80

and do I need to edit the jetty.xml file and add the line:

<Set name="port"><Property name="jetty.port" default="80"/></Set>

Is there anything else that I need to do or is this not possible? When I made the above changes and try to access my site I now get the error:

HTTP Error 404.3 - Not Found
The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.
0
 
LVL 6

Accepted Solution

by:
rjohnsonjr earned 500 total points
ID: 40211760
well if you are going to use jetty as the web server you have to turn off IIS or setup IIS entries to listen on a different port than 80.
0
 

Author Comment

by:WestCoast_BC
ID: 40211802
I am not very knowledgeable with setting this up and I am not sure what I need. I just noticed that I had IIS setup and it was using port 80 which is why I thought I might need to change my Railo to use port 80 as well.  How do I know if I am using jetty or IIS as my web server? I just use the start.bat that was installed with Railo to get it started. I don't think my changes are correct since I now can't get Railo to start so I am undoing the changes mentioned in my previous post
0
 
LVL 6

Expert Comment

by:rjohnsonjr
ID: 40211832
You already told me you used Railo Express.  You need to uninstall that and install the normal railo installer.  That will setup the connector from IIS to railo to allow you to use port 80.  The railo installer is easy to do.. basically you just need to choose the defaults but make sure you click the option to setup the iis connector.
0
 

Author Comment

by:WestCoast_BC
ID: 40211870
Thank you but I now have it working with Railo Express so I will continue to use what I have now. I may try in the future to install the full Railo but for now I will keep what I have since it does seem to work.
0
 
LVL 6

Expert Comment

by:rjohnsonjr
ID: 40211966
ok cool. as long as you are up and running!
0
 

Author Comment

by:WestCoast_BC
ID: 40220028
To recap: To get Railo to work I disabled my IIS and I changed the port that Railo was using from 8888 to 80 by modifying start.bat to be:

"jre/bin/java" -DSTOP.PORT=8887 -DSTOP.KEY=railo -javaagent:lib/ext/railo-inst.jar -jar start.jar --module=http jetty.port=80
0
 

Author Comment

by:WestCoast_BC
ID: 40220038
I've requested that this question be closed as follows:

Accepted answer: 0 points for WestCoast_BC's comment #a40220028

for the following reason:

I solved my own problem
0
 
LVL 6

Expert Comment

by:rjohnsonjr
ID: 40220039
I suggested the author's resolution in #2 of response above:  2014-07-21 at 20:48:17 ID: 40210524
0

Featured Post

3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

CFGRID Custom Functionality Series -  Part 1 Hi Guys, I was once asked how it is possible to to add a hyperlink in the cfgrid and open the window to show the data. Now this is quite simple, I have to use the EXT JS library for this and I achiev…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now