• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 399
  • Last Modified:

Windows server 2003 internet time error

windows server 2003 is unable to sync with the time server provided. I've tried different time servers, but i still keep getting the error message "An error occurred while Windows was synchronizing with xxx.xxx.xxx.xxx. The time sample was rejected because : The Peer is not synchronized, or it has been too long since the peer's last synchronization.
0
Adelaido Jimenez
Asked:
Adelaido Jimenez
  • 4
  • 4
  • 2
1 Solution
 
Hypercat (Deb)Commented:
Make sure that the time set manually on the Windows 2003 server is relatively close to the actual time and that the time zone is set properly.  Also, when you specify the time server, make sure you use the 0x8 tag, for example:

time.nist.gov,0x8
0
 
Hypercat (Deb)Commented:
Correction: I think you need to use 0x1 on Windows 2003 for the tag, not 0x8.
0
 
Adelaido JimenezDevOpsAuthor Commented:
I have already tried the configuration and the server keeps throwing the error "An error occurred while Windows was synchronizing with xxx.xxx.xxx.xxx"
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Hypercat (Deb)Commented:
Are you trying to sync with an internal time server (i.e., a domain controller on your domain), or with an external server?  Here's an article that may help if this is an internal problem:

http://technet.microsoft.com/en-us/library/cc757610(v=WS.10).aspx
0
 
Adelaido JimenezDevOpsAuthor Commented:
I'm trying to sync with an external server. I've tried for external and internal servers, but they all give me the same error. I disabled my firewall, but that didn't help either. I also did a ping test and the IP's for the time servers I tried replied just fine.
0
 
gurutcCommented:
Hi,

Configure the gold standard time sources, not microsoft use these:

tick.usno.navy.mil
tock.usno.navy.mil

Then use this utility to change the update interval to a default of 8 hrs.

Change Internet Time Interval Utility

Also check to make sure both port 37 and 123 are open on the firewall.

Good Luck,
- gurutc
0
 
gurutcCommented:
Also, a break in the Time Sync Heirarchy can occur, you can fix this by saving this text below to a .REG file and merging it to your registry:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DateTime\Servers]
@="0"
"0"="tick.usno.navy.mil"
"1"="tock.usno.navy.mil"
"2"="time.windows.com"
"3"="time-b.nist.gov"
0
 
Hypercat (Deb)Commented:
Another hint - rather than using "time-b.nist.gov" as gurutc mentioned, you can just use "time.nist.gov."  This time server address actually works as a round-robin for all the NIST time servers, so you're pretty much assured of always being able to connect to one:

http://tf.nist.gov/tf-cgi/servers.cgi

And be sure to open UDP port 123 on the firewall, not TCP.
0
 
Adelaido JimenezDevOpsAuthor Commented:
I got my server to sync with our internal NTP server. For some reason it wont let me sync with any other outside server. For now my issue has been solved, but I don't get why its not letting me sync with outside servers.
0
 
Adelaido JimenezDevOpsAuthor Commented:
Got NTP server working with internal NTP server
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now