making t38modem work with asterisk and Hylafax on Linux system

I am trying to set up t38modem on an asterisk 11 system with Hylafax.  The system is fully working with IAXmodem but I find I am getting too many errors.  I have successfully compiled the latest version of t38modem and it appears to run properly.  I have it registered to SIP and working with faxgetty.  My problem is that I can't get it to successfully connect with another fax.  I keep getting 'busy signal detected' errors when sending even though the call goes through and the other end answers.  I also get 'no carrier detected' when receiving.  It appears to be a configuration issue but I can't find very much information on configuration.  I am looking for the proper parameters to use in launching t38modem and setting up the faxgettys.  Thank you.
jaym25Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PhonebuffCommented:
Make sure your SIP provider is support T38..  Many still do not --
0
jaym25Author Commented:
Thank you,  However, the problem I am having is with the setup.  I am using a gateway with analog lines and t38 capability and I want to get it working with that first.  I just can't find a resource that explains how to set up the t38modem parameters with Hylafax and Asterisk and how to startup the t38 and faxgetty daemon processes where t38modem will actually complete a call.

It appears that you must start multiple T38 tty's per t38modem instance and link them together.  It also appears that you are only allowed to make 1 SIP assignment per instance even though it appears you've created 2 or 3 separate modems for each instance.  This part is very different from the way IAXmodem works and is the part I don't understand.

If you don't have an answer, perhaps you can point me to a resource or a person who may be able to explain or assist.  Thank you.
0
PhonebuffCommented:
Well based on your description I am a little confused --  

Are you defining the ATA (is it T-38 Enabled) as a trunk or as an extension ?  

As a Trunk standard out bound routes would apply, as an extension maybe a Ring Group round robin ..

For detail support check out the mailing lists at http://www.hylafax.org/content/Main_Page.  

-----------------------  Hope I helped.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

jaym25Author Commented:
I have read the Hylafax information top to bottom and actually have Hylafax working very well with the T-38 enabled FXO gateway and IAXmodem using individual line selections as opposed to round robin.  I am not trying to create a high volume fax server.  I simply want 2 or 3 lines that work well through my system to take advantage of email2fax and fax2email features which I have implemented in my integrated system.  The logic works properly, with both Asterisk and the gateway (a Grandstream GXW4108) .

The problem I am having is a high number of communications failures that seem to be common with IAXmodem (an analog soft modem using spandsp) on an IP system.  I tried using Asterisk's T-38 Gateway mode with IAXmodem but that doesn't seem to give much improvement.

It is my intention to have t38modem replace IAXmodem to take advantage of Asterisk 11's t38 pass-through capabilities.  My specific problem is the proper configuration of t38modem for which I can find very little information.
0
PhonebuffCommented:
Sorry, I am a basic user and use it incoming fax2email only.   However when I have issues I need to resolve a post to the hylafax-users  list at the site usually get's me the fastest answers.  

=======
0
jaym25Author Commented:
For now, I have decided to stay with IAXmodem.  It is working pretty well.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jaym25Author Commented:
Never was able to get T38modem working properly.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IP Telephony

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.