Solved

cisco 1700 router

Posted on 2014-07-21
36
452 Views
Last Modified: 2014-08-19
cannot connect to the internet wireless through verizon actiontec router

The Dhcp is working on spare card when plugged into router. but I would rather laptop get dhcp from wireless.  What am I missing?

here is my setup:

int fa0
ip address 172.168.1.1 255.255.255.0
no shut

int fa2 (DHCP)
switchport mode access
switchport access vlan 5

ip dhcp excluded-address 192.168.5.1 192.168.5.99
ip dhcp pool Users
network 172.168.5.1 255.255.255.0
default-router 172.168.5.1
dns-server 4.2.2.2

access-list Users permit 172.168.5.0.0.0.0.255
ip nat inside source list Users interface fastethernet 0/1 overload
int fa0
ip nat inside
int fa0
ip nat outside
0
Comment
Question by:moman1961
  • 14
  • 7
  • 7
  • +2
36 Comments
 

Accepted Solution

by:
moman1961 earned 0 total points
Comment Utility
points increased for replies
0
 
LVL 17

Expert Comment

by:Garry-G
Comment Utility
Are you sure you copied your config excerpts correctly and complete? e.g. the fa0 nat lines at the end don't seem right ... I reckon the latter is fa0/1
Also, where is the wireless connected to? In the same LAN broadcast domain as fa0? If you configure a wireless client with fixed IP, can you reach the router on its LAN ip?
0
 

Author Comment

by:moman1961
Comment Utility
sorry fa1 is outside fa0 is inside for nat.  I also wanted to know is their anything I need to do with the router in terms of configuration?
0
 
LVL 45

Expert Comment

by:Craig Beck
Comment Utility
Please provide the full config... as Garry said, it's not complete so we can't see what's wrong.
0
 
LVL 17

Expert Comment

by:Garry-G
Comment Utility
in general, DHCP on a Cisco router (or most anywhere) is pretty much straigthforward, so if you have the right netmask/subnet matching your LAN segment, and the packets get through, it ought to work ... do check the fixed IP and reaching the router to ensure your wireless network is actually working ....
0
 
LVL 17

Expert Comment

by:Garry-G
Comment Utility
Also, this line is most likely wrong:

 ip nat inside source list Users interface fastethernet 0/1 overload

as there isn't a fa0/1 ... (unless you also have an additional WIC in the router)
0
 

Author Comment

by:moman1961
Comment Utility
Here is my configuration.

int fa0
ip address 172.168.1.1 255.255.255.0
no shutdown
exit

int fa1
ip address 108.251.52.62 255.255.255.0
no shutdown

interface vlan5
ip address 172.168.5.1 255.255.255.0
ip nat inside
no shut
exit

interface fa2
switchport mode access
switchport access vlan5

ip dhcp pool Vlan5
ip dhcp excluded-address 172.168.5.1 172.168.5.99
network 172.168.5.0 255.255.255.0
default-router 172.168.5.1
dns-server 4.2.2.2
no shut

interface fa0
ip nat inside
exit

interface fa1
ip nat outside
exit

access-list Vlan5 permit 172.168.5.0  0.0.0.255
ip nat inside source list Vlan5 interface fa1 overload
exit
0
 
LVL 17

Expert Comment

by:TimotiSt
Comment Utility
As the 1700 series doesn't support wireless (afaik), where does the other router/wireless come into play?
Also, +1 for the config: it doesn't seem like a full/cisco running/startup config. Can you dump a full "show running"?

Tamas
0
 
LVL 45

Expert Comment

by:Craig Beck
Comment Utility
The 1700 only has one FastEthernet interface unless you put a ESW module in it.  Is that what you have?
0
 
LVL 15

Expert Comment

by:deepdraw
Comment Utility
Here is my 1760 show ip int brief
FastEthernet0/0            192.168.0.1      YES NVRAM  up                    up      
FastEthernet0/1             unassigned      YES unset  up                    down    
FastEthernet0/2             unassigned      YES unset  up                    down    
FastEthernet0/3             unassigned      YES unset  up                    down    
FastEthernet0/4             unassigned      YES unset  up                    up  

We would expect your interfaces to appear the same or similiar if the esw is not plugged into the first wic slot.
Can the verizon actiontec routeract as a switch for your wireless, this would mean giving it an ip address in the range of vlan 5 and turning of the routers dhcp.
You could buy  a cisco wireless access point and plug this in.

Regards

Greg
0
 

Author Comment

by:moman1961
Comment Utility
yes it has 4HWIC ports

FasthEthernet0
FasthEthernet1
FasthEthernet2
FasthEthernet3
FasthEthernet4

ok you mean that can I add vlan5 to the verizon router and also give it the ip address of the vlan so that it can issue ip addresses to it?
0
 
LVL 15

Expert Comment

by:deepdraw
Comment Utility
I have not seen a verizon router as i live in the uk so i dont know the functionality
some routers will allow you to stop using dhcp and if you give them an ip address on the vlan5 range they will be able to work as a wireless bridge.

Regards

Greg
0
 

Author Comment

by:moman1961
Comment Utility
ok I will try and post results
0
 
LVL 45

Expert Comment

by:Craig Beck
Comment Utility
AFAIK the Verizon router won't do VLANs or multiple DHCP pools.

You could use the 1700 as a DHCP server for multiple VLANs though.
0
 
LVL 17

Expert Comment

by:TimotiSt
Comment Utility
Out of curiosity, could you post a photo of that Cisco router?
0
 

Author Comment

by:moman1961
Comment Utility
here is my setup: DHCP is working but still no internet:

!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.2.1 192.168.2.10
ip dhcp excluded-address 192.168.3.1 192.168.3.10
!
ip dhcp pool Vlan3
   network 192.168.3.0 255.255.255.0
   default-router 192.168.3.1
   dns-server 4.2.2.2 4.2.2.3
!
!
no ip domain lookup
!
!
!
!
!
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
 speed auto
!
interface FastEthernet1
 switchport access vlan 2
!
interface FastEthernet2
 switchport access vlan 3
!
interface FastEthernet3
 switchport access vlan 3
!
interface FastEthernet4
 switchport access vlan 3
!
interface Vlan1
 no ip address
!
interface Vlan2
 ip address 192.168.2.1 255.255.255.0
 ip nat outside
!
interface Vlan3
 ip address 192.168.3.1 255.255.255.0
 ip nat inside
!
!
no ip http server
no ip http secure-server
ip nat inside source list 100 interface Vlan2 overload
!
access-list 100 permit ip 192.168.3.0 0.0.0.255 any
!        


sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.2.0/24 is directly connected, Vlan2
C    192.168.3.0/24 is directly connected, Vlan3
JMP1721#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.2.0/24 is directly connected, Vlan2
C    192.168.3.0/24 is directly connected, Vlan3
0
 
LVL 15

Assisted Solution

by:deepdraw
deepdraw earned 167 total points
Comment Utility
Hi

this looks to be the problem
Gateway of last resort is not set

try
conf t
ip route 0.0.0.0 0.0.0.0 (this can be an ip address or interface)

Regards
0
 

Author Comment

by:moman1961
Comment Utility
ok I think there has probably been some mass confusion even on my part.  Ok on my cisco 1721 router I would like it to get its DHCP from the Verizon MW1424 Rev 1 wireless router. It has 4 etherports and 1 WAN port connections.

I would like to know how can I get the wireless to work through the cisco router? My 1721 has the 4 port ESWIC installed, so I can configure the Fa0 and the Fa1 ports for inside and outside nat to connect to the router.

Would I need to create a new route such as 192.168.2.1 etc on the verizon router? to have the wireless access or add another wireless router?
0
Give your grad a cloud of their own!

With up to 8TB of storage, give your favorite graduate their own personal cloud to centralize all their photos, videos and music in one safe place. They can save, sync and share all their stuff, and automatic photo backup helps free up space on their smartphone and tablet.

 
LVL 45

Assisted Solution

by:Craig Beck
Craig Beck earned 167 total points
Comment Utility
The Cisco router could get an IP address on its WAN port from the Verizon router, but anything connected to the etherswitch ports will need to get DHCP from the 1721 (or another DHCP server on the inside).
0
 
LVL 15

Expert Comment

by:deepdraw
Comment Utility
interface FastEthernet0
 ip address dhcp
(this will give you an ip address from the dhcp server connected to the interface fa0)

but that does not resolve the internet.
can you post the output from show ip int brief
can you advise draw a diagram of where the internet comes in.
where the cisco router is and where the wireless is.
please include port numbers on the diagram.

Regards
0
 

Author Comment

by:moman1961
Comment Utility
you are both right! I can do all of that, but I don't want to plug anything else into the ports on the router/switch. All I want is to be able to do the following.

A, before I had any cisco router, my Verizon coax-connected router was issuing Dhcp for all my wireless machines, and I created static ips for some of my gadgets such as Xbox, Kindles, nas boxes.

B, my goal with the cisco is to know will I need to connect another wireless router to use for my wireless pc's and laptops meaning I don't have to plug them into a switch.
0
 

Author Comment

by:moman1961
Comment Utility
500 points to the correct answer.
0
 
LVL 17

Expert Comment

by:Garry-G
Comment Utility
Short answer - unless you want to (and can) use wireless from e.g. the Verizon router, you can plug any wireless AP that will do bridging between LAN and wireless into one of the 1700 switch ports, which should then give you IPs from the DHCP Server on the 1700. You can test that ahead of time by just plugging in a regular PC/notebook and check whether it gets its IP and default gateway, and can access the internet on it.

Btw, the "excluded address" 192.168.2.* can be dropped, as it is outside the DHCP pool listed (unless you have a second one for that range).
0
 

Author Comment

by:moman1961
Comment Utility
if I am using verizon router yeah any pc/laptop gets ip from verizon router? but because this router also controls VOD etc and is coax, I would like to keep those settings I guess I will need to go into the verizon router and configure a new route that can issue dhcp for my wireless clients but still use the old route 192.168.1x for the VOD.
0
 
LVL 17

Assisted Solution

by:Garry-G
Garry-G earned 166 total points
Comment Utility
No, use the DHCP server on the 1700 ... that ought to work just fine ... you already have it set up for VLAN 3 from what I can see in the config posted earlier ... except that I'm missing the access-list 100 from your post - if it isn't in the router, it could be the reason you can't get any Internet ... doing something like this should get it to work:

ip access-list extended 100 permit ip 192.168.3.0 0.0.0.2255 any
0
 
LVL 45

Expert Comment

by:Craig Beck
Comment Utility
Already said this.  If you connect the Cisco router anything not on the WAN side can't use the Verizon router for DHCP.

If you connect to the wireless on the Verizon router you get DHCP from there.  If you connect an AP to the Cisco router you need to use that as a DHCP server unless you're on the WAN side.  If you do that though there's no point in using the Cisco router though.

As soon as you use VLANs you MUST use the Cisco router for any VLAN that's not the WAN.
0
 

Author Comment

by:moman1961
Comment Utility
this is the config and I still can't get internet?

no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.3.1 192.168.3.15
!
ip dhcp pool vlan3
   network 192.168.3.0 255.255.255.0
   default-router 192.168.3.1
!
!
no ip domain lookup
!
!
!
!
!
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
interface FastEthernet1
 switchport access vlan 2
!
interface FastEthernet2
 switchport access vlan 3
!
interface FastEthernet3
!        
interface FastEthernet4
!
interface Vlan1
 no ip address
!
interface Vlan2
 ip address 192.168.2.1 255.255.255.0
 ip nat outside
!
interface Vlan3
 ip address 192.168.3.1 255.255.255.0
 ip nat inside
!
ip route 0.0.0.0 0.0.0.0 192.168.3.0
!
no ip http server
no ip http secure-server
ip nat inside source list 100 interface Vlan2 overload
!
access-list 100 permit ip 192.168.3.0 0.0.0.255 any
!
control-plane
!        
!
line con 0
 exec-timeout 0 0
 password 7 0615042E584F
 login
line aux 0
line vty 0 4
 password 7 095F45060D044143
 logging synchronous
 login
!
end

JMP1721(config)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.2.0 to network 0.0.0.0

C    192.168.2.0/24 is directly connected, Vlan2
C    192.168.3.0/24 is directly connected, Vlan3
S*   0.0.0.0/0 [1/0] via 192.168.2.0
0
 
LVL 17

Expert Comment

by:Garry-G
Comment Utility
I assume you have the machine connected to a VLAN3 port? You said earlier you get an IP from the router? Should also see it assigned by doing "show ip dhcp bind". Can you look at the routing table of the machine you connected? Does it include 192.168.3.1 as default gateway to 0.0.0.0 ? How does the output of "show ip nat trans" look?
0
 
LVL 15

Expert Comment

by:deepdraw
Comment Utility
what is the ip address of the verizon router?
can you plug a pc into this and get on the internet?
if yes can you try this

if ip address of verizon is 192.168.1.1 255.255.255.0
set ip of vlan 1
192.168.1.2 255.255.255.0
set all 4 switchports to vlan1
set the default gateway using
ip route 0.0.0.0 0.0.0.0 192.168.1.1
remove old default gateway
no ip route 0.0.0.0 0.0.0.0 192.168.3.0
remove nat as you dont have an external ip on the router.
0
 
LVL 45

Expert Comment

by:Craig Beck
Comment Utility
It looks like you edited the config or routing output...

The config shows 192.168.3.0 as the default route but the routing table shows 192.168.2.0??

Your default route needs to point to the IP of the Verizon router, then you'll get internet.
0
 

Author Comment

by:moman1961
Comment Utility
router ip is 192.168.1.1
nothing shows when doing ip nat translation

below is what I have configured.


no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.3.1 192.168.3.15
!
ip dhcp pool vlan3
   network 192.168.3.0 255.255.255.0
   default-router 192.168.3.1
!
!
no ip domain lookup
!
!
!
!
!
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
interface FastEthernet1
 switchport access vlan 2
!
interface FastEthernet2
 switchport access vlan 3
!
interface FastEthernet3
!
interface FastEthernet4
!
interface Vlan1
 no ip address
!
interface Vlan3
 ip address 192.168.3.1 255.255.255.0
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 password 7 0615042E584F
 login
line aux 0
line vty 0 4
 password 7 095F45060D044143
 logging synchronous
 login
!
end

JMP1721#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0              unassigned      YES NVRAM  administratively down down    
FastEthernet1              unassigned      YES unset  up                    up      
FastEthernet2              unassigned      YES unset  up                    up      
FastEthernet3              unassigned      YES unset  up                    down    
FastEthernet4              unassigned      YES unset  up                    down    
NVI0                       unassigned      NO  unset  up                    up      
Vlan1                      unassigned      YES NVRAM  up                    down    
Vlan2                      192.168.2.1     YES manual up                    up      
Vlan3                      192.168.3.1     YES manual up                    up      

JMP1721#sh ip dhcp bind
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
192.168.3.16        0100.005a.1142.f1       Mar 02 2002 03:57 PM    Automatic

JMP1721#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.3.0 to network 0.0.0.0

C    192.168.2.0/24 is directly connected, Vlan2
C    192.168.3.0/24 is directly connected, Vlan3
S*   0.0.0.0/0 [1/0] via 192.168.3.0
JMP1721#
JMP1721#
JMP1721#sh ip nat trans        

JMP1721#
0
 
LVL 17

Expert Comment

by:Garry-G
Comment Utility
I don't see any active connection to the Verizon router in that config output ... On which VLAN/interface is this router connected to its uplink (the Verizon router) - what IP does it have? You had it on VLAN2 in the earlier output (which has to match the NAT line interface as well as the "ip nat outside" interface), but now removed the IP (in the config output at least, the show ip route still has it in - those infos don't match up!). Also, this line (which isn't shown in the output anymore) can't be right:

 ip route 0.0.0.0 0.0.0.0 192.168.3.0

Change it to

ip route 0.0.0.0 0.0.0.0 IP_OF_VERIZON_ROUTER
0
 
LVL 45

Expert Comment

by:Craig Beck
Comment Utility
So now you have less config than before and it's lacking important bits.

As Garry said, your default route has gone.

Also the NAT statements have disappeared.

Going back to the OP, which said...
cannot connect to the internet wireless through verizon actiontec router

The Dhcp is working on spare card when plugged into router. but I would rather laptop get dhcp from wireless.  What am I missing?
...what does the 1700 actually do here then?  The Verizon router has wireless and a DHCP server - therefore the 1700 serves no purpose in this function at all.
0
 

Author Comment

by:moman1961
Comment Utility
I added WIC ethernet port to 1721 router:

interface Ethernet5
 ip address dhcp client-id Ethernet5
 ip nat outside
 half-duplex
!
interface FastEthernet0
 no ip address
 ip nat inside
 speed auto
!
interface FastEthernet1
!
interface FastEthernet2


IP address I got from Actiontec Router:

JMP1721#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet5                  192.168.1.4     YES DHCP   up                    up      
FastEthernet0              unassigned      YES manual up                    up      
FastEthernet1              unassigned      YES unset  up                    down    
FastEthernet2              unassigned      YES unset  up                    down    
FastEthernet3              unassigned      YES unset  up                    down    
FastEthernet4              unassigned      YES unset  up                    down    
NVI0                       unassigned      NO  unset  up                    up      
Vlan1                      unassigned      YES unset  up                    down  

IP route:

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

C    192.168.1.0/24 is directly connected, Ethernet5
S*   0.0.0.0/0 [254/0] via 192.168.1.1










\
!
interface FastEthernet3
!
interface FastEthernet4
!
interface Vlan1
 no ip address
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 password 7 03175004120E
 logging synchronous
 login
line aux 0
line vty 0 4
 password 7 00171809105A5D57
 login
!
end

when I try to configure FA0 I get the following:

JMP1721(config)#int fa 0
JMP1721(config-if)#ip address 192.168.1.11 255.255.255.0
% 192.168.1.0 overlaps with Ethernet5
0
 
LVL 15

Expert Comment

by:deepdraw
Comment Utility
Thats right, its not possible to add these ports to a vlan.


Regards
0
 

Author Closing Comment

by:moman1961
Comment Utility
I had to do additional research that the experts did not elaborate about.
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

This subject  of securing wireless devices conjures up visions of your PC or mobile phone connecting to the Internet through some hotspot at Starbucks. But it is so much more than that. Let’s look at the facts: devices#sthash.eoFY7dic.
For Sennheiser, comfort, quality and security are high priority areas. This paper addresses the security of Bluetooth technology and the supplementary security that Sennheiser’s Contact Center and Office (CC&O) headsets provide.  
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now