Solved

ASP.Net WebPage returning blank page on postback after 1 minute

Posted on 2014-07-22
5
1,657 Views
Last Modified: 2014-07-25
I am trying this again. I have a ASP.Net web application that is returning a blank page on postback. The forms work for a minute when you open them. So if you fill out the form and hit submit fast enough, it seems to work. My tests will let the postback work as expected so long as the actions are done in 1 minute or less. One you get past 1 minute and click the submit/save button, or make a change in the drop down list, you get the blank page. I was thinking of session timeouts, but I have that all set to 60 minutes, both in web.config and IIS (its IIS6). The only change done recently is implementing PKI 2 weeks ago, and that is when this behavior began. I've asked this question all over, including here, but I have not found a solution yet. Any ideas would be greatly appreciated.
0
Comment
Question by:dodgerfan
  • 3
  • 2
5 Comments
 
LVL 16

Expert Comment

by:Vikram Singh Saini
ID: 40213388
1.
One you get past 1 minute and click the submit/save button, or make a change in the drop down list, you get the blank page.

What you mean by blank page, here, exactly?

2.
I've asked this question all over, including here, but I have not found a solution yet

Could you share links where you had asked same? Will help us to understand other experts suggestions provided to you for fixing this.

3. Is this deployed on some server and can be accessed by us too for testing purpose (if it is ok)? We would like to test it on our end too.

4. As solution, I could recommend you to -

(a) Clear the Asp.Net temporary files at C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files, and then test it again.

(b) Is this issue specific to browsers? Or it show up for all browsers? Which browser you are trying?

(c) Did you got chance to view the response from your website in Fiddler too? Might be response is coming but browser is not able to display it. Or something wrong happening on browser end but Fiddler will show you error too which browser might not be showing you.

Share your answers and testing results for all.
0
 

Author Comment

by:dodgerfan
ID: 40214472
Thanks for the response. It's just a blank page, white screen. The code behind does not execute, either. It does the same thing on IE (version 8) and Firefox. A view source of the blank page shows just these lines:

<!DOCTYPE HTML PUBLIC "-//W3C/DTD HTML 4.0 Transitional//EN">
<HTML><HEAD><META content="IE=7.0000" http-equiv="X-UA-Compatible">

<META content="text/html; charset=windows-1252" http-equiv=Content-Type></HEAD>
<BODY></BODY></HTML>

I cleared the temp files, but I still get it. I am hampered by the environment I have. I can't post code easily, if at all. And I do not have many tools available. I do not have fiddler. Again thanks for the help and any insight or ideas to chase is appreciated.
0
 
LVL 16

Accepted Solution

by:
Vikram Singh Saini earned 500 total points
ID: 40214860
After reading right now not having immediately to answer for same.

However can I ask you to deploy some other website on same IIS and check if it display response properly or not. Now I am suspecting that either the Asp.Net engine or some related services are not working (or running). And might be cause for same.

Let me know your response.
0
 

Author Comment

by:dodgerfan
ID: 40220762
Finally found it. Thanks for the ideas on chasing it down. I found this and ran it.

http://www.experts-exchange.com/Networking/Protocols/SSL/Q_24461827.html

It turns out that we needed to issue the following 2 statements from
the c:\inetpub\adminscripts directory to solve the problem:

cscript adsutil.vbs set w3svc/site#/uploadreadaheadsize 200000

and set the SSLAlwaysNegoClientCert value by issuing the following
command:

cscript adsutil.vbs set w3svc/site#/SSLAlwaysNegoClientCert true

where site# is the identifier number associated with the website.
0
 
LVL 16

Expert Comment

by:Vikram Singh Saini
ID: 40220922
That was nice to know that you finally nailed down the problem. Thanks for sharing that relevant information with me.
0

Featured Post

Space-Age Communications Transitions to DevOps

ViaSat, a global provider of satellite and wireless communications, securely connects businesses, governments, and organizations to the Internet. Learn how ViaSat’s Network Solutions Engineer, drove the transition from a traditional network support to a DevOps-centric model.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question