Solved

Can't access internal resource - Cisco VPN

Posted on 2014-07-22
2
512 Views
Last Modified: 2014-07-26
Hello, at my office we are running Cisco ASA 5505 which is on a 192.168.0.x network and I'm trying to connect to internal resources from a remote VPN, however, I can not Ping our server (192.168.0.5) or access it's resources through Windows Explorer. I can connect to the VPN session however no traffic appears to be passing to the internal network. At my house, my IP address is on  the 192.168.72.X network and the VPN assigns the VPN client a 10.10.10.X address. Any ideas why it isn't working? Thanks.


Result of the command: "show running-config"

: Saved
:
ASA Version 7.2(4)
!
hostname WrigthASA
domain-name local.wright.com
enable password GLMpD7ZQ2ZmR7vCT encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.0.10 Server
name 192.168.0.5 SBS
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.0.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address x.x.x.x 255.255.255.248
!
interface Vlan3
 shutdown
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name local.wright.com
object-group service RDP tcp
 port-object eq 3389
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group service SMTP tcp
 port-object eq smtp
object-group service RWW tcp
 port-object eq 4125
access-list outside_access_in extended permit tcp any interface outside eq www
access-list outside_access_in extended permit tcp any interface outside eq https
access-list outside_access_in extended permit tcp any interface outside object-group RDP
access-list outside_access_in extended permit tcp any interface outside eq ftp
access-list outside_access_in extended permit tcp any interface outside eq 4125
access-list outside_access_in extended permit tcp any interface outside eq smtp
access-list outside_access_in extended permit tcp any interface outside eq 100 inactive
access-list outside_access_in extended permit gre any interface outside
access-list outside_access_in extended permit tcp any interface outside eq pptp
access-list outside_access_in extended permit ip 10.10.10.0 255.255.255.240 192.168.0.0 255.255.255.0
access-list inside_access_in extended permit tcp host SBS any eq smtp
access-list inside_access_in extended deny tcp any any eq smtp
access-list inside_access_in extended permit ip any any
access-list RAVPN_splitTunnelAcl standard permit any
access-list inside_nat0_outbound extended permit ip any 10.10.10.0 255.255.255.240
access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 10.10.10.0 255.255.255.240
access-list WrightVPN_splitTunnelAcl standard permit 192.168.0.0 255.255.255.0
pager lines 24
logging enable
logging asdm notifications
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool VPNPool 10.10.10.5-10.10.10.10 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface ftp SBS ftp netmask 255.255.255.255
static (inside,outside) tcp interface www SBS www netmask 255.255.255.255
static (inside,outside) tcp interface https SBS https netmask 255.255.255.255
static (inside,outside) tcp interface 3389 SBS 3389 netmask 255.255.255.255
static (inside,outside) tcp interface smtp SBS smtp netmask 255.255.255.255
static (inside,outside) tcp interface 4125 SBS 4125 netmask 255.255.255.255
static (inside,outside) tcp interface 100 192.168.0.104 100 netmask 255.255.255.255
static (inside,outside) tcp interface pptp SBS pptp netmask 255.255.255.255
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh 192.168.0.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

group-policy RAVPN internal
group-policy RAVPN attributes
 dns-server value 192.168.0.5
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value RAVPN_splitTunnelAcl
 default-domain value wcsi.local
group-policy WrightVPN internal
group-policy WrightVPN attributes
 dns-server value 192.168.0.5 8.8.8.8
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value WrightVPN_splitTunnelAcl
 default-domain value wcsi.local
username rreno password aODN2ljL20I13Zif encrypted privilege 0
username rreno attributes
 vpn-group-policy RAVPN
username admin password vWUcXaw6TBqHyxda encrypted privilege 15
username dmartin password g.HauiOzwlPyWEvH encrypted privilege 0
username dmartin attributes
 vpn-group-policy WrightVPN
tunnel-group RAVPN type ipsec-ra
tunnel-group RAVPN general-attributes
 address-pool VPNPool
 default-group-policy RAVPN
tunnel-group RAVPN ipsec-attributes
 pre-shared-key *
tunnel-group WrightVPN type ipsec-ra
tunnel-group WrightVPN general-attributes
 address-pool VPNPool
 default-group-policy WrightVPN
tunnel-group WrightVPN ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect pptp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:3bbe72f634fd26fcfa6012f0dab14b9b
: end



Result of the command: "show running-config"

: Saved
:
ASA Version 7.2(4)
!
hostname WrigthASA
domain-name local.wright.com
enable password GLMpD7ZQ2ZmR7vCT encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.0.10 Server
name 192.168.0.5 SBS
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.0.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address x.x.x.x 255.255.255.248
!
interface Vlan3
 shutdown
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name local.wright.com
object-group service RDP tcp
 port-object eq 3389
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group service SMTP tcp
 port-object eq smtp
object-group service RWW tcp
 port-object eq 4125
access-list outside_access_in extended permit tcp any interface outside eq www
access-list outside_access_in extended permit tcp any interface outside eq https
access-list outside_access_in extended permit tcp any interface outside object-group RDP
access-list outside_access_in extended permit tcp any interface outside eq ftp
access-list outside_access_in extended permit tcp any interface outside eq 4125
access-list outside_access_in extended permit tcp any interface outside eq smtp
access-list outside_access_in extended permit tcp any interface outside eq 100 inactive
access-list outside_access_in extended permit gre any interface outside
access-list outside_access_in extended permit tcp any interface outside eq pptp
access-list outside_access_in extended permit ip 10.10.10.0 255.255.255.240 192.168.0.0 255.255.255.0
access-list inside_access_in extended permit tcp host SBS any eq smtp
access-list inside_access_in extended deny tcp any any eq smtp
access-list inside_access_in extended permit ip any any
access-list RAVPN_splitTunnelAcl standard permit any
access-list inside_nat0_outbound extended permit ip any 10.10.10.0 255.255.255.240
access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 10.10.10.0 255.255.255.240
access-list WrightVPN_splitTunnelAcl standard permit 192.168.0.0 255.255.255.0
pager lines 24
logging enable
logging asdm notifications
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool VPNPool 10.10.10.5-10.10.10.10 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface ftp SBS ftp netmask 255.255.255.255
static (inside,outside) tcp interface www SBS www netmask 255.255.255.255
static (inside,outside) tcp interface https SBS https netmask 255.255.255.255
static (inside,outside) tcp interface 3389 SBS 3389 netmask 255.255.255.255
static (inside,outside) tcp interface smtp SBS smtp netmask 255.255.255.255
static (inside,outside) tcp interface 4125 SBS 4125 netmask 255.255.255.255
static (inside,outside) tcp interface 100 192.168.0.104 100 netmask 255.255.255.255
static (inside,outside) tcp interface pptp SBS pptp netmask 255.255.255.255
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh 192.168.0.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

group-policy RAVPN internal
group-policy RAVPN attributes
 dns-server value 192.168.0.5
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value RAVPN_splitTunnelAcl
 default-domain value wcsi.local
group-policy WrightVPN internal
group-policy WrightVPN attributes
 dns-server value 192.168.0.5 8.8.8.8
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value WrightVPN_splitTunnelAcl
 default-domain value wcsi.local
username rreno password aODN2ljL20I13Zif encrypted privilege 0
username rreno attributes
 vpn-group-policy RAVPN
username admin password vWUcXaw6TBqHyxda encrypted privilege 15
username dmartin password g.HauiOzwlPyWEvH encrypted privilege 0
username dmartin attributes
 vpn-group-policy WrightVPN
tunnel-group RAVPN type ipsec-ra
tunnel-group RAVPN general-attributes
 address-pool VPNPool
 default-group-policy RAVPN
tunnel-group RAVPN ipsec-attributes
 pre-shared-key *
tunnel-group WrightVPN type ipsec-ra
tunnel-group WrightVPN general-attributes
 address-pool VPNPool
 default-group-policy WrightVPN
tunnel-group WrightVPN ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect pptp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:3bbe72f634fd26fcfa6012f0dab14b9b
: end

0
Comment
Question by:bhodge10
2 Comments
 
LVL 57

Accepted Solution

by:
Pete Long earned 500 total points
ID: 40214035
0
 
LVL 14

Expert Comment

by:anoopkmr
ID: 40216370
issue crypto isakmp nat-traversal 60  on ASA and try.

kindly show the output of  show crypto isakmp sa  and show crypto ipsec sa while testing .
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
I've written this article to illustrate how we can implement a Dynamic Multipoint VPN (DMVPN) with both hub and spokes having a dynamically assigned non-broadcast multiple-access (NBMA) network IP (public IP). Here is the basic setup of DMVPN Pha…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now