Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6649
  • Last Modified:

Disabling Hyper-threading on a Dell PE R720

I need to disable hyper-threading due to licensing issues but, I can't find the setting in the BIOS that would allow me to disable it. Does anyone know where I can find the setting on a Dell PowerEdge R720?
0
jfholloway
Asked:
jfholloway
  • 2
1 Solution
 
Svet PaperovCommented:
The BIOS option is called “Logical Processors”. See the manual ftp://ftp.dell.com/Manuals/Common/poweredge-r720_Owner's%20Manual_en-us.pdf 

However, I am curious, what licensing issues require the disabling? When Microsoft licensing is done “per processor” – it’s actually per physical processor, not processor core or logical one.
0
 
rindiCommented:
"Due to Licensing issues"

What product do you have licensing issues with? Usually licenses are limited by sockets, not the number of cores or threads...

So I doubt turning off hyper-threading will make any difference, even if it were possible to be disabled in the BIOS, which is very unlikely. Only old P-IV socket 478 PC's sometimes had the possibility to enable hyperthreading.
0
 
jfhollowaySr. Systems AdministratorAuthor Commented:
Oracle requires licensing based on all CPU's present physical and virtual.
0
 
rindiCommented:
From what I've found online, Oracle's licensing is based on cores and processor definition, not hyperthreading. If I were you I'd double check with Oracle.
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now