Exchange 2013/2010 Coexistence Mail Flow Issue

I have two Exchange servers - a 2010 server and a 2013 server.  Both use my internal DNS for all name resolution.  I can successfully send mail from 2013 to 2010, but not from 2010 to 2013.  The error I am seeing in my queue for the version 15 hub transport is "451 4.7.0 Temporary server error. Please try again later. PRX2".  In my experience, this points to a DNS issue of some sort.  Both servers can ping each other.  Port 25 is open between the servers.  In my internal DNS, I have one MX record that points to my old 2010 server.  Does communication between the servers depend on MX records?  I've also made sure that the custom receive connectors on my 2013 box do not include the 2010 server's IP.
LVL 1
marrjAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
Can you to connect via telnet and check if you are able to submit email. Also check this article:
http://www.techieshelp.com/exchange-2013-451-4-7-0-temporary-server-error-please-try-again-later-prx5/
0
marrjAuthor Commented:
http://blog.kloud.com.au/2013/11/22/exchange-2013-dns-settings-cause-transport-services-to-crash/

This article seems to have done the trick.  Never knew that Exchange cared about an automatically registered hostname.  Exchange 2013 is proving to be quite the learning experience for me.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AmitIT ArchitectCommented:
Thanks for sharing the solution.
0
marrjAuthor Commented:
I ended up fixing the problem with my own research.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.