Solved

PC Won't Boot after Hard Drives Rearranged

Posted on 2014-07-23
19
2,301 Views
Last Modified: 2016-06-26
Hello,

I think I just experienced the proverbial "shooting oneself in the foot" syndrome.  I have a custom built PC that uses a CoolerMaster HAF-XM case.  This case has room for 6 internal hard drives and two X-Dock slots for hot swappable removable HDDs. My configuration this morning was as follows:

B: Blue Ray drive
C: Windows 7 boot drive - internal Crucial 128 GB SSD
D: internal Western Digital (WD) Black 1.5TB HDD (that failed and needs to be returned to WD)
E: another internal WD Black 1.5 TB drive
F: second internal 128GB Crucial SSD identical to C
J: new internal WD Black 1.5 TB that will replace failed D drive
H: internal 2TB Seagate HDD
Z drive: 1 TB WD Black drive in X-dock #1

I have an ASUS P8Z77-V LK motherboard running their UEFI Bios utility Bios version 0210.

Earlier today I opened the case to remove the failed D drive.  At that time I got it in my head to move around some of the other drives.  I wanted to move my two working 1.5 TB WD Black drives into my X-docks.  These drives are being used to backup photos and videos from a NAS device and I liked the idea of being able to easily pull them out and swap them.  

I did NOT move or touch either of the two SSD drives (including the C boot drive).  I did move all of the HDD drives into their desired place.  Just when I put the case back together I had a bad premonition - I was wondering if changing the drives would effect booting. In theory, I did not change the boot drive so I thought I was OK. Wrong!

When I booted the computer the BIOS would load then I would get a black screen with the following error message:

Reboot and select proper boot device
or
Insert boot media in selected boot device and press any key.

I have since rebooted a number of times into the BIOS to try and find the problem.  I have changed the Boot Priority in EZ Mode and Advanced Mode - I still get the same problem.

My BIOD Under EZ Mode:
Boot 1 disk was shown as P0 M4-CT128M4SSD2
Boot 2 disk was disabled in BBS Order***

*** After my problem I set the CD/DVD Drive BBS Priorities to disabled to try and force the issue with the SSD - no luck.

Under HD Priority it gives me 4 options and it shows all the 4 drives installed - the two SSDs and two HDs (the two HDs in the X-dock are not connected and do not show).

The other SSD shows as S0 M4-CT128M4SSD2.  I can't tell if S0 or P0 is the true Boot drive, so I tried setting S0 as first priority then P0, it did not work.

I did notice that under Advanced Mode SATA Configuration only one of the SSD drives shows up.  All the drives that do show are listed as Hot Plug Disabled.  (I wonder if this was enabled if the problem would have been avoided).

I am writing this from a very old, slow XP box.  I would really appreciate help in getting my W7 PC back running.  I need to leave the house for 45 minutes.  If you post a quick reply, it may take me an hour to respond.  THANK YOU!!!!
0
Comment
Question by:MrChip2
  • 11
  • 5
  • 2
  • +1
19 Comments
 
LVL 14

Assisted Solution

by:Don Thomson
Don Thomson earned 75 total points
Comment Utility
Disconnect everything but you Boot Disk - Once you get the bios setting right for this - add the drives back on at a time
0
 
LVL 46

Expert Comment

by:noxcho
Comment Utility
It could be that on that failed drive your boot files were located. These are normally Boot folder and BootMGR file. Do you have on any currently working drives these two folder and file?
0
 

Author Comment

by:MrChip2
Comment Utility
Hi, I am back from my doctor's appointment.  DTH Consulting I am going to try your suggestion now.  Noxcho, I don't have any ability to check that unless I move the drives to another PC.  I can tell you that I had all files in three folders which I deleted.  I had explorer set to show me hidden files.  I am not sure if system files were set to show.  After deleting all visible files on D the PC booted up fine.  Not sure why there would be boot files on D, but it is possible.
0
 
LVL 14

Expert Comment

by:Don Thomson
Comment Utility
could be the pagefile.sys was on d:drive
0
 

Author Comment

by:MrChip2
Comment Utility
that is a possibility. should I install the bad d drive and see if the system boots?  I could also re-enable booting from a CD and boot to Ubunto and search the SSD for pagefile.sys.  I have only used Ubunto once, but could try this if you think it would help.

I unplugged all the drives except P1.  When it was booting a message quickly flashed - No Virtual Disks! No Physical Disks!  Wonder why it would say no Physical Disks?
0
 

Author Comment

by:MrChip2
Comment Utility
More info, I unplugged P1 SSD and plugged in S0 SSD.  When I rebooted I got the same error.  The only difference is the quick message said No Virtual Disk but for Physical Disk it listed S0.

I am wondering is S0 is my C drive and not P1.  I should have labeled these when I built the system.
0
 

Author Comment

by:MrChip2
Comment Utility
Update - I am going to boot in Ubunto (sp?) and find the boot files you both mentioned.  I won't be able to post my answers until 9pm Pacific Time (or so).  Any chance one or both of you can check in this evening?  If not, if you have any other suggestions for me to try this evening, please post them.  Thanks!!
0
 
LVL 18

Assisted Solution

by:web_tracker
web_tracker earned 100 total points
Comment Utility
I would make sure that both the sata cables are firmly plugged into the mobo and the drive, as well as the power cables plugged into the drives as they may have loosened while moving things around.

Also if you changed the order of how the sata cables are connected, this may change the boot order of the drives, for example the mobo numbers the sata slots as 0, 1, 2, 3... etc. I you plug in your boot drive into sata connector 2 in may not boot up, because it is looking for the os on connected to sata 0.
0
 

Author Comment

by:MrChip2
Comment Utility
Web tracker - thanks for your suggestion.  I am back and now have 3+ hours to dedicate to this.  Although I wouldn't mind solving it in 20 minutes!  I will check all the connections and cables.  However, can a drive be detected / listed in BIOS if a connection is loose?
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 

Author Comment

by:MrChip2
Comment Utility
DTHConsulting and noxcho,

I do not think there were any files on my bad HDD related to booting or the OS.  I ran 64-bit Ubuntu version 14 from my BluRay drive.  Once it opened, I checked for the location of the files you mentioned.  All of them were on a drive that Ubuntu called "128 GB Volume".

On this SSD drive I found the following:
 - hiberfil.sys and pagefile.sys on the root
 - a folder called Windows/Boot
 - a folder called Windows/System32/Boot
 - Bootmgr located here: Windows/Boot/PCAT/Bootmgr
 - multiple other files with Boot or Bootmgr in their names, all located on this SSD

I searched the bad drive and did not pagefile.sys, boot, or bootmgr.

Given Ubuntu can read all of these drives, does this mean all of the connections are solid and secure?  Or should I still shut down and re-seat the power and data cables on both ends?

One interesting note, the three installed drives showed up as follows:

128 GB Volume
Erase and Return - what I named the bad drive under properties before I started erasing
SSD for Video - what the second SSD is named

I am not sure if I named my C drive anything. If I did not name it, would that explain Ubuntu calling it "128 GB Volume"?  Or does the generic name on the boot drive indicate a problem?

P.S. I still do not know which SSD is the C drive vs. the Video drive.  I may shut down the PC, disconnect one and re-boot with Ubuntu to finally determine which is which.
0
 

Author Comment

by:MrChip2
Comment Utility
OK - I just confirmed using Ubuntu that the SSD in the top slot is my boot disk that is being called "128 GB Volume" that has W7 and the aforementioned boot files.
0
 
LVL 46

Accepted Solution

by:
noxcho earned 325 total points
Comment Utility
Wait, do not hurry.
The files I am referring to must be on root of C: drive which is your system drive. Not in Windows directory.
Default Windows installation looks as follows:
100MB partition which contains Boot folder and BootMgr file. This in case you installed Windows on empty drive and let Windows format it.
And on C: drive which is actual system drive you have Windows, Program Files and Users folders. This is where Windows loads its files.

But, if the Windows was installed on pre-partitioned system then the Boot folder and BootMgr files are put to first active partition on PC. Means they can be on D: on C: on E: or whatever drive you have.
What you need to do is to boot the system from Windows 7 installation DVD and get to repair mode. There go to command line and run there Diskpart.exe command.
List the drives and see which of them has active partition.
If active partition exists then check if this partition on its root directory has Boot folder and BootMgr file.
If not - browse the other partitions and see if any of them has these files.
Or use third party tool where the disk layout with its partition status are showed such as boot CD for Paragon Hard Disk Manager 14 Suite or any other.
Your primary goal is to set diagnosis. That's way do not change any cables or reformats etc etc. First check what I ask for.
0
 

Author Comment

by:MrChip2
Comment Utility
Hi noxcho,

Sorry for such a slow reply.  I have been on the phone with ASUS tech support.  We verified that all of the motherboard's ports are working and that the problem is not in the BIOS settings (boot sequence).  The tech rep believes that somehow Windows Boot file(s) got corrupted.

I now have all my drives plugged in the way they were prior to this mess.  I did this before seeing your message about not changing any drives - sorry.  It took a while, but I finally located the Windows 7 Pro installation disk.  I am going to do a little online reading into Repair Mode and then do what you ask.  As you said, my only goal is diagnosis.  I will not make any changes before getting your go ahead.

One question - is there any risk in running Repair mode to my data files, etc.  Is there a dummy setting that will protect me from accidentally changing installation or settings?
0
 

Author Comment

by:MrChip2
Comment Utility
PS - I know it is close to 9 pm in Germany.  I hope you are a late owl like me....
0
 
LVL 46

Expert Comment

by:noxcho
Comment Utility
The repair mode looks as follows: you boot the Windows DVD and it asks you if you want perform new install or run repair. The repair tries automatically to repair the system by looking for active partition with these mentioned file and folder. If not found it will give you the error. If found it will try to update the BCD and if failed give you an error and automatically give you an option for command line. And to the data it does nothing. Only to the bcd file if it exists. As long as you have boot problems it will not do anything worse.

The other way you can check the drive content is using free version of Rescue Kit from Paragon. They have on it File Transfer Wizard so that you can see the content of all partitions one by one.
0
 

Author Closing Comment

by:MrChip2
Comment Utility
Thank you three very much for your help.  I am typing this note from my healed PC.  It took a while, but here is how I fixed the problem.  First I used Ubuntu to copy all my files from my failed drive and my SSD boot drive to another drive.  Then I used my Windows Installation disk to get into repair mode to do the following:  

1) I ran bootrec.exe /ScanOS - It scanned all my drives and found one Windows Installation at D:\Windows (which is my SSD boot drive)

2) Then I ran bootrec.exe /FixMBR

After step 2 my PC booted to Windows!!  The only problem was that it did not show my second SSD.  I had a brand new 256 GB Samsung SSD on hand, so I pulled out the "invisible 128GB SSD", put in the new Samsung, but the PC still did not see the second SSD.  I then noticed that I was running a VERY old BIOS on my Mobo.  I was running a version from 2012 that has since been updated 13 times.  Many of these updates were to add support for newer devices.  I confirmed with ASUS that I need to install one update at a time, a laborious process.  After many updates and reboots, my MOBO is now running the latest BIOS from this year and the Samsung drive is visible and working.  So this problem is solved.  Thank you all for your help with this!!
0
 
LVL 46

Expert Comment

by:noxcho
Comment Utility
Glad to hear you resolved it.
Take care
Nox
0
 

Author Comment

by:MrChip2
Comment Utility
You too and a belated congratulations on Germany's World Cup victory.  I didn't know until now that is where you are from.  Have a great weekend.
0
 
LVL 46

Expert Comment

by:noxcho
Comment Utility
:) thank you!
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Let’s face it, any data that’s not backed up frequently is in danger. And when data loss happens to you, it can seem like the end of the world.
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup". After a while, you have entered a loop for Auto repair which does not fix anything and you will be in a  panic as all your work w…
This Micro Tutorial will teach you the basics of configuring your computer to improve its speed. It will also teach you how to disable programs that are running in the background simultaneously. This will be demonstrated using Windows 7 operating…
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now