Error connecting to SQL Server

A network-related or instance-specific error occurred while establishing a connection to
SQL Server. The server was not found or was not accessible.
Verify that the instance name is correct and that SQL Server is configured
to allow remote connections. (provider: Named Pipes Provider, error: 40 -
Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 53)

Explanation

The SQL Server client cannot connect to the server. This error could occur because either the client cannot resolve the name of the server or the name of the server is incorrect.

User Action

Make sure that you have entered the correct server name on the client, and that you can resolve the name of the server from the client. To check TCP/IP name resolution, you can use the ping command in the Windows operating system.
 
How do I ping?

Thanks,
DovbermanAsked:
Who is Participating?
 
Jerry_JusticeConnect With a Mentor Commented:
It looks like it is trying to connect using named pipes.

Is TCP/IP enabled on this workstation?  Start/Run - cliconfg

Make sure TCP/IP is an enabled protocol.

If you want to ping the server: Start/Run - cmd
At the C:> prompt type "ping servername"

That doesn't help a whole lot if SQL Server you are connecting to is a named instance, but at least it tells you if that server is responding to a ping by name.

Last - can other workstations connect remotely to this SQL server?  If not, is SQL Browser service running on the server?
1
 
DovbermanAuthor Commented:
This is a local installation of SQL Server.  I just re-installed. The installation was successful.

However, I cannot find the new instance.
0
 
Jerry_JusticeCommented:
If you are running Windows Firewall, turn it off.  It may be blocking access.  But you still need to make sure SQL Browser service is running.
0
Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

 
DovbermanAuthor Commented:
I can connect with Windows authentication only.
0
 
DovbermanAuthor Commented:
I got it.

From the SQL Server Management Studio,

Use Windows Authentication to connect without a password.

Once connected, Choose Security-->Logins.

Choose SQL Server Authentication.

Enter a login name.  Enter a password .
0
 
DovbermanAuthor Commented:
Thanks for the ideas.
0
All Courses

From novice to tech pro — start learning today.