Solved

SP2010 Timer Service

Posted on 2014-07-24
22
404 Views
Last Modified: 2014-07-29
Application: SharePoint 2010
Description: The Execute method of job definition Microsoft.Office.Server.Search.Administration.IndexingScheduleJobDefinition <guid> threw an exception.
"The password of the search service account has expired.  To update the password visit the services on server page and  update the password for the search service".
Symptom:
1. Users cannot make changes to calendar items although they have contribute permission level.  No change made to their permission level at all.  As a workaround, I have to make changes locally on the server, when user(s) request for changes to be made.
Steps taken so far:
1. reset IIS
2. went to Central Admin > Security > Configure Managed Accounts and checked settings.  Looks normal.
Any advice provided is appreciated.
0
Comment
Question by:Francis Michael
  • 11
  • 11
22 Comments
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40217939
looks like the search service authentication has failed.
follow below to setup/change service applications authentication/passwords the right way.
http://blogs.technet.com/b/seanearp/archive/2011/01/25/updating-passwords-on-sharepoint-2010.aspx
0
 

Author Comment

by:Francis Michael
ID: 40220325
Jaya,
I went through this blog as well as Todd Klindt's blog.  For my server, I have taken a screenshot of "configure service accounts" page.  All services are managed by domain\SQLAdmin.  I don't understand where the change is to be made.  Please advice.  See screenshot.
Screenshot-on-Timer-and-password-issues-
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40220367
Go to CA,
Under General Security, click Configure managed accounts.
 Click the Edit button next to the account that you want to change in your case its domain\sqladmin.
In the Credential Management section of the resulting page
click the checkbox next to change password and then choose set account password to new value and save it. allow it few mins for the effects to take place.
0
 

Author Comment

by:Francis Michael
ID: 40220413
I did as instructed.  Now unable to connect to CA.  See screenshots.
Error--2.png
Error--1.png
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40220444
whats your farm admin account ? does that have entry in sql server ?
make sure this account domain\sqladmin is having db owner acces on the sql server. if not please add it. once you are able to connect to ca then change the settings of the sql permission as documented
or
look at the apppool the ca is running, revert it back to the identity which its running initally and you shoulbe be able to connect and also ensure
a. Click Start->run->input "Services.msc"(no quotation) in prompt command.
b. Right click SQL Server(SHAREPOINT) services->Properties->click Log On Tab
c. Select 'Log on as Local System account' option.
d. Start the SQL Server(SHAREPOINT) services normally. how about the results?
0
 

Author Comment

by:Francis Michael
ID: 40220522
1. Farm Account is SP_Farm
2. Yes, SP_Farm has an entry in SQL server
3. domain\sqladmin has access as dbcreator
4. Cannot connect to CA
5. I cannot log into SQL Server
Please advice.
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40224083
switch the account (app pool identity) back to sp_farm account.
Also make sure of the service applications(services.msc) sharepoitn ones to run on sp_farm account
0
 

Author Comment

by:Francis Michael
ID: 40224230
When I attempt to connect to Microsoft SQL Server Management Studio (2012) using the following:
1. Server Type: Database Engine
2. Server Name: SQL
3. Authentication: Windows Authentication
I get error, see screenshot.  I tried logging into SQL using SP_Farm account without any success.  Looks like I'm locked out of SQL.  Please advice.
connect-to-sql-error-message.png
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40224262
ok so looks like the sp_farm account is your farm account. and the account sql dosent have proper rights to access the content db.
change the application pool identity of the central administaion and the web application to sp_farm account , you should be able to connect

+ here are some troubleshooting steps http://snahta.blogspot.com/2008/08/cannot-connect-to-config-db.html
0
 

Author Comment

by:Francis Michael
ID: 40224317
OK.  
1. I can connect to (and log into) MS SQL Server Management Studio. Thank you.  (Note SQL is on a separate server).
2. When I go to my SharePoint Server and start SharePoint 2010 Central Administration, I get the following message, viz. "Cannot connect to the Configuration Database".  
3. What next?
Francis
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40224334
PS note my comment : change the application pool identity of the central administration and the web application to sp_farm account , you should be able to connect

1. Click Start --> Run--> Type inetmgr
2. Double-click the Web Sites folder.
3. Right-click the virtual server that is running WSS and then click Properties.
4. Click Home Directory.
5. Note the information that is in the Application name box (this is the application pool name), and then click Cancel.
6. In the left pane, right-click Application Pools, and then click Properties.
7. Click the Identity tab.
8. Note the information that is in the Application pool identity pane, and then make sure its sp_farm not sql.
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 

Author Comment

by:Francis Michael
ID: 40224802
OK.  Central Admin is connected!.  Can access SharePoint via web browser.  Looks like we are back to square one.  Do I repeat steps suggested before?  Or do you suggest something else.  The original issue, see first request for help remains open.  Here are two screenshots of error messages from browser.  Screenshot A shows that uses can access SharePoint using IP address not domain friendly name.  Screenshot B shows error when user tries to open a folder (user has full access to folder).  Screenshot C is the original screenshot sent earlier which shows what happens when a user tries to add an item to the calendar.  (User has full access to calendar).  Please advice.
Thank you.
Screenshot-A.png
Screenshot-B.png
Screenshot-C.png
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40224835
two different issues.
1. you request was an error for changing service account passwords. If that needs to be done
change query server From app to WFE Server and also updated search service account password after that search should be working.

2.you need to configure AAM /host header to resolve your domain name instead of IP. If you use the domain name B and C should be resolved
0
 

Author Comment

by:Francis Michael
ID: 40224954
1. Please give "how to" for "change query server From app to WFE Server".  Will same issue arise if I update search service account?
2. the second issue, viz IP instead of DNS is minor issue.  Will follow configuration of AAM / host header method.
Advice on item 1, please.
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40225107
go to CA, services on server which ll end up in /_admin/Server.aspx.. then from there drop down the server names and pull up app server and in that "Search Query and Site Settings Service " stop on app server and start on web server. and then do a full crawl
0
 

Author Comment

by:Francis Michael
ID: 40225581
On CA, under server name, I only  have SharePoint WFE and SQL.  (It is 2 tier set-up). Web Server and App Server are the same.  Does that make a difference in stop / start "Search Query and Site Settings Service".  Thanks.
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40225849
yes it will try to stop and start the search query and site settings.
also restart sharepoint search service from services.msc
0
 

Author Comment

by:Francis Michael
ID: 40226764
Do you know Powershell?  See error message in screenshot showing password recognition.  I wonder if this will resolve Timer / Search issues.  Any advice?
Error-when-trying-to-start-Search-Servic
0
 
LVL 8

Expert Comment

by:Jayaraja Jayaraman
ID: 40226916
looks like the passwords got changed from AD and SP stored password is different.
To fix this issue do the following
Logon to the SharePoint 2010 server as an admin, preferably as the account used to install SharePoint
Open up the SharePoint PowerShell command prompt
Set-SPManagedAccount -UseExistingPassword -Identity CISSA\cisadmin
You will then be prompted for the existing\new password for "CISSA\cisadmin"
Run "Repair-SPManagedAccountDeployment" to verify the passwords are now in sync
0
 

Author Comment

by:Francis Michael
ID: 40227271
Jaya,
1. Ran PS cmdlet as requested.
2. Provided new pwd for cissa\cisadmin
3. Ran "Repair....."
4. No problems reported in PS.
5. Stop / Start - search service
6. ran iisreset

Final result - issue unresolved.  User cannot make change to calendar.  Error remains.  User cannot make changes to calendar.
0
 
LVL 8

Accepted Solution

by:
Jayaraja Jayaraman earned 400 total points
ID: 40227297
As i said above its a different issue.
for "The password of the search service account has expired.  To update the password visit the services on server page and  update the password for the search service" the issue is resolved.

This has nothing to do with the calendar. Please close this and create a separate thread for the calendar issue going on.
Did you setup aam ?  .
0
 

Author Closing Comment

by:Francis Michael
ID: 40227560
OK.  AAM have been set up and access to sharepoint is done to IP not domain names.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Sharepoint 2013 - Bulk Add Users 6 50
SCCM Microsoft Report 2 48
SharePoint 2010 Versioning 2 23
Sharepoint installation and configuration 4 58
Note:  There are two main ways to deploy InfoPath forms:  Server-side and directly through the SharePoint site.  Deploying a server-side InfoPath form means the form is approved by the Administrator, thus allowing greater functionality in the form. …
I thought I'd write this up for anyone who has a request to create an anonymous whistle-blower-type submission form created using SharePoint 2010 (this would probably work the same for 2013). It's not 100% fool-proof but it's as close as you can get…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now