?
Solved

Wifi priority sequence changes after laptop reboot

Posted on 2014-07-26
18
Medium Priority
?
505 Views
Last Modified: 2014-08-14
My Windows 7 (Profsnl x64) on my Lenovo X220 priority sequence will change each time
after the laptop is being rebooted despite being set (I followed one of the EE's article).

What could be the reason & how to get this fixed permanently?
0
Comment
Question by:sunhux
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
  • 3
  • +3
18 Comments
 
LVL 97

Expert Comment

by:Experienced Member
ID: 40221354
Wi-Fi will connect first if is it available, normally. You can change the metric for it. Where did you change the sequence?
0
 

Author Comment

by:sunhux
ID: 40221509
Both the Wifi services (there are 3 if including one tethering from a
mobile phone that I sometimes connect as a last resort but it's slow)
in my office are always on 24x7 (& 365 days a year).


I configure according to a past question/EE solution :

http://www.experts-exchange.com/Networking/Wireless/Q_28438273.html

http://www.howtogeek.com/howto/27067/change-wireless-network-priority-to-make-windows-7-choose-the-right-network-first/

http://bt.custhelp.com/app/answers/detail/a_id/36763/~/changing-the-priority-of-your-wireless-connections---windows-xp
0
 
LVL 38

Expert Comment

by:Gerwin Jansen, EE MVE
ID: 40252209
Hello sunhux,

Are you saying that with every reboot, the order of Preferred Networks is changing?

You have 3 networks, right (A,B and C)? They are all at your home, right?

So you set this order: A, B, C and after a reboot the order changes to B,A,C or C,A,B?

Btw: you didn't follow an EE article for this but articles that are not on EE (howtogeek and bt.custhelp).
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 82

Expert Comment

by:David Johnson, CD, MVP
ID: 40252470
It depends upon which is available. if you configure A,B,C and when you reboot A is not available it will B,C,A
0
 
LVL 19

Assisted Solution

by:NerdsOfTech
NerdsOfTech earned 800 total points
ID: 40252589
The TOP priority connection should be on the VERY TOP of your connection list; the 2nd connection should be 2nd highest on your list, and so forth.

Under Control Panel > Network and Sharing Center > Manage Wireless Networks > Click on network you want to prioritize > then click Move Up until it is on the VERY TOP of the list.


Move your 2nd highest priority connection to the 2nd from the top position of this list.

Move your 3rd highest priority connection to the 3rd from the top position of this list.
0
 

Author Comment

by:sunhux
ID: 40253082
Already tried what David & NerdsofTech suggested.

Hi Gerwin,
It's an EE thread
http://www.experts-exchange.com/Networking/Wireless/Q_28438273.html
which references 2 other external links.

It's in my office.

I've set it to ABC, but everytime after reboot, it will become BAC
(& it's always BAC though I wanted it to be ABC) & all 3 Wifi are
always On
0
 
LVL 38

Expert Comment

by:Gerwin Jansen, EE MVE
ID: 40253117
>> it's always BAC though
Do you have a dual band NIC and are the 3 access points possibly not on the same band? Could be that your NIC orders the connections based on 2.4G / 5G band automatically.
0
 
LVL 43

Expert Comment

by:Davis McCarn
ID: 40253403
Lenovo says you have one of these two:
•11a/b/g/n, PCIe Half Mini Card, Intel Centrino® Advanced-N 6205, 2x2
•11a/b/g/n, PCIe Half Mini Card, Intel Centrino Ultimate-N 6300, 3x3
Which is it?
And, is B an N router with A & C being G?
0
 
LVL 19

Assisted Solution

by:NerdsOfTech
NerdsOfTech earned 800 total points
ID: 40253834
I would suggest ONE of the following strategies:
***strategies 1-2 recommended***

1. Zero/Seamless Handoff


If you have control over the 3 APs and these APs are namely for coverage extension, your system may prioritize based on last connection, band, attenuation, interference, etc. The solution would be to implement a seamless, "zero handoff" wireless network/configuration. One solution, if the APs are in the 2.4Ghz band, would be to configure the AP's to non-overlaping frequencies, channel 1, 6, and 11 and have the name SSID and security (and the routing correct) for single MERGED connection (Or configure your 2 infrastructure APs, to a non-overlap, MERGED, configuration, as you mentioned that a mobile connection; separate from your infrastructure connections.) .

Or, you can implement some new hardware and make a quick zero-handoff network such as using Ubquiti's UniFi hardware.

2. Turn off all but A's Automatic Connection


if you don't have control over the APs, determine the AP you will most often use and disable "automatic connection" on the other connections, (in other words, reduce to one "auto" access point connection):
Uncheck "start connection automatically" on the other connections except for your primary;

OR just disable B's auto connection (which will allow you to stay on A, unless you are out of the office and connecting to C; when A and C are unavailable THEN AND ONLY THEN will you want to connect to B "manually"). A and C would be automatic.



***Less conventional / extreme strategies:

3. Connect even if network is not broadcasting


3. Permanently connect to A first by checking "connect even if the network is not broadcasting" on it's properties in "manage network connections".

4. Turn off all automatic connections AKA manually connect


4. Turn off (uncheck) ALL automatic connections off from A-C, and connect manually each time; preserving A-C's network connection details.

5. Remove all but A's network connection??


5. Permanently remove B and C from your list??
0
 

Author Comment

by:sunhux
ID: 40255043
> •11a/b/g/n, PCIe Half Mini Card, Intel Centrino® Advanced-N 6205, 2x2
> •11a/b/g/n, PCIe Half Mini Card, Intel Centrino Ultimate-N 6300, 3x3
> Which is it?

My laptop is Lenovo X220 & on Network Connections, it shows as
"Intel(R) PCI bus 3, Intel WifFi Link 1000GBN"

Device Manager shows Driver version 13.0.0.107 with four driver files:
NETw5s64.sys
vwifibus.sys
NETw5c64.dll
NETw5r64.dll

> And, is B an N router with A & C being G?

Yes, B is an N router.  Don't know what's A as it's provided by
our building management while C is a 3G mobile phone
tethering service.  I have admin access to B's AP only : it's a
100Mbps broadband router used by our department but I use
A most of the time for Sharepoint & some of our corporate
eClaims/eLeave services & only uses B occasionally when
need to access public Internet directly

=====================

> implement some new hardware and make a quick zero-handoff
> network such as using Ubquiti
Don't plan to buy/invest in a new hardware.  I'm not allowed to
turn off any Wifi services as they are shared by many staff in
our department
0
 
LVL 19

Expert Comment

by:NerdsOfTech
ID: 40255105
Why are you using A, is the connection faster?

A might be a b/g protocol AP, this may mean B has a stronger signal and newer protocol g/n. Thus I recommend option #2 above as solution: turn off automatic connection to B = problem solved. So whenever you want B on manually connect (password is saved). Whenever you're in range  of C and not A, C will auto connect.
0
 
LVL 43

Accepted Solution

by:
Davis McCarn earned 720 total points
ID: 40255495
Disconnect from B and uncheck the box to automatically connect.
0
 
LVL 38

Assisted Solution

by:Gerwin Jansen, EE MVE
Gerwin Jansen, EE MVE earned 480 total points
ID: 40255963
>> only uses B occasionally when need to access public Internet directly
Agree with above suggestions - set B to manual and connect when necessary.
0
 

Author Comment

by:sunhux
ID: 40258416
I'm using A as it's our corporate Wifi which enables me to
login to our corporate eLeave/eClaim/Sharepoint systems.

B is to public internet as it's a broadband.


For Davis & Gerwin's suggestion, is it the same as unchecking
"Connect Automatically when this network is in range" ?
0
 
LVL 43

Assisted Solution

by:Davis McCarn
Davis McCarn earned 720 total points
ID: 40258449
Yes!  You will then be able to connect to it manually (Connect button); but, it won't connect to B unless you tell it to.
0
 

Author Comment

by:sunhux
ID: 40260053
Yes, Davis & Gerwin's suggestion work as what I wanted.  Thanks!
0
 

Author Closing Comment

by:sunhux
ID: 40260055
excellent
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article helps those who get the 0xc004d307 error when trying to rearm (reset the license) Office 2013 in a Virtual Desktop Infrastructure (VDI) and/or those trying to prep the master image for Microsoft Key Management (KMS) activation. (i.e.- C…
The Summer 2017 Scholarship Winners have been announced!
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question