Internet Explorer 11 Closing Upon Clicking the "Browse" Button

Hello:

I just got a new laptop with Windows 8 and Internet Explorer 11.  Whenever I click the "Browse" button on a web site to attach documents, whether it is this web site or another, a small window appears telling me that Internet Explorer has stopped working.

Is there anything that can be done to fix this, so that I can attach documents?

Thanks!  Much appreciated!

TBSupport
LVL 1
TBSupportAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Try removing add-ins in IE. (Tools, Manage add-ins). Make a list of what add-ins are active, remove (disable) all of them. Then restart and try again to see if IE is doing what you need.

I have IE11 on Windows 8.1 and I have a bare minimum of add-ins enabled. IE works better that way.
TBSupportAuthor Commented:
Hi John:

I have very few add-ons, as well.  The only ones that are "out of the ordinary" are Google Toolbar, Google Toolbar Helper, and Shockwave Flash Object.

Would removing these add-ons resolve this issue?

TBSupport
JohnBusiness Consultant (Owner)Commented:
Adobe Acrobat is disabled, Skype is disabled, Java is mostly disabled, Shockwave is ENABLED as you, and Google is not allowed on my computer.
Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

JohnBusiness Consultant (Owner)Commented:
Also in Advanced System Properties, Advanced Tab, go to the Performance settings button, Data Execution Prevention tab and set the choice for Run DEP except on exclusions and exclude IE11.
TBSupportAuthor Commented:
Hi John:

I tried to do this, but I got a message saying that DEP cannot exclude 64-bit executables.

TBSupport
JohnBusiness Consultant (Owner)Commented:
Are you using IE11 64-bit?  That was not mentioned. Microsoft does not recommend 64-bit IE or 64-bit Office at this time because everything around it must be 64-bit and that is not feasible yet.

That may be your issue. I use 32-bit IE.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TBSupportAuthor Commented:
I ran updates, and the problem seems to have gone.   It sounds like you were definitely onto something!

Thanks, John!!

TBSupport
JohnBusiness Consultant (Owner)Commented:
@TBSupport  - Thanks for the update I was happy to help. I am down to about 2 IE11 errors a month or maybe a bit less - Windows 8 and Windows 7.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.