Solved

Mail-Enabled Public Folders Not receiving email from external sources?

Posted on 2014-07-27
4
11,204 Views
Last Modified: 2016-10-12
I just got moved to Office365/Exchange Online and its all working ok right now except 1 thing.

Our mail enabled public folders are receiving emails from internal sources but anything sent to them from say my gmail account don't show up.

Is something like a receive connector missing? I really don't work with exchange much and we had a consultancy do the migration.

We receive accounting reports from external sources that get sent straight to these folders.

Thank you

"Always have fun, even if everyone is miserable...It makes you feel better and confuses others :D"
0
Comment
Question by:Tsz109
4 Comments
 
LVL 38

Assisted Solution

by:Vasil Michev (MVP)
Vasil Michev (MVP) earned 150 total points
ID: 40223465
Any particular NDR you are getting?

Check the settings for the PF in question: go to EAC -> Public Folders -> Public Folders -> Mail flow Settings -> Message Delivery Restrictions. Make sure that "Require that all senders are authenticated" is switched off and that the "All Senders" radio button is checked under "Accept messages from".
0
 

Author Comment

by:Tsz109
ID: 40223472
BN1AFFO11FD011.mail.protection.outlook.com rejected your message to the following email addresses:
Op Production Reports (ProductionReports@XXXX.onmicrosoft.com)
BN1AFFO11FD011.mail.protection.outlook.com gave this error:
[ProductionReports@XXXXX.onmicrosoft.com]: Recipient address rejected: Access denied
A communication failure occurred during the delivery of this message. Please try resending the message later. For more tips to resolve this issue see DSN code 5.4.1 in Exchange Online. If the problem continues contact your help desk.


This is strange because I got 2 of the 4 folders working.
It was having to go into the permissions through outlook and allow "Anonymous" to contributor level.
I did the same on the other 2 and I still get this error.
0
 
LVL 19

Accepted Solution

by:
Delphineous Silverwing earned 350 total points
ID: 40224119
Make sure the "Anonymous" privileges to the folder allow creating new items (contributor).

Use powershell to ensure the public folder is properly mail-enabled and verify the e-mail address.

Using Powershell with Exchange Online
http://technet.microsoft.com/en-us/library/jj984289%28v=exchg.150%29.aspx

Mail-Enable a Public Folder
http://technet.microsoft.com/en-us/library/aa997560(v=exchg.150).aspx
0
 

Expert Comment

by:Siraj Mohammad
ID: 41840103
Make sure the primary SMTP is not @onmicrosoft.com  but the original username@domainname.com
0

Featured Post

Want to promote your upcoming event?

Attending an event? Speaking at a conference? Or exhibiting at a tradeshow? Easily inform your contacts by using a promotional banner in your email signature. This will ensure your organization’s most important contacts are in the know.

Join & Write a Comment

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
This Experts Exchange lesson shows how to use VBA to loop through rows in Excel.  In order to sort, filter, and use database features, there needs to be a value in each column for every row. When data arrives with values missing, code to copy values…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now