How do I grant permission to a folder when creating a database in a new SQL Express instance?

I have performed a quiet load of SQL Express and named the instance something specific.  This code works.  I then try to set up a new database with the code below, and it throws an error.  When I access the file through file explorer, I get the error, "You don't currently have permission to access this folder.  Click continue to permanently get access to this folder."  I click Continue and the folder opens.  I then go back to my code below and it works.

How can I grant permission to the folder from behind the scenes in my code?

 Private Sub myNewDatabase()
        Try

            Dim str As String
            Dim srv As Server
            srv = New Server(machine & "\" & Inst)

            Dim myConn As SqlConnection = New SqlConnection("Server=" & machine & "\" & Inst & ";Trusted_Connection=True;")

            '============new string =================================

            str = "CREATE DATABASE [AddBook] " & _
                  "CONTAINMENT = NONE ON  PRIMARY " & _
                  "( NAME = N'AddBook', FILENAME = N'C:\Program Files\Microsoft SQL Server\MSSQL11.DTH2012\MSSQL\DATA\AddBook.mdf' , SIZE = 3072KB , MAXSIZE = UNLIMITED, FILEGROWTH = 1024KB )" & _
                  "LOG ON " & _
                  "( NAME = N'AddBook_log', FILENAME = N'C:\Program Files\Microsoft SQL Server\MSSQL11.DTH2012\MSSQL\DATA\AddBook_log.ldf' , SIZE = 1024KB , MAXSIZE = 2048GB , FILEGROWTH = 10%)"

            '========================================================

            Dim myCommand As SqlCommand = New SqlCommand(str, myConn)

            Try
                myConn.Open()
                myCommand.ExecuteNonQuery()
            Catch ex As Exception
                MessageBox.Show(ex.ToString())
            Finally
                If (myConn.State = ConnectionState.Open) Then
                    myConn.Close()
                End If
            End Try

        Catch ex As Exception
            MessageBox.Show(ex.Message, My.Application.Info.Title, MessageBoxButtons.OK, MessageBoxIcon.Error)
        End Try

    End Sub

Many thanks!!
Karen WilsonProgrammerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jacques Bourgeois (James Burger)PresidentCommented:
Have you tried running your code as an administrator?

In newer versions of Windows, even if you are logged as an administrator, applications are working by default as if you were a regular user.

You can force an application to work under your administrator account either by launching with a right click and selecting the Run As Administrator option, or by modifying the Windows Settings in the Application tab of the project's Properties window.
0
Karen WilsonProgrammerAuthor Commented:
I think I found the code but I haven't really tested it yet.  I was hoping to receive a similar response to compare.

 'open the file up for permssion
Dim FolderPath As String = "C:\Program Files\Microsoft SQL Server\MSSQL11.DTH2012\MSSQL\DATA" 'Specify the folder here
Dim UserAccount As String = machine & "\" & user 'Specify the user here

            Dim FolderInfo As IO.DirectoryInfo = New IO.DirectoryInfo(FolderPath)
            Dim FolderAcl As New DirectorySecurity

FolderAcl.AddAccessRule(New FileSystemAccessRule(UserAccount, FileSystemRights.Modify, InheritanceFlags.ContainerInherit Or InheritanceFlags.ObjectInherit, PropagationFlags.None, AccessControlType.Allow))
            FolderAcl.SetAccessRuleProtection(True, False) 'uncomment to remove existing permissions
            FolderInfo.SetAccessControl(FolderAcl)
0
David Johnson, CD, MVPOwnerCommented:
C:\Program Files\Microsoft SQL Server\MSSQL11.DTH2012\MSSQL\DATA\AddBook.mdf'

Create the database elsewhere but not under C:\Program Files.. You can attach db files from just about anywhere. as a workaround if you insist on not using current microsoft best practices is to shell out to takeown i.e.
takeown /f "C:\Program Files\Microsoft SQL Server\MSSQL11.DTH2012\MSSQL\DATA\ /r /d n"

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Karen WilsonProgrammerAuthor Commented:
I used this code and it worked:

            'open the file up for permssion
Dim FolderPath As String = "C:\Program Files\Microsoft SQL Server\MSSQL11.DTH2012\MSSQL\DATA" 'Specify the folder here
Dim UserAccount As String = machine & "\" & user 'Specify the user here

Dim FolderInfo As IO.DirectoryInfo = New IO.DirectoryInfo(FolderPath)
Dim FolderAcl As New DirectorySecurity

FolderAcl.AddAccessRule(New FileSystemAccessRule(UserAccount, FileSystemRights.Modify, InheritanceFlags.ContainerInherit Or InheritanceFlags.ObjectInherit, PropagationFlags.None, AccessControlType.Allow))
FolderAcl.SetAccessRuleProtection(True, False) 'uncomment to remove existing permissions
       
I also made the choice to use a directory outside of the program files directory and that is working, too.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual Basic.NET

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.