[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1283
  • Last Modified:

disk.sys BSOD on Windows Server 2003 Hyper-V

Environment
Host: Windows Server 2012 R2 Datacenter
VM OS: Windows Server 2003 R2 Enterprise 64-bit

I recently converted a VMWare VM to Hyper-V and was using the legacy NIC to get everything up and running and install Hyper-V Integration Services.

I had a few occasional blue screens on the VM but after removing VMWare integration services and some other unnecessary services/applications it seemed my VM was stable. I finally got to the point where I could replace the legacy NIC with the synthetic Hyper-V NIC. It seems that after that the VM started to blue screen frequently. It is stable in safe mode. I have just reverted to the legacy NIC to verify it is stable.

Notes about the virtual NIC:
- I tried both with SR-IOV and without - bsod with both.
- The hardware NIC is an Intel Gigabit ET Quad Port. I've tried two different ports.

Any help is much appreciated.

Thx!

Joe
0
dekroon
Asked:
dekroon
  • 4
  • 2
1 Solution
 
JurajUQUCommented:
Did you remove all the devices from the device manager that were on the metal server?

Also remove the legacy network adapter driver, restart, then try to add the other one.

Btw what toold did you use to convert P2V?
0
 
dekroonAuthor Commented:
yes - all devices specific to vmware were removed (it was a VM, not a physical server)

yes - i've been changing virtual NICs by removing and restarting. I verified the system is stable in safe mode and also stable in normal mode with the legacy Hyper-V NIC but not with the synthetic Hyper-V NIC.

I use Symantec System State Restore with "Restore to Different Hardware" for all my VM conversions. Works very consistently with many different guest OS versions.

Latest thing I'm trying is to disable NIC offloading, as I've read about network connectivity issues that can be remedied by doing that. Don't know if it addresses stability, though. . .
0
 
dekroonAuthor Commented:
I disabled NIC offloading as per http://support.microsoft.com/default.aspx?scid=kb;EN-US;904946 

Time will tell, but since I did this some 4 hours ago I've experienced no BSOD.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
JurajUQUCommented:
Good for you. Hope it lasts and works well.
0
 
dekroonAuthor Commented:
Disabling NIC offloading is the solution. The server has been completely stable since doing that.
0
 
dekroonAuthor Commented:
Self-discovered solution worked.
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now