?
Solved

"read more" link on blog posts not working

Posted on 2014-07-27
5
Medium Priority
?
241 Views
Last Modified: 2014-08-11
Hi - there's a "read more" link on each blog entry of my blog page, but it doesn't link through to the single blog post page. It's linking to the blog page. Not sure where to look to fix that. Any help much appreciated. thanks!

blog page
0
Comment
Question by:Trevor Local
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 7

Assisted Solution

by:Raghu Mutalikdesai
Raghu Mutalikdesai earned 400 total points
ID: 40223562
This is your sample link (as pointed by READ MORE) for the post Artist: The DUDEZ:
<a class="read-more" href="http://development10.crispyconnection.com/get-connected/">Read More</a>

Open in new window

You must give exact / complete path of your article in anchor. You already have the correct link for the header. Just change the link of READ MORE to the one which you gave for header / title href="http://development10.crispyconnection.com/artist-feature/the-dudez/".
0
 
LVL 111

Accepted Solution

by:
Ray Paseur earned 1600 total points
ID: 40223753
0
 

Author Comment

by:Trevor Local
ID: 40224851
It seems I'll have an easier time with removing the current "read more" and using a plugin to re-insert it.

From this page http://codex.wordpress.org/Customizing_the_Read_More it talks about removing the "read more" link. Its states:

To remove the teaser:

Change the_content(); in your index.php to (i.e., the second parameter controls this):

the_content('',FALSE,'');

I don't see "the_content" in my index.php file. I looked at both the child and parent index.php file.
To remove the teaser:

Change the_content(); in your index.php to (i.e., the second parameter controls this):
the_content('',FALSE,'');

Open in new window

0
 

Author Comment

by:Trevor Local
ID: 40225930
I'm seeing some other posts about creating code in the child theme style.css to remove the "read more", but I don't see the actual code to insert.
To remove the teaser:

Change the_content(); in your index.php to (i.e., the second parameter controls this):
the_content('',FALSE,'');

Open in new window

0
 

Author Closing Comment

by:Trevor Local
ID: 40254936
thank you
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Nothing in an HTTP request can be trusted, including HTTP headers and form data.  A form token is a tool that can be used to guard against request forgeries (CSRF).  This article shows an improved approach to form tokens, making it more difficult to…
This article discusses how to implement server side field validation and display customized error messages to the client.
The purpose of this video is to demonstrate how to update a WordPress Site’s version. WordPress releases new versions of its software frequently and it is important to update frequently in order to keep your site secure, and to get new WordPress…
The purpose of this video is to demonstrate how to set up the permalinks on a WordPress Website. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php : Go t…
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question