Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

AppleTV is not accessible using AirParrott on SonicWall wireless network.

Posted on 2014-07-28
10
705 Views
Last Modified: 2014-07-30
I have a client who purchased an Apple TV for their conference room. They want to be able to mirror their display from their laptop to the TV during meetings. The network wireless is run from a SonicWall TZ215W. The wireless is bridged to the LAN.

When we connect the Apple TV and Laptop via LAN Ethernet AirParrott works great. but when we try and do the same using the wireless on both devices AirParrott cannot mirror to the Apple TV. If I turn off the SoncWall wireless and use a consumer store bough access point it works. So something in the SoncWall is not allowing communication and it is specific to the wireless.

I have turned on multicast and enabled IPHelper with mDNS.

Thoughts?
0
Comment
Question by:mthsupport
  • 5
  • 4
10 Comments
 
LVL 16

Accepted Solution

by:
Joshua Grantom earned 400 total points
ID: 40224920
Multicast address needs to be

224.0.0.251/24 and make sure you allow the Apple Bonjour Service over UDP Port 5353
0
 
LVL 16

Expert Comment

by:Joshua Grantom
ID: 40226520
Any luck?
0
 

Author Comment

by:mthsupport
ID: 40227896
Haven't had a change to try it yet.

Why would I need that multicast address policy?

Also this is the integrated wireless that is bridged to the LAN so all traffic is allowed. No port blocking at all.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 16

Expert Comment

by:Joshua Grantom
ID: 40227934
oh ok, Do wireless clients get the same IP subnet as the DHCP server?
0
 

Author Comment

by:mthsupport
ID: 40228209
yes they do. And if I wire everything it works. It is only on the wireless that I have the issue.
0
 
LVL 16

Expert Comment

by:Joshua Grantom
ID: 40228240
Go into the Network Zones and edit the WLAN connection and make sure the check box for "Allow Interface Trust" is checked
0
 
LVL 2

Assisted Solution

by:Peter Wilson
Peter Wilson earned 100 total points
ID: 40228548
Did you configure the IP Helper Policies?
Network > IP Helper page, find the Policies section.
Click the “Add…” button to add a new IP Helper Policy.
Configure the WLAN to LAN IP Helper Policy. The WLAN to LAN policy allows Bonjour discovery to work from LAN clients.
This will allow WLAN devices/systems to be discovered by LAN devices/systems.
Here's the Policy Configuration:

Protocol: mDNS
From: “Interface W0” (Tip: You can replace “Interface W0” with any specific Interface.)
To: “LAN Primary Subnet” or “X0 Subnet” (Tip: You can replace this with any specific Destination object. For example: X2 Subnet.)
Optionally, add a comment to the Policy

Then, configure the LAN to WLAN IP Helper Policy. The LAN to WLAN policy allows Bonjour discovery to work from WLAN clients.
The same effect but in opposite direction: LAN devices/systems are discovered by WLAN devices/systems.

Here's its Policy Configuration:
Protocol: mDNS
From: “Interface X0”
To: “W0 Subnet”
Again optionally, add a comment to the Policy.

Here things to note:
- IP Helper Policies do not allow the discovered services to bypass access rules. Access Rules must be in place between the two Zones in order to utilize discovered services.
- Two IP Helper policies are necessary to allow two-way discovery of services using Bonjour.
- The WLAN to LAN Policy allows LAN clients to discover WLAN clients.
- The LAN to WLAN Policy allows WLAN clients to discover LAN clients.

Lastly, configure the Access Rules:
Firewall > Access Rules.
Select the “Matrix” View Style. Select the WLAN to LAN intersection.
Note: By default, the WLAN to LAN Access Rule table contains a single rule that denies any traffic but since you bridged the Zones there shouldn't be such a rule.

Depending on your scenario, security-wise, either create a new rule or edit the default WLAN to LAN Deny rule. Change the Action to Allow. Click OK.

You will want to do this in both directions LAN > WLAN and WLAN > LAN.

Here's a list of ports used by Apple’s software products: http://support.apple.com/kb/TS1629
0
 

Author Comment

by:mthsupport
ID: 40230289
Okay here is what I did.

Fortunately, I had an available SonicPoint Ne.

First I disabled the integrated wireless on the SonicWall TZ215

Second, I setup the SonicPoint to be managed by the SonicWall per SonicWall documentation.

On the new Zone / Interface I enabled Multicast support.

I connected the Apple TV and my laptop to the new wireless network and viola it worked!!!!

Thanks for the feed back.
0
 
LVL 16

Expert Comment

by:Joshua Grantom
ID: 40230294
Very Nice!
0
 

Author Closing Comment

by:mthsupport
ID: 40230295
I gave Josh the most points because he responded the most. Thanks for the detailed reply Peter.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
I had an issue with InstallShield not being able to use Computer Browser service on Windows Server 2012. Here is the solution I found.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question