New Hard Disk doesn't show up under Western Digital's Data Lifeguard Diagnostics

Hello experts,

I just installed a WD Red 3 TB HDD on a Startech.com Enclosure (SAT3510BU3) and initialized/partitioned the drive to the following settings:

MBR, NTFS, Primary and 1 Partition

The drive shows up in "My Computer" and "Disk Management". For some reason, it doesn't show up on Western Digital's Data Lifeguard Diagnostics so I'm unable to run diagnostic tests before copying my data to the drive.

Any comments would be appreciated. Thanks in advance.
focus15Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nobusCommented:
>>  For some reason, it doesn't show up on Western Digital's Data Lifeguard Diagnostics  <<  are you running it from within Windows ?
if not, it may just not have the correct driver
0
focus15Author Commented:
Yes, nobus. Thanks. What should I do then? :(
0
rindiCommented:
First, as it is over 2TB in size, you should make it a GPT disk, or you will only have 2/3 of it's total space available to you. MBR only supports up to 2TB max.

Second, run the diagnostic with the disk connected directly to a SATA connector of your PC, not with an enclosure in between.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Gary CaseRetiredCommented:
As rindi noted, you should re-initialize the disk and make it a GPT disk.   Any drive > 2TB neeeds to use GPT to see the full size.

Data Lifeguard should see the drive okay regardless of whether it's connected via a direct SATA port or a USB bridge device (there are some restrictions on the testing with bridge devices) ... although if you have a bridge device that doesn't have > 2TB support that may explain why it's not being seen correctly -- so I agree you should try it with a direct SATA connection.
0
focus15Author Commented:
Thanks rindi and Gary.

I tried with GPT first but since that didn't work, I changed it to MBR.

I'm a bit confused by MBR and GPT. All my other drives (2.5 TB and 3 TB) are MBR drives but that didn't stop them from displaying the full available space of the drives.

Does that mean even though they show the Free Space as 2.72 TB, the HDD is maxed out at 2 TB?

MBR Drive - Properties
After changing the MBR drive to a GPT Drive:

GPT Drive - Properties
Even after changing, the drive is unrecognized by Lifeguard..

The enclosure previously had another 3 TB WD Red Drive which was recognized by WD's Lifeguard without any issues.. :(

I'm not sure if it's worth calling WD. A couple of times I called them, I got nowhere...
0
nobusCommented:
if  the nclosure worked before - it should work now too -unles it failed in between; can you test it with the drive that it worked with?
i also have a 3 TB (seagate) - no gpt necessary (is that not only required when booting from it?)
but you can always try a direct connection with Sata  to test it
0
rindiCommented:
Diskmanagement will see the full space of the disk if it is an MBR disk, but you can only use 2TB of it. When you try creating a partition, you will be able to create4 one with 2TB size, and the rest of the space will just not be available.

It looks like the case just doesn't work with that disk. So if you want to run the diagnostic, connect it directly to the PC for that. If the disk works there, get another case.
0
focus15Author Commented:
Thanks nobus and rindi.

I just tried the previous 3 TB Red drive that was detected by WD Lifeguard 2 days ago and it doesn't now! :( So, I just ordered the same enclosure to see if that would work.

This is total size of files in a WD Elements 2.5 External HDD running MBR.. The total file size looks about the size of the drive.

WD Elements 2.5 TB HDD
I wonder if there's a way to put MBR and GPT logic to test/rest :(

Also, since we're on the topic about SATA connections, could you guys please recommend a cable from Monoprice?

I created a separate question for this:

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_7/Q_28486381.html

Thanks again for your help.
0
Gary CaseRetiredCommented:
"... I'm a bit confused by MBR and GPT. All my other drives (2.5 TB and 3 TB) are MBR drives but that didn't stop them from displaying the full available space of the drives. "  ==>  Don't be confused at the difference between the size of the DISK and the size of the PARTITIONS you can create on the disk.   You can't create a partition larger than 2TB on an MBR disk.    With GPT there's no limit [actually there is, but it's WAY beyond anything you're going to encounter anytime soon :-) ].
0
focus15Author Commented:
Thanks for the clarification, gary.. Appreciate it.

As mentioned above, I have only 1 partition on my Elements 2.5 TB disk and the total size of all files comes around 2.5 TB.. Since it is an MBR drive, the total size should be around 2 TB then, right?

How can the size of files exceed the size of the partition?

Or, am I misunderstanding something here? :(
0
focus15Author Commented:
So, I found out that when the hard drive is connected directly to an USB port of the desktop, WD's Lifeguard can most likely detect it.

If the HDD is connected to an USB hub, that's when it goes undetected.

Thanks so much everyone for your time.. Greatly appreciate the help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.