Can't add .vmx file to ESXi 4.1 stand alone installation

Posted on 2014-07-29
Last Modified: 2014-07-30
Hi all.
I have copied a master imaged from a vsphere 4.1 cluster environment to a data store for a single ESXi 5.5 installation. When I right click the .vmx from within the data store and add to inventory it works just fine ie. it lists the machine name. Then when I power it on I chose the option "I copied it". but then I get an error message - please see attachment. Is this an error or can I not export a machine from 4.1 into 5.5?
I have included two attachments. the first details the error and the second shows the files in the data store.

And, when I try to copy the *.vmdk file to another folder in the data store I get an error message "a specified parameter was not correct. name too long or wrong type.

Many thanks
Question by:Jason Thomas
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 5
LVL 120
ID: 40226252
this may be a better option of transfer

see my EE Article

Part 10: HOW TO: Backup (Export) and Restore (Import) virtual machines to VMware vSphere Hypervisor 5.1 for FREE

But you should be able to transfer the files with no issues....

how was it transferred...

the error indicates either snapshot of vmdk issue (corrupt)

V2V using VMware vCenter Converter Standalone 5.5

HOW TO:  P2V, V2V for FREE - VMware vCenter Converter Standalone 5.5

Author Comment

by:Jason Thomas
ID: 40226268
Hi Andrew,

If I run up the convertor how do I point it at a VM in a ESXi 4.1 cluster? And, I guess I need to make a copy of it first to keep the original?

Author Comment

by:Jason Thomas
ID: 40226306
Hi, forget that I have worked it out but here now is my problem.
On the 4.1 production cluster we have one Win2008 Template. I navigated the data store, created a new folder and copied the Win2008 files into the new folder.
When I copied off the new folder is when the corruption occurred but heres what I try next.
Using VM convertor I navigate to the vSphere cluster, authenticate and the search for templates but I only see the original. So my copying the files didn't create a new template clearly. So, I need to V2V the template but a copy of it so that it is still available on the cluster - any ideas?
Building an interactive eFuture classroom

Watch and learn how ATEN provided a total control system solution including seamless switching matrix switch, HDBaseT extenders, PDU, lighting control to build an interactive eFuture classroom.

LVL 120
ID: 40226428
You can only convert a VM, so use Deploy from Template to a VM.

and then either Export to OVF or V2V using Converter.

Author Comment

by:Jason Thomas
ID: 40226811
So have my servername under the templates folder in vsphere. I don't see an option to deploy from template?
LVL 120
ID: 40226824
Do you have vCenter Server to create templates?

Author Comment

by:Jason Thomas
ID: 40227049
Hi, its ok I found it, on 4.1 it's called Clone to New Virtual Machine, is that what you meant? I'm currently doing a V2V from production vsphere to a standalone ESXi host running 5.5 - slow, 15 minutes in and only 4%. Get back to you when done.
LVL 120

Accepted Solution

Andrew Hancock (VMware vExpert / EE MVE^2) earned 500 total points
ID: 40227079

Clone to virtual machine will do, it converts the template to a VM, which can then be copied, V2V, OVF Exported or what ever...

as for slow....have an article for that...

HOW TO: Improve the transfer rate of a Physical to Virtual (P2V), Virtual to Virtual Conversion (V2V) using VMware vCenter Converter Standalone 5.0

HOW TO: FAQ VMware P2V Troubleshooting

it's a data move, I generally do not watch them, I go off and do something else......

depends on many things, network, datastores speed of read and write...

Author Comment

by:Jason Thomas
ID: 40227691
I thought about your article on speeding up the v2v but I thought - does removing the ssl  apply  here considering the source is on 4.1? Isn't the asleep a feature of 5.5? I'm probably wrong

Author Comment

by:Jason Thomas
ID: 40227694
Isn't the ssl a feature of 5.5?
LVL 120
ID: 40227704
it disables the SSL encryption of VMware Converter, which can slow down transfer.

Author Closing Comment

by:Jason Thomas
ID: 40228624
Thank you.

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
DC freezes when running VMTools 15 64
Which vmware product do I need. 8 64
VSphere Center 16 58
Windows Deployment Services 6 57
In this article, I show you step by step with screenshots to assist you - HOW TO: Deploy and Install the VMware vCenter Server Appliance 6.5 (VCSA 6.5), with some helpful tips along the way.
Is your company's data protection keeping pace with virtualization? Here are 7 dynamic ways to adapt to rapid breakthroughs in technology.
Teach the user how to use configure the vCenter Server storage filters Open vSphere Web Client:  Navigate to vCenter Server Advanced Settings: Add the four vCenter Server storage filters: Review the advanced settings: Modify the values of the four v…
This Micro Tutorial steps you through the configuration steps to configure your ESXi host Management Network settings and test the management network, ensure the host is recognized by the DNS Server, configure a new password, and the troubleshooting…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question