• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 238
  • Last Modified:

VS2008 - How to uncheck a solution

Hi experts,

I am new to all this.

Maybe someone can answer:
I am just trying to get acquainted with how you "Check Out" and "Check In" a solution or package.

Right now I have this red check mark on a .dtproj file.
I do not want this red check mark and would like to start the process of "Check Out" all over again?
I have read some information on this issue, but all seem to be confusing to me.

How do I not save back to the team foundation and get rid of the red check mark?

From what I understand so far, please correct me if wrong.  You first have to "Check Out" the solution and then you can "Check Out" the package that is within that solution?

After removing the red check mark:

I clean up my local drive by deleting all folders.
I goto the Source Control Explorer and find the correct Solution (.sln) and do a right click "Check Out"
Then I go to the subfolder and find the package (.dtsx), right click "Check Out"
At that point my "Solution Explorer" should be populated with what I just "Check Out".  If not then right click inside the "Solution Explorer" and do a get option.

Please help and thanks
0
Amour22015
Asked:
Amour22015
  • 10
  • 5
1 Solution
 
ValentinoVBI ConsultantCommented:
What you're looking for is called "Undo checkout".  Open Source Control Explorer, locate the file, right-click it and you'll see that option.

If you just need to change a package you only need to check out the package.  The solution only needs to get checked out when you need to make changes to it, such as adding a new package or removing an existing one.

To ensure that you're working with the most recent version you should use the "Get Latest Version" functionality.  That is done by right-clicking the project folder in Source Control Explorer.

More info: Open Solutions and Projects from Version Control
0
 
Amour22015Author Commented:
Ok,

I right click the .dtsx file and there is no "Undo checkout" there is a "Undo Pending Changes" this time the red mark went away.

Next:
I deleted my local copy.  I deleted the whole folder.

Then:
I reopen VS2008 and goto the "Source Control Explorer" I find the .dtsx file that I want: do a "Get latest version" and then select a "Check Out for Edit".  I can now see a red check mark.

But:
In the Solution Explorer nothing comes up

I tryed right clicking within the empy "Solution Explorer" and nothing happens.

What am I doing wrong?

Please help and thanks
0
 
ValentinoVBI ConsultantCommented:
Right, it's indeed called "Undo Pending Changes", sorry for the confusion.  (I don't have it in front of me to verify.)

You need to do "Get Latest Version" on the whole folder, not just the dtsx.  Or double-click the .sln file, this will get a local copy first (which is like "Get Latest") and then it will open it in Solution Explorer.
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
Amour22015Author Commented:
Ok,

Looks like that does not work.

I did a "Get latest Version" on the whole folder and then a "Get latest Version" and a "Check Out" on the .dtsx file (which is the SSIS package).

Please help and thanks.
0
 
Amour22015Author Commented:
Ok,

So I did a "Check Out" for the whole folder and then a open project.  That brought the items into the Solution Explorer but all the packages are now "Checked Out" have a red check mark.  I just want one with a red check mark not all of them.

Before when I just did a "Get latest version" I tryed "Open Project" and there was nothing to open.

Seems like I am still doing something wrong.

I don't want the all to be "Checked Out" just one.  The one I want to work on.

Please help and thanks
0
 
ValentinoVBI ConsultantCommented:
In Solution Explorer you can right-click the ones you don't want to check out and choose Undo Pending Changes.  That should bring you to the desired situation...
0
 
Amour22015Author Commented:
Ok,

Now the problem is that it populates the Solution Explorer, but does not have the correct .dtsx file in that list.  So I try the: Right click and select the add existing package option within the Solution Explorer and it will create it like Name(1).dtsx.  It is not bring in the correct package Name.dtsx.

What am I doing wrong?

I also tryed just bring in the .sln (solution) (Get latest version), (Check Out for editing) and again the list in Solution Explorer does not have the name.dtsx file that I am looking for.

Please help and thanks
0
 
ValentinoVBI ConsultantCommented:
The "Name(1).dtsx" is indeed an annoying issue.  The easiest fix in your case is to start all over again: undo all pending changes, delete all local files and get them again through Source Control Explorer by using Get Latest Version.
0
 
Amour22015Author Commented:
Currently,

I am using the link:
stackoverflow.com/questions/2002088/the-project-file-has-been-moved-renamed-or-not-on-your-computer

and this sounds more like the problem I am having.
but it mentions to not do the "Get latest version" because on the server it thinks that I already have the latest version.

basically it say that the server is confused about the correct mapping I have on my local drive.
which I don't have anything on my local drive because I have deleted that.

What is nice about this is that I did not have any changes on my local drive.
All the work I have done already was sent back to the server.
I did work on a project but have already done a "Check In" to update that project.
I quess this it the reason I see my project on the "Souce Control Explorer" tab?

This looks like it is going to be a good posting for future readers of the ExpertsExchange?
If I get into this problem then there is sure to be others.



Please help and continue to keep up on this post, thanks
0
 
ValentinoVBI ConsultantCommented:
"I quess this it the reason I see my project on the "Souce Control Explorer" tab?"

Source Control Explorer displays everything that is stored in TFS (on the server) to which you've been given access rights.  So it's normal that you see things in there which you've checked in previously.

Did you try what I wrote in my previous comment?  It's not clear anymore if you're still facing an issue or not.  If yes, which one?
0
 
Amour22015Author Commented:
Yes,

even after I deleted the folder locally I am still getting the:
"PackageName(1).dtsx"

I guess that is because what I am doing:
Right click the .sln within the Solution Explorer
Select Add existing
The menu that comes up says that it will get a copy of the SSIS Package.

But I don't want the copy.

Why is it so hard to just goto the server (Source Control Tab)  and select the one that you want to work with and bring that into the Solution Explorer?

Why does all the other .dtsx files come over, but the one I want to work with?  There must be something I am doing wrong?  Why when I do the "Get latest version", "Check Out for edit" on the folder all but the one I want to work on is not within the Solution Explorer?  Maybe I have to let VS2008 know that that is contain within that folder?  Yet when I look at this on the server that .dtsx is within that folder.

Maybe my co-workers know that it is just a copy of the .dtsx file?  I cannot see what they are doing because they are not local to me.

So yes I still need help.
0
 
Amour22015Author Commented:
Ok,

This is what is going on with my SSIS package at this point:
http://www.bidn.com/forums/microsoft-business-intelligence/integration-services/369/package-doesn-t-show-up-under-ssis-packages-when-using-file-save-copy-of-package-as

But one should not have to do this when all other package.dtsx are showing up.

There must be a way to update so that the "Check Out" knows that there is another package.dtsx file to bring over to the Solution Explorer?

Please help and thanks
0
 
Amour22015Author Commented:
Ok,

There is the same problem out there:
http://social.msdn.microsoft.com/Forums/vstudio/en-US/a3eb5bbf-03cc-4820-8ab5-eaf282d2076d/package-load-failure-visual-studio-2008?forum=vssetup

I don't have permission to do:
Uninstall .NET Framework 3.5 SP1 and reinstall it.

So I have to wait for someone else to do this and then I will see if the problem goes away and then I will update the post.

Thanks
0
 
Amour22015Author Commented:
Ok,  

Just wanted everyone to know that I solved the problem.

Just do:

Check Out the .sln file
Check Out the .vsssn file
Open the project
Project comes up within the Solution Explorer

On the .sln file
right click
select the "Add existing package"
Menu comes up "Add Copy of Existing Package"
Package location: File System
find the package.dtsx
<ok>
so a PackageName(1).dtsx shows up
just rename it to what you want

Check In the .sln file
Check in the .vsssn file

all should be ok...
0
 
Amour22015Author Commented:
Great thanks for helping, see final post to show solution.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 10
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now