Solved

Reverse DNS issues but related to Cisco ASA Firewall

Posted on 2014-07-29
4
733 Views
Last Modified: 2014-08-04
So I have recently upgraded my Exchange server from 2003 to 2010 and mail seems to be flowing perfectly however the reverse DNS doesn't work

In my firewall (cisco asa) I have the following NAT configuration for Inside network:

Static - Source (192.168.1.8) - Interface (Outside - 178.10.123.123) - Address (Webmail = 178.10.123.30)

With this NAT rule I can run ActiveSync, Webmail, etc.. all from outside of the network however my Reverse DNS doesn't work but if I change it too:

Static - Source (192.168.1.8) - Interface (Outside - 178.10.123.123) - Address (reverse dns = 178.10.123.254)

Everything works like a charm for Reverse DNS but now my Webmail and ActiveSync no longer work from outside.

If I try to create 2 of those NATS one for webmail and one for reverse it tells me that "an overlapping error occurred and cannot be completed"

Before on my old server I had OWA and Exchange on two separate boxes, but now that there all on one box I cannot figure this out.

Thank you for all your help
0
Comment
Question by:Neogeo147
  • 2
4 Comments
 
LVL 6

Expert Comment

by:Matt
ID: 40229001
Do you have anything logged on ASA when you try to do reverse DNS?

Try to do reverse DNS and be at the same time connected to ASA box... Submit logg here, so we can see where is the catch...
0
 
LVL 20

Expert Comment

by:rauenpc
ID: 40229265
It would be helpful to get a scrubbed config. Also, inbound nat rules don't necessarily mean that the outbound traffic will use the same IP address. I would hop on the server and go to a site like www.ipchicken.com or something that shows your external IP address and you may find that outbound traffic uses a different public IP than the inbound traffic.
0
 

Accepted Solution

by:
Neogeo147 earned 0 total points
ID: 40230605
Ok so I got it fixed

First I had to create a Static NAT rule with the following:

Original:

Interface = Inside

Source = 192.168.1.8

Translated:

Interface = Outside

Use IP address = 178.10.123.30

Enable PAT:

TCP

Original Port = 443

Translated Port = 443

Then I created another Static NAT rule with the exact same settings as above except for the PAT ports = 80

Then I had to create a Dynamic Policy NAT rule with the following:

Interface = Inside

Source = 192.168.1.0/24

Destination = any

service = tcp/smtp

Translated from global pool of dynamic translation:

Interface = Outside

Addresses Pool = 178.10.123.254

Now everything works perfectly
0
 

Author Closing Comment

by:Neogeo147
ID: 40238535
I fixed this myself, this is the correct way in making it so you can receive mail to your Barracuda spam and virus firewall and be able to send out on another public IP with Reverse DNS working perfectly
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Suggested Solutions

Resolve Outlook connectivity issues after moving mailbox to new Exchange 2016 server
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now