Exchange 2013 activesync asking for domain name

Hello.
i have exchange 2013 fully working  , autodiscover is working fine as well.
my problem is with mobile devices asking for username , domain , password .... when trying to configure the email accounts.
i have added the \ and domain under basic aut setting in iis .
this is working only when the email address name is the same as the user name login name in AD
let say that my email is contoso@domain.com the settings are getting completed.
if my email is microsoft.contoso@domain.com i need to provide the missing setting , domain , password , username...

thanks in advance.
Regev.
restartpc12Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

hecgomrecCommented:
All access to services on 2013 is perform on the server using OWA, remember 2013 uses proxy by default.

Open your EMC on Exchange 2013, look for servers and select "virtual directories", select your client access server and open the properties for owa (Default Web Site); under authentication change "Use form-based authentication logon format:" to  Username only and type your default domain.  Restart or reset your IIS.
0
restartpc12Author Commented:
Hi,
Thank you for your reply,
This is my current configuration .
User name only , my domain .
Just to make sure , my prblem is my cellular mobile phones (ios and android) not OWA.
Thanks.
0
hecgomrecCommented:
Did you migrated from 2003?

Are you having problems with Android or iOS or both?

Are you setting the phones using WiFi (within the organization) or carrier data signal?

Is your OWA internal and external access the same?

Your OWA combination is Username/password?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

restartpc12Author Commented:
The first server was 2003, now i am migrating from 2010.
Both of mobile devices.
I am using cellular data signal or wifi outside the organisation.
Owa inside and outside are the same
The combination is user name only

If i am trying to connect a user that his user name and email are the same it is working fine, if they are different it is not.
Thanks
0
hecgomrecCommented:
This could be the issue:

One of your servers is running authentication on UPN instead of Username only.

If you have 2013 as your main server (DNS MX records and firewall pointing to your server) it will take the credentials and passed to the 2010 if the user mailbox is on that server so if the authentication is different there it will fail.

If you open your EMC on 2013 and go under server, virtual directories you will see both server for each of the directories (website), make sure both EAS and OWA have the same settings, if you do changes remember to restart the virtual directory for the changes to take effect.

Now for added troubleshoot, still on your 2013 in the EMC under mobile, devices access create new rules to accept Android, BlackBerry and iPhone families.
0
restartpc12Author Commented:
i think you misunderstood my proble.
first , the settings are the same.
second , the problem is
let say my email is "user@contoso.com" and my username is "user" , in this case it is working fine no matter where the mailbox is (exchange 2010 or 2013).
in case that my email is "user.lastname@contoso.com" and my user name is "userl" the devices are not compliting the settings and i need to put it manualy ( user name , doman , server).
thanks.
0
hecgomrecCommented:
Oh this is normal... kind of!!!

The process will try always try to use the first part of the email as your username.  I have encounter this error but the opposite, when the alias of the username is not even similar to the email but this was ok for security reasons.
0
restartpc12Author Commented:
So, is there a way to make it work with this settings?
0
hecgomrecCommented:
Unfortunately, I don't know how, if the alias (created by either policy or manual) doesn't match the user name then it won't work, remember this is a procedure the mobile devices have built-in... they assume the username from the first part of the email therefore if it is something else the device is program to ask for full credentials to try to establish the connection.

Usernames matching with the emails will pass, if you have everything configured properly but if they don't match then you most do it manually.

At least is not for all of them... I had a client who requested not to have autodiscover for his organization and one must enter domain\username\password\server info for every user.

Sorry I can't help you more...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
restartpc12Author Commented:
Ok.
Thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.